Sign in with
Sign up | Sign in
Your question

New 6670 looks bad over HDMI

Tags:
  • Graphics Cards
  • HDMI
  • Cable
  • Graphics
Last response: in Graphics & Displays
Share
January 17, 2013 9:58:54 PM

I just got a Gigabyte 1gb ddr3 6670 in the mail. I am upgrading from a 6600gt that I had hooked up to my TV via a DVI-> HDMI cable and optical for sound. One of the reasons I decided to upgrade my video card was to have a single cable solution for HD audio/video. I hooked it up via HDMI, and the picture is awful! The text is...not blurry...but definitely not sharp, colors are not quite right, and my desktop is WAAYY oversharpened. It honestly looks like it would if I was just using the generic windwos video drivers, but I am positive I have the right drivers, and I have uninstalled and reinstalled them twice.

I Tried hooking up the new 6670 via my old DVI->HDMI cable, and everything looks great, just as it did before; sharp, clear text; nice colors. Using the DVI output, my overscan is set to 0% (which it should be, correct?), With just the straight HDMI cable, I need to set it three has marks to the left of 0% to get it to work.

I am hooked up from Computer (6670) -> Onkyo HT-R390 Receiver -> 1080p TV. AMD Vision center detects my display as HT-R390.

Any ideas on what is wrong here?

More about : 6670 bad hdmi

January 17, 2013 10:39:32 PM

I feel like if I could get the driver to NOT detect my receiver, that it might work. It seems like the driver is detecting this as a totally different kind of source because it is straight HDMI instead of DVI->HDMI. Is there any way to disable this? Or is what I am thinking correct, or even possible??
m
0
l
a b U Graphics card
January 17, 2013 11:12:01 PM

My opinion hooking a pc up to a tv doesnt look as good as a pc monitor...Its blurry to me
m
0
l
Related resources
January 17, 2013 11:15:21 PM

determinologyz said:
My opinion hooking a pc up to a tv doesnt look as good as a pc monitor...Its blurry to me


But it looks great over DVI, why not over HDMI? Not using the TV for my monitor is not an option.
m
0
l
January 17, 2013 11:19:40 PM

It seems as if it's mainly a scaling issue...because the source is HDMI, the receiver, and thus TV see it as such, and enables overscan. When I use DVI, it is receiving a different signal (although I thought the two should be identical?), and doesn't enable overscan, and allows the signal through unchanged. I have never ran into these problems before, this is just what I have gathered from reading around on the internet. Is there any way to fix this??
m
0
l
!