Sign in with
Sign up | Sign in
Your question
Solved

I REALLY need help making my graphics card work!!!

Last response: in Graphics & Displays
Share
January 17, 2013 11:07:31 PM

Hello everyone. I have an HD 7770 Vapor X Ghz edition etc etc. The card is GOOD, I know this because I put it in my own computer and it worked fine. However, I put it into my friend's computer and it won't produce video output. But the computer beeps 1 short time indicating that it DID POST. UGH! Here is a list of what I've done.
I have installed drivers for the 7770 while the old GPU was installed.
I have reseated it.
I've made sure the PSU is adequate. (It's a nice psu, and 520w. Not the issue.)
I've reset the CMOS.
I've turned off/on the pc many times with the new GPU in.
I've taken out all the RAM's but 1 stick.


I have NO IDEA what is going on and why this card won't work in my friends pc! Everything says that it should work!!
I would really really really (times a thousand) appreciate it if you guys could help me get this thing working. I've done everything I can think of to make it work.
January 17, 2013 11:29:06 PM

This is a time sensitive thing so any quick responses would really help!!!!!

Best solution

a b U Graphics card
January 17, 2013 11:48:39 PM
Share

Have you disabled the integrated graphics in the bios? Try another slot if available, and a different power connector.
Related resources
January 17, 2013 11:59:24 PM

Best answer selected by ArcticWonder.
January 17, 2013 11:59:53 PM

I did that and it worked!!! I'm still confused because I didn't have to disable the integrated graphics when the OLD graphics card was in, but whatever it works and we're happy so thanks!
!