Sign in with
Sign up | Sign in
Your question
Closed

Sapphire Radeon HD 5970

Last response: in Graphics & Displays
Share
January 18, 2013 4:23:19 AM

I just inherited one of these from a buddy of mine. When I ran 3DMark 11. I got a score of around 3700. According to all the charts I should be seeing closer to 7700. Any idea what is going on? Is there a setting that I need to click in order for the card to run in pseudo-crossfire mode. I assume that it is automatically detected as 2 cards (in one) but it appears that maybe it is only measuring it as a single gpu.

More about : sapphire radeon 5970

a b U Graphics card
January 18, 2013 5:05:23 AM

What's the rest of your PC specs? Could be a bottleneck issue
Score
0
January 18, 2013 12:20:38 PM

Oh yea... I should have included specs. It's a new build:

MSI Z77A-G41 LGA 1155
Intel Core i7-3770K Ivy Bridge 3.5GHz (overclocked to 4.0GHz)
G.SKILL Ripjaws X Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1866 (PC3 14900)
Kingston HyperX 120GB SATA III (that has Windows 7 and AVG antivirus on it)
Crucial 512GB m4 2.5-inch SATA III SSD (that has all my games on it)
and of course my Sapphire Radeon HD 5970

Score
0
Related resources
January 18, 2013 12:26:44 PM

Here is something else that might be helpful. I just installed CPU-Z and under the Graphics tab it shows 2 HD 5900 series cards (which I assume is correct since that is what the 5970 is). But, the 1st device shows the following under Clocks:
Core - 156 MHz
Memory - 300 MHz

Under the 2nd device it shows:
Core - 724 MHz
Memory - 1000 MHz

Is that how it should be or is there a problem with the 1st one?
Score
0
a b U Graphics card
January 18, 2013 12:27:23 PM

Can you open GPU-Z and check whether it reports 2 GPUs or not? I believe it should have something like Radeon HD5900 series and 2 GPUs enabled

EDIT: ^Forget it, you've already done that apparently. I believe the 156MHz is because it's in idle mode. If you play a game or whatever, the clockspeed will raise. If you'd like to make sure they both run at default speed, try using MSI Afterburner and raise the clockspeeds manually
Score
0

Best solution

a b U Graphics card
January 18, 2013 1:03:06 PM

I own an HD5970 and yes you should be getting around 7000 odd in the benchmark. Have you installed a clean copy of Catalyst? I sounds like only 1 gpu is enabled. Check nothing is set under profiles as this can sometimes be used to disable XFire.
Share
January 18, 2013 1:30:26 PM

I have the latest (13.1) Catalyst running and I've OC'd both gpu's to 800 and 1250. Additionally, most of the games I am running are very laggy. So, I think there is definately something strange going on. Can either of you (or anyone else) recommend any software that will give accurate info on my system that might help id the problem?
Score
0
a b U Graphics card
January 18, 2013 2:45:08 PM

I think i'd set your clocks back to default first. Try using MSI Afterburner to discover your temps and check they are within limits. The only game i've ever had that's laggy is FC3 which suffers from microstutter. I can run BF3 almost maxxed on 4aa in the region of 50 - 60fps.
Score
0
a b U Graphics card
January 18, 2013 2:46:40 PM

Incidently i'm running the 12.1 Beta drivers. I've not downloaded the latest yet.
Score
0
January 25, 2013 12:00:46 AM

Best answer selected by jconway1968.
Score
0
!