Sign in with
Sign up | Sign in
Your question
Solved

Computer no longer connects to Internet once it's removed from domain

Last response: in Networking
Share
February 23, 2012 9:28:53 PM

I am having a very strange issue with my computer. I have a laptop which has Windows XP Professional SP3 installed. I recently started using this laptop for testing purposes by adding it do a domain. The domain ran using VMWare Player, and the domain was installed on the Windows Server 2000 SP4 operating system (OS). In other words, I was using a virtual Windows Server 2000 OS domain, and I used my desktop computer to run this virtual domain. I decided to remove the laptop from this domain using the following steps:

Right-click on My Computer --> Select Properties --> Computer Name tab.

Once there I removed it from the domain, I added it back to the workgroup, which is named MSHOME. I restarted the computer as instructed, and once I logged back on, I was no longer able to access the Internet. I checked my network settings by right-clicking on the Properties tab of my wireless local area connection icon on the laptop. I removed the preferred DNS server listed, and I reset the options as they were when the laptop was part of the MSHOME workgroup before. I also have the connection set to obtain an IP address and DNS server address automatically. I am able to get a valid IP address, and the DHCP and DNS information was my modem’s IP address. I am also able to successfully ping the desktop computer’s IP address, my loopback address, and my modem’s IP address. However, I did notice that I was not able to ping any websites, and the tracert command failed. I received this error message when I used the command tracert www.yahoo.com:

Unable to resolve the server name www.yahoo.com

I tried this command using several other websites, and I still received the same error. The desktop computer has no problem connecting online, it is just the laptop. I took the following steps in order to resolve this issue:

1. Released and renewed the IP address.
2. Reset tcp/ip by using this command: netsh int ip reset reselog.txt
3. Reset winsock by using this command: netsh winsock reset. I restarted my computer as instructed, and still no Internet connection.
4. Flushed the DNS cache by using this command: ipconfig /flushdns
5. Registered DNS using this command: ipconfig /registerdns

These steps did not resolve my issue. I disabled my firewall completely by using msconfig to make sure that it did not start up after my computer restarted. I also made sure that the Windows Firewall was disabled, and it was. Once I restarted my computer, and logged back on, the Internet connection still did not work. I decided to restart the computer in Safe Mode with Networking, and oddly enough the Internet connection works. I then decided to disable the services listed on the Services tab in msconfig, and I restarted the computer in normal mode. The Internet connection still does not work in normal mode. I have uninstalled the reinstalled the drivers for my wireless network card, and I still cannot get online. I used my Ethernet cable in an attempt to get online, and still no luck. The only way I can get the Internet connection to work in normal mode is if I do a system restore to a point before I removed the laptop from the domain. I also manually added an IP address, subnet, default gateway and dns server to the Properties tab of the wireless network connection, and it still will not work in normal mode. The Internet connection only works in Safe Mode with Networking now. I also performed a scan to look for any spyware and viruses, and the laptop was free of those. Does anyone have any idea what could be wrong here?

Here is the output when I used the command ipconfig /all command while in Safe Mode with Networking:

Windows IP Configuration
Host Name . . . . . . . . . . . . : shania
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Broadcast
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : gateway.2wire.net
Ethernet adapter Wireless Network Connection:
Connection-specific DNS Suffix . : gateway.2wire.net
Description . . . . . . . . . . . : 802.11G Wireless PC Card
Physical Address. . . . . . . . . : 00-D0-41-AF-F3-55
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.64
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.254
DHCP Server . . . . . . . . . . . : 192.168.1.254
DNS Servers . . . . . . . . . . . : 192.168.1.254
Lease Obtained. . . . . . . . . . : Thursday, February 23, 2012 4:39:51 PM
Lease Expires . . . . . . . . . . : Friday, February 24, 2012 4:39:51 PM
Tunnel adapter Teredo Tunneling Pseudo-Interface:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : FF-FF-FF-FF-FF-FF-FF-FF
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : fe80::ffff:ffff:fffd%4
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Disabled
Here is the output when I used the command ipconfig /all command while in Normal Mode:


Windows IP Configuration
Host Name . . . . . . . . . . . . : shania
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Broadcast
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : gateway.2wire.net
Ethernet adapter Wireless Network Connection:
Connection-specific DNS Suffix . : gateway.2wire.net
Description . . . . . . . . . . . : 802.11G Wireless PC Card
Physical Address. . . . . . . . . : 00-D0-41-AF-F3-55
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.64
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.254
DHCP Server . . . . . . . . . . . : 192.168.1.254
DNS Servers . . . . . . . . . . . : 192.168.1.254
Lease Obtained. . . . . . . . . . : Thursday, February 23, 2012 5:02:14 PM
Lease Expires . . . . . . . . . . : Friday, February 24, 2012 5:02:14 PM
Tunnel adapter Teredo Tunneling Pseudo-Interface:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : FF-FF-FF-FF-FF-FF-FF-FF
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : fe80::ffff:ffff:fffd%4
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Disabled
Tunnel adapter Automatic Tunneling Pseudo-Interface:
Connection-specific DNS Suffix . : gateway.2wire.net
Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : C0-A8-01-40
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : fe80::5efe:192.168.1.64%2
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Disabled

Best solution

a b D Laptop
February 24, 2012 2:34:44 PM

how about the Proxy setting under

Control Panel --> Internet Options --> Connections --> Setting button

make sure it is unchecked
Share
February 24, 2012 9:18:16 PM

Emerald said:
how about the Proxy setting under

Control Panel --> Internet Options --> Connections --> Setting button

make sure it is unchecked



Hi Emerald

I checked those settings, and everything there is unchecked. I even went far enough to do a Repair Installation of Windows XP, and that still didn't work.
m
0
l
Related resources
February 25, 2012 12:36:04 AM

I have resolved my problem. While my laptop was part of the domain, I made changes regarding the IP Security Policies by going to the Local Security Settings located under the Administrative Tools folder. I modified the Server (Request Security) Properties by right-clicking on this and choosing "Assign". Once I removed the laptop from the domain, I forgot to undo this change, and this caused me to lose my Internet connection when I placed the computer back into the MSHOME workgroup. I verified that this was the cause of my Internet connectivity issues by re-assigning the policy, and I lost my Internet connection again. I updated this post and posted an image of the local security to help anyone else who might have this issue in the future.




m
0
l
February 25, 2012 12:47:47 AM

Best answer selected by Shania1682.
m
0
l
!