Sign in with
Sign up | Sign in
Your question
Closed

New GPU, No Signal

Last response: in Graphics & Displays
Share
January 18, 2013 11:54:46 PM

Good day folks! To begin, I must say I'm a veritable greenhorn when it comes to computer modifications, so I apologize for whatever poor information I may give. I've also searched this site and visited http://www.tomshardware.com/forum/261145-31-perform-ste...

Anywho, onto the issue:

Issue:
I bought a Dell Inspiron 660 with Nvidia GeForce 1GB DDR3 GT620. I replaced the PSU with a 500w PSU (URL listed below) without issue, but when I replaced the graphics card with a Radeon HD 5770 (used and reliable), I get "no signal" to my monitor. I've tried multiple monitors, HDMI and DVI cables and no success. Furthermore, an odd incident sometimes occurs when after I remove the Radeon and reinsert the GeForce -- my computer gets stuck on the Dell logo and doesn't move on. There are no "beeps" and everything runs normally. Oddly enough, the problem seems to be remedied by starting the computer up without any cables in the GeForce and putting one in while the computer boots. This has worked three times so far, but it may very well be coincidence.

PSU: http://www.pcpower.com/products/description/Silencer_Mk...)

Troubleshooting:
* I tested the Graphics card on a different computer with success. The graphics card seems to work fine.
* I borrowed a stronger PSU (650w) and that did not work.
* I've removed all video drivers (aside from Intel HD Graphics).
* I've reseated the PSU cables and Graphics Card many times.


Some very basic details on my new computer:
Inspiron 660 Fast Track 0514
3rd gen Intel Core i5-3330 processor 3.0 GHz with Turbo Boost 2.0 up to 3.20 GHz
8GB DDR3 SDRAM, 1600MHz-2X4GB
Nvidia GeForce 1GB DDR3 GT620 Win8
2TB Hard Drive, 3.5", 7200rpm, SATA
Windows 8, 64-bit, English

Thank you very much for your time and consideration! Have nice weekend, everyone!

More about : gpu signal

Best solution

January 20, 2013 3:51:43 PM

If the new video card doesn't have UEFI bios you must disable secure boot and enable legacy or compatibility mode on your computer.

Details:
http://nvidia.custhelp.com/app/answers/detail/a_id/3156...
Share
January 21, 2013 12:18:52 AM

Best answer selected by Sigma13.
Score
0
January 21, 2013 12:19:17 AM

Thank you! That was perfect! Have a most excellent day!
Score
0
!