Far Cry 3 MSAA not working

I 've just installed Far Cry 3 and update patch 1.04, the driver I used is 310.90 from Nvidia.The performance is much higher than 306.97 but it seems that MSAA option in FC3 is not working.
If I set PostFx to low, then 0x, 2x or 4x MSAA give the same visual quality and same FPS, everything is horribly jagged.
If I set PostFx to medium, everything is not jaggy anymore and FPS drop about 30%.Again, changing MSAA setting give no performance hit or improve quality.
I search for it in the internet and very few people have this problem, most other have MSAA work correctly.Is this a game bug or driver issue ? How can I fix this ?
7 answers Last reply
More about msaa working
  1. revert to previous driver and check again
  2. redeemer said:
    revert to previous driver and check again

    I just change back to 306.97 and still the same problem.And with both driver, the character is "glowing dark" if SSAO or HBAO enabled.
  3. Check whether you have Enabled "Let the 3D application decide" in the Nvidia Control Panel

    Maybe you haven't enabled that.
    And using your Own settings through "Use the advanced 3D settings"
  4. Just try it, still doesn't work.Everything is jaggy unless PostFx is set to medium or higher.Even when I try to force AA through Nvidia Control, it still doesn't work.
  5. It works OK now.Actually, to have MSAA work I have to run farcry3_d3D_11.exe not farcry3.exe
  6. Ahh.. You must be Running the DX9 version.
    Switching to DX11 worked, Nice !
  7. Sumukh_Bhagat said:
    Ahh.. You must be Running the DX9 version.
    Switching to DX11 worked, Nice !

    Yes, farcry3.exe is the Dx9 version (unable to use MSAA) and still have DX11 in graphic option :fou:. Hope that they remove this in next patch.This makes everyone confused .
Ask a new question

Read More

Nvidia Performance Graphics