Sign in with
Sign up | Sign in
Your question

The Sims 2 does not start under user permission

Last response: in Windows XP
Share
Anonymous
September 4, 2005 3:24:36 AM

Archived from groups: microsoft.public.windowsxp.games (More info?)

Hi all

Starting The Sims 2 works fine under administrator permission. But logged in
as a user it results with the error message "Unspecified Error". This text
is not really helpful for me.
I'm using the german version of Windows XP Professional with SP2.

Thanks in advance for any help,
Andreas
Anonymous
September 4, 2005 3:24:37 AM

Archived from groups: microsoft.public.windowsxp.games (More info?)

Hi Andreas,

Update: I created this workaround solution in 2003, however since then there
has been a utility created to allow for Administrators to allow users to run games:
Please visit: http://www.palmersoft.co.uk/main.asp?content=runasuser

Original Workaround:
Some games will work with limited accounts after they have been installed and
run once either using an administrator account, or by temporarily changing the
limited user account(s) to an admin account in Control Panel / User Accounts,
just for the purpose of running the game the first time in order to be able to
install the necessary files and create the keys in the registry that it needs to
function, but may not be able to due to the restrictive nature of limited accounts.

If that mouthful doesn't resolve the issue, use the "Run As.." command instead:

1. Click Start / Control Panel / User Accounts / Create a New Account /
Name the Account: "able2play" (without quotes) / Next Pick: "Computer-
Administrator" & Click "Create Account";

2. Click on your new able2play account and Create a Password for it;

3. When your limited user wants to play a game that requires Administrator
privileges they can Right-Click the shortcut to that game / Click Run As... /
"The Following User": able2play and enter the password. Simple as that!

I know what you're thinking: That defeats the purpose of the limited user account.
To secure the "able2play" account so that it can't be used to logon to the computer:

First you can hide the account so that it won't show up on the Welcome Screen:
http://www.dougknox.com/xp/scripts_desc/xp_hide_users.h... (thanks Doug!)

Next add a shortcut to the windows logoff routine into the RUN key of the
able2play registry. I made a reg patch to simplify this process if you wish to use it:

4. Logon to the "able2play" account,

5. <ONLY RUN THIS PATCH USING THE "ABLE2PLAY" ACCOUNT>
Save this patch to your drive and then doubleclick it to install it to your registry.
http://www3.sympatico.ca/nibblesnbits/OnlyRunUsingAble2...

or

*Instead of using the reg patch, click Start / Run / regedt32 / browse to:
[HKCU\SOFTWARE\ Microsoft\Windows\CurrentVersion\Run] and
Click Edit / New / String value / ValueName: logoff / Value data: logoff

From now on, if anyone logs on with the "able2play" account, the computer will log
them off immediately. They will not gain access to an administrators desktop! :-)

--
Cheers, Windows XP MVP Shell / User
Jimmy S. http://mvp.support.microsoft.com

Game FAQs: http://support.microsoft.com/default.aspx?scid=FH;[LN];gms
Visit my Zone.com / Gaming Helpsite: http://nibblesnbits.tk or Call / Contact
MS Support at: http://support.microsoft.com/default.aspx?scid=sz;en-us;top
My advice is donated "AS IS" without warranty; nor do I confer any rights.
_________________________________________________________




"Andreas Manz" <Andreas.Manz@gmx.ch> wrote in message news:%23ZrVs3MsFHA.1256@TK2MSFTNGP09.phx.gbl...
| Hi all
|
| Starting The Sims 2 works fine under administrator permission. But logged in
| as a user it results with the error message "Unspecified Error". This text
| is not really helpful for me.
| I'm using the german version of Windows XP Professional with SP2.
|
| Thanks in advance for any help,
| Andreas
|
|
Anonymous
September 4, 2005 3:24:37 AM

Archived from groups: microsoft.public.windowsxp.games (More info?)

There was a problem with that was supposed to be fixed with the patch or
with the University expansion which also patches it. Go to the Sims 2
official site and search. It is a Sims 2 problem.

"Andreas Manz" <Andreas.Manz@gmx.ch> wrote in message
news:%23ZrVs3MsFHA.1256@TK2MSFTNGP09.phx.gbl...
> Hi all
>
> Starting The Sims 2 works fine under administrator permission. But logged
in
> as a user it results with the error message "Unspecified Error". This text
> is not really helpful for me.
> I'm using the german version of Windows XP Professional with SP2.
>
> Thanks in advance for any help,
> Andreas
>
>
Related resources
Anonymous
September 4, 2005 8:02:23 AM

Archived from groups: microsoft.public.windowsxp.games (More info?)

When is this message shown? When the game is booted? Once you are
playing? More details please.


--
Glennw
------------------------------------------------------------------------
Glennw's Profile: http://forums.techarena.in/member.php?userid=8644
View this thread: http://forums.techarena.in/showthread.php?t=354751
Visit - http://www.techarena.in | http://forums.techarena.in | http://gallery.techarena.in
Anonymous
September 4, 2005 4:11:32 PM

Archived from groups: microsoft.public.windowsxp.games (More info?)

Hi

Thanks for your hint. The patch
http://thesims2.ea.com/update/exe/release/1.0.0.994/the...
works fine and as expected.

Kind regards,
Andreas

"meanornerywench" <mean@ornery.wench> schrieb im Newsbeitrag
news:uTOZjkPsFHA.4044@TK2MSFTNGP09.phx.gbl...
> There was a problem with that was supposed to be fixed with the patch or
> with the University expansion which also patches it. Go to the Sims 2
> official site and search. It is a Sims 2 problem.
>
> "Andreas Manz" <Andreas.Manz@gmx.ch> wrote in message
> news:%23ZrVs3MsFHA.1256@TK2MSFTNGP09.phx.gbl...
>> Hi all
>>
>> Starting The Sims 2 works fine under administrator permission. But logged
> in
>> as a user it results with the error message "Unspecified Error". This
>> text
>> is not really helpful for me.
>> I'm using the german version of Windows XP Professional with SP2.
>>
>> Thanks in advance for any help,
>> Andreas
>>
>>
>
>
!