Sign in with
Sign up | Sign in
Your question

Problems with Sapphire HD5870 1gb Vapor-x

Last response: in Graphics & Displays
Share
January 20, 2013 12:46:18 AM

Hi all! My english isn't top notch but I'll try to be as clear as I can :hello: 

So a few days ago I buyed a refurbished Sapphire hd5870 1gb, inside the hd5870 box it came a vapor-x edition though.

The thing is I tried playing Skyrim with the graphics card standar overclocked by the manufacturer to 875/1250 and within 2 minutes of playing it, the monitor goes "no signal" and the fan speed of the gpu goes to 100%, having to restart the computer.
So I tried changing it to default 850/1200 and played Far Cry 3 perfectly fine, but after that I started playing The Witcher 2, and within 30min or 1 hour of gameplay the same black screen issue happens, and running it overclocked gives me a grey screen with white stripes.

The game runs at 75ºC the whole time at 100% gpu usage, the fan is in auto mode, but even if I set it really high doesn't seem to remove that much heat.

The card is connected correctly and I tried a clean reinstall of the drivers, but didn't fixed the issue at all.

So what do you guys think? Should I RMA it? Is it overheating? I don't have any idea :( 

Here are my computer specs:

Asrock G41M-S3 Motherboard
Kingston ValueRam 4GB DDR3 1333mhz (running at 1066mhz)
Cooler Master GX-Lite 600W
Intel Core Quad Q9300 2.50ghz
Windows 7 64 bits
January 20, 2013 1:00:51 AM

Mostly likely overheating problem, take a pic of your setup and stuff if possible.. also give us more detail like you tested out other video card and it worked fine until you put card in and how much PSU watts you have... BTW, take pic of the back and the heatsink and stuff...
February 1, 2013 3:41:33 PM

u have to update the latest driver for your hd 5870. it works
!