Sign in with
Sign up | Sign in
Your question
Closed

Some games run fine and some drop to 12 fps!!!

Last response: in Graphics & Displays
Share
January 20, 2013 4:16:15 PM

Hello,
My name is fauzan and I have a problem with some of my games running extremely slow in my pc but first my specs:
i5 2500k cpu 3.3 (not overclocked)
Asrock B75M mobo
2*4gb ram
xfx hd 6870 1gb
600 watt cooler master psu.
So basically the problem is that these games(hitman absolution,assasins creed 3,far cry cry 3,need for speed hot pursuit) run perfectly fine but then on the other hand these(kane and lynch dead men,prince of persia 2008,need for speed most wanted 2005) don't run properly in both kane and lynch and prince of persia there is a 12-14 fps dip from time to time which shouldn't be their considering how old the games are,and need for speed most wanted also lags from time to time.
I really don't know whats happening since I haven't installed any new hardware or software.I've also tried different display drivers but nothing helped.
So if anyone has any idea of what might be wrong and how it might be fixed then please let me know.thanks.

January 20, 2013 5:32:09 PM

Sounds to me like power-saving frequencies kicking in when they shouldn't. The possible solution is to use an app to force 3D clocks everytime before you play those games. I use MSI afterburner for that myself. It is normal for that to happen if you're running low resource apps on a powerful GPU and it's due to ATi's retarded decision to base power saving features off GPU usage alone (and not including a way to disable it in their drivers :pfff:  ).

Install MSI afterburner, look up "afterburner.cfg" in the program folder and change "EnableUnofficialOverclocking=0" to "EnableUnofficialOverclocking=1" , now all you have to do is set the core clock to anything other than default, even by just 1mhz, and the card will stick to those clocks until you press the reset button.

You can save it as profile and bind a hotkey to it, or set it as "3d profile" clocks so everytime a 3D program kicks in it will force the clocks automatically or just check apply at startup if you don't mind the extra heat and power while you're not playing. .
Score
0
January 20, 2013 6:24:23 PM

Unfortunately no joy man I tried creating the profiles as you said in Msi afterburner as well as creating 3d profiles in catalyst control center.I now noticed that the low fps usually happens when their is a lot of smoke on the screen.
I really want to fix this problem as I fear I might face it in the new devil may cry game.
Please let me know if anything else comes to mind.
Score
0
Related resources
January 20, 2013 9:58:37 PM

Run GPU-z in the background while you play a game as the fps dips occur, make sure "log to file" is checked under the sensors tab. Then upload the .txt for me to see or copy and paste it here.

You sure you've never had it happen on the newer games you mentioned?
Score
0
January 20, 2013 10:03:37 PM

fauzan_22 said:
Unfortunately no joy man I tried creating the profiles as you said in Msi afterburner as well as creating 3d profiles in catalyst control center.I now noticed that the low fps usually happens when their is a lot of smoke on the screen.
I really want to fix this problem as I fear I might face it in the new devil may cry game.
Please let me know if anything else comes to mind.


If AMD's power-saving feature isn't the cause, then the only thing that leaps to mind is that maybe certain games are using the Intel integrated graphics on your Core i5 -- but then, you should see pathetic performance across the board, not just occasional dips into pathetic territory. ;) 

wiini's GPUz suggestion is a good one, in any case.

It's also possible that certain old games just don't play nice with your modern software/hardware configuration. Have you tried running the games in WinXP compatibility mode?
Score
0
January 21, 2013 7:22:15 AM

wiinippongamer said:
Run GPU-z in the background while you play a game as the fps dips occur, make sure "log to file" is checked under the sensors tab. Then upload the .txt for me to see or copy and paste it here.

You sure you've never had it happen on the newer games you mentioned?


All right here's prince of persia's log file http://www.mediafire.com/?m7c5d5kq4gubq34
and here's kane and lynch's http://www.mediafire.com/?adlrl5g6tgdedgt.
Well it did happened with far cry 3 but it was after my brother played the entire game without any problems and the problem started after I started playing far cry 3 but after I reinstalled the game it ran fine,unfortunately the same trick didn't worked with the previous two games I mentioned.
Let me know what you think after looking at the log files.thanks.


@Fulgurant well it can't be the integrated graphics as I've disabled it in bios and also no luck with win xp compatibility mode but thanks for the suggestion.


Score
0
January 21, 2013 2:52:22 PM

Did you alt-tab out of the games a few times while the log was made? If not then it's definetly power play interfering, there are some short periods of 300/300 frequencies spared between 900/1050, that would certainly cause a big dip in the framerate for a few seconds.
Score
0
January 21, 2013 3:32:07 PM

Poweplay is just what AMD calls it's power saving features for their GPUs.

There's no way the values on pop2008 txt are accurate. At 6-21ghz the system would crash pretty much inmediately.

Make sure you set up MSI afterburner right and check if it did apply the frequency you set using gpuz or in Catalyst Control Center.
Score
0
January 21, 2013 5:05:11 PM

@ wiinippongamer as you said changed the value of unofficial mode from '0' to '1' and then changed the core clock from 900 to 904 saved the profile and also double checked it with GPU-Z but still no joy.Will formatting and reinstalling windows 7 x64 fix the issue?
Score
0

Best solution

January 21, 2013 5:53:31 PM

If it's driver related yes. You can try the following to avoid reformatting that might also work:

Look up driver sweeper and install it, unistall your current drivers, boot up under safe mode and scan for AMD drivers using driver sweeper to delete all leftover files, then boot back as normal and install the 13.1 drivers.

If that doesn't fix it and neither does a reformat the card is likely defective.

It could be CPU related, but since other more demanding games run fine it's unlikely.

Share
January 22, 2013 5:46:45 AM

Best answer selected by fauzan_22.
Score
0
January 22, 2013 5:56:12 AM

@ wiinippongamer thanks a lot I uninstalled the drivers and used driver sweeper and reinstalled the drivers and now everything is back to normal prince of persia,kane and lynch are running at 60 frames like they should and no low fps issue whatsoever,I swear that if I didn't came on tom's hardware then I would have definitely ended up formatting my pc.Again thanks a lot to every single one of you.Strange thing is now that all games are running extra nicely I don't feel like playing them truly strange.

Score
0
!