Sign in with
Sign up | Sign in
Your question

7950 Vapor-X Issues

Last response: in Graphics & Displays
Share
January 21, 2013 1:15:36 PM

A few months ago I purchased a Sapphire 7950 Vapor-X and it seemed to work fine for a bit, but ever since then I've been having issues with random artifacting and hard locks. I've tried increasing the power limit, running it at stock clocks (850/1000). It should be noted that this issue started before I even attempted to overclock the card myself.

I'm planning on RMAing the card but I'm worried that they're going to send me the revision card which uses 8+8 PCI power connectors when my power supply can only support a 6+8 configuration.

More about : 7950 vapor issues

a b U Graphics card
January 21, 2013 2:34:20 PM

Are you still running it a stock settings? Set everything back to normal and run Msi Kombustor
m
0
l
a c 82 U Graphics card
January 21, 2013 2:36:33 PM

whats the rest of ur pc specs?

m
0
l
Related resources
January 21, 2013 3:17:55 PM

yamahahornist said:
Are you still running it a stock settings? Set everything back to normal and run Msi Kombustor


Doing so now. I'm just saying that this card shouldn't be artifacting at 950/1400 or 850/1000.
m
0
l
January 21, 2013 3:27:48 PM

Kombustor looks fine, no graphical glitches to report at 900/1300

Even so, there are occasional mosaic-looking graphical glitches while playing games (not even the DX9 issue) so I'm not sure what's causing it.
m
0
l
a c 82 U Graphics card
January 21, 2013 3:32:14 PM

uninstall ur drivers. download driversweeper after uninstalling ur drivers and restarting pc than install latest drivers.

m
0
l
January 21, 2013 3:57:44 PM

I have this card and its a pain in the butt ,
If the artifacting is happening after some time it could be the vrm1 temp (not GPU temp)
Have you got the original bios as this card has a bios update which lowers the vrm1 voltage from 1.6 to 1.5 and has helped me with a lot of the issues I have with mine ,but if you can I would return it as mine still doesn't perform as well as I think it should and if you get the one with the 2x8 pin you can use the included 2x4 pin mmole adaptor
Hope this helps
m
0
l
January 21, 2013 4:03:47 PM

codnan said:
I have this card and its a pain in the butt ,
If the artifacting is happening after some time it could be the vrm1 temp (not GPU temp)
Have you got the original bios as this card has a bios update which lowers the vrm1 voltage from 1.6 to 1.5 and has helped me with a lot of the issues I have with mine ,but if you can I would return it as mine still doesn't perform as well as I think it should and if you get the one with the 2x8 pin you can use the included 2x4 pin mmole adaptor
Hope this helps


I haven't yet updated the bios.
m
0
l
January 21, 2013 4:17:22 PM

Before I updated the bios on the 950 setting with +20 on the power the GPU temps were getting to only 55c but vrm1 was getting to ove r 90c after bios update it goes into low 70c
I haven't had any artifacting since, but if you ran it for a while at the boost clock it might have damaged the vrm1 .
But if you want to try bios update here's the link:
https://m.facebook.com/photo.php?fbid=10151220018934430...

Make sure you check your model no is the right one.
m
0
l
January 21, 2013 4:19:17 PM

codnan said:
Before I updated the bios on the 950 setting with +20 on the power the GPU temps were getting to only 55c but vrm1 was getting to ove r 90c after bios update it goes into low 70c
I haven't had any artifacting since, but if you ran it for a while at the boost clock it might have damaged the vrm1 .
But if you want to try bios update here's the link:
https://m.facebook.com/photo.php?fbid=10151220018934430...

Make sure you check your model no is the right one.


Only recently have I tried to overclock the card at all, I've been running it with the switch off at the standard power level for a few months, though, with little artifacting.
m
0
l
January 21, 2013 4:47:36 PM

bios updated, not seeing any artifacting yet at 900/1300. Will tick up in increments of 25 until I get artifacting. VRM temps are much lower, now.
m
0
l
January 21, 2013 4:51:28 PM

OK glad I could help someone with this card
Tell us if all is good
Also I am sure you know anyway but make sure to check your vrm temps when over clocking because those temps get hotter than the actual gpu
m
0
l
a c 82 U Graphics card
January 21, 2013 4:59:04 PM

keep ur card at stock settings. also do u have the latest mobo drivers?

m
0
l
January 21, 2013 5:00:54 PM

codnan said:
OK glad I could help someone with this card
Tell us if all is good
Also I am sure you know anyway but make sure to check your vrm temps when over clocking because those temps get hotter than the actual gpu


Will do. The new BIOS settings already have the VRM1 temps down by about 10C, so that's fantastic. Hopefully I can get her to around 975/1475 or so, but I'd be happy with 950/1450 if it doesn't artifact. Only time will tell.
m
0
l
a c 82 U Graphics card
January 21, 2013 5:05:31 PM

or just keep it stock, id just keep it at stock dude to avoid issues.

also runa defragment of ur c: and a scandisk with fix errors checked.

also uninstall drivers. than use driversweeper and than restart pc and install latest drivers.

also download msi afterburner to maybe underclock ur card if u ever have issues again.

peace
m
0
l
January 21, 2013 5:24:44 PM

I just run it on the boost setting now so 950/1500 and no artifacts
Also if your trying to play borderlands 2 I had terrible screen tearing until I activated triple buffering in ccc
m
0
l
January 21, 2013 5:27:47 PM

iceclock said:
or just keep it stock, id just keep it at stock dude to avoid issues.

also runa defragment of ur c: and a scandisk with fix errors checked.

also uninstall drivers. than use driversweeper and than restart pc and install latest drivers.

also download msi afterburner to maybe underclock ur card if u ever have issues again.

peace


It's already running okay boosted right now, so I'm not TOO worried. If it starts artifacting like Indiana Jones again, I'll lower the OC.
m
0
l
a c 82 U Graphics card
January 21, 2013 5:47:10 PM

ok lol indiana jones n1c3

m
0
l
!