Closed

Big lag even in older games

Hi folks,

I recently upgraded my RAM, CPU and Motherboard, and since have been having issues with games that would run on my older system config just fine. Every component other than the RAM, CPU, and Motherboard is unchanged. The games I'm running are Company of Heroes, the original Crysis, Mass Effect 2, and Mass Effect 3 - in all of them they run okay, but I get a semi-regular BIG pause in graphics on each of them, it's not smooth at all. There are smooth sections, but then it will pause, go, pause, go, pause, go - this affects both graphics and sound as well. My system specs are:

- Asus P8Z77-V-LX
- Intel 3570 CPU
- XFX 1GB HD5770 Graphics
- 8GB DDR3 1600 RAM
- Windows 7 Professional
- 650W Thermaltake Toughpower QFan PSU
- 1 x 3TB Seagate Barracuda 7200RPM HDD (system)
- 1 x 1.5TB WD Green SATA HDD (games)


For comparison my old setup, which ran them fine, was:
- AMD 6000+ dual core (two 3 GHz cores) CPU
- Gigabyte M61-PM-S2 Motherboard
- XFX 1GB HD5770 Graphics
- 6GB DDR2 800 RAM
- Windows 7 Professional
- 650W Thermaltake Toughpower QFan PSU
- 1 x 160GB WD Black SATA HDD
- 1 x 250GB WD IDE HDD
- 1 x 1.5TB WD Green SATA HDD
11 answers Last reply
More about older games
  1. Sounds like driver issues to me..
    grab and install the latest drivers for your motherboard.
    http://support.asus.com/download.aspx?SLanguage=en&m=P8Z77-V+LX&os=8

    And graphic card:
    http://support.amd.com/us/gpudownload/windows/Pages/radeonaiw_vista64.aspx

    Links are for windows 7 64 bits, i assume you have 64 bits else those 8GB of ram would be wasted.

    Also, did you do a clean windows install or just changed the board without formatting?
    If the problem persists after updating drivers i would suggest you backup your files, format and reinstall windows.
    Since changing boards without formatting is not advisable.
  2. Thanks for the quick reply! :)

    It was a clean install, I actually had a huge amount of problems with the system until I was told I had to do a clean install which I did, and yes I'm running the 64-bit version.

    I've updated to the latest Catalyst drivers recently which didn't do anything. I've just updated them again, see what happens. I also just tried updating the Motherboard chipset, but it's telling me that I have a newer version already installed.
  3. hmm rather odd problem, make sure you have directx updated.
    http://www.microsoft.com/en-us/download/details.aspx?id=35

    update windows too, u never know
  4. The program says DX is up to date, and I check for Windows updates daily.

    Could it be something like physical damage? I've had this issue since I got the new RAM, CPU, and Motherboard.
  5. Did you use the driver disk that came with your motherboard?
  6. I did yeah
  7. Well, if you are possitive all the software is up to date you can start by testing the rams.
    Download the latest memtest (4.20) from here
    http://www.memtest.org/download/4.20/memtest86+-4.20.iso.zip

    Burn it and boot from that CD. Let it run until it says it found no errors.
  8. Will do. Also tested system temps - when the lag starts the CPU and core are around 65 degrees, the GPU was about 74 degrees max.
  9. Alright I ran Memtest, it didn't find any errors.
  10. Bump.
Ask a new question

Read More

Radeon Games Graphics