Sign in with
Sign up | Sign in
Your question

7950 2d flickering

Last response: in Graphics & Displays
Share
January 23, 2013 4:24:39 PM

I recently bougth this card and I´m experiencing this weird 2d flicker, mainy on desktop or while browsing. I´ve been looking for info on the subject and it seems that the problem is driver related but I´m not really sure of that. I´ve already tried 3 different sets of drivers (including 13.1) to no avail.
For example today, while on facebook, the whole screen flickered and then when blank for a second. On a hunch I went to the hardware administrator and found an exclamation mark on the monitor menu, I opened it and it read that “Windows cannot load the device driver for this hardware because the device driver still in memory, error 38” and that a system reboot was necessary.
Finally, the card is not oced, nor is any hardware on my system. Thanks in advance. Any light on this matter will be much appreciated.

My system: Phenom II X4 965@ 3.4Ghz / TA790GX A3+ / ati sapphire 7950 3 gb vapor x / Gskill 8GB DDR3 (4x4GB) / hds: crucial m4 128gb (s.o.); Samsung spinpoint f3 1 tb/OCZ stealthxstream 600w/ SO: Windows 7 64

More about : 7950 flickering

January 23, 2013 5:18:32 PM

What Monitor are you using. You could try looking for a specific driver for the model you are using.
m
0
l
January 23, 2013 10:36:26 PM

Hi blackmancer, thanks for answering :) . I´m using a dell st2321l with the official drivers. Also tried all the connections (dvi, hdmi, vga) but the issue remains.
m
0
l
February 7, 2013 2:01:46 PM

Morgemil said:
I recently bougth this card and I´m experiencing this weird 2d flicker, mainy on desktop or while browsing. I´ve been looking for info on the subject and it seems that the problem is driver related but I´m not really sure of that. I´ve already tried 3 different sets of drivers (including 13.1) to no avail.
For example today, while on facebook, the whole screen flickered and then when blank for a second. On a hunch I went to the hardware administrator and found an exclamation mark on the monitor menu, I opened it and it read that “Windows cannot load the device driver for this hardware because the device driver still in memory, error 38” and that a system reboot was necessary.
Finally, the card is not oced, nor is any hardware on my system. Thanks in advance. Any light on this matter will be much appreciated.

My system: Phenom II X4 965@ 3.4Ghz / TA790GX A3+ / ati sapphire 7950 3 gb vapor x / Gskill 8GB DDR3 (4x4GB) / hds: crucial m4 128gb (s.o.); Samsung spinpoint f3 1 tb/OCZ stealthxstream 600w/ SO: Windows 7 64





ISSUE SOLVED WITH MULTIPLE FIXES



Ok Guys, Im going to be updating how I fixed the issue for those that read, My monitor is a 1080p 75hz monitor, even though I KNOW its 60hz The Catalyst ( CCC )
Program ( EIED ) Was telling me it was 75hz. So I manually set it to 60hz and everything appeared fine. However the flickers started,

I donwloaded software called Radeon Pro and created a new profile.

I click add new profile, when to the ATI folder and added it. Forced the settings I wanted like in CCC and disabled overdrive ( It still downclocks which is nice )
however this is just personal taste, what actually solved the issue was there was an option to manually force a refresh rate of 60Hz.

All I do now is run the profile just to make sure each time ( Im sure its auto anyway) and the flicker has stopped. The reason I believe the issue was happening was my FPS were going past 75, then down to 50 quickly in fast games like SC2 and LoL and the flicker happened. So the refresh rates were getting confused even though it said 60hz in CCC and I tried Vsync.

ALSO!

Coinciding with the fix I also set my games to borederless at the same time of doing the fix mentioned above so that may be the fix or the RadeonPro thing. Yet to test it fullscreen so try that.


Authough forcing 2d clocks didnt work for me, here is how to do it.
Open CCC, top left make a new profile, Close CCC.

Enable Hidden folders ( Search folder options )

The go to Your name on your PC -
APP Data
LOCAL
ATI
and go to your new Profile
EDIT IN NOTEPAD


and look for

<Property name="Want_0" value="30000" />
<Property name="Want_1" value="80000" />
</Feature>
<Feature name="PowerControl_PCI_VEN_1002&DEV_679A&SUBSYS_27601462&REV_00_4&BAB4994&0&0008A">
<Property name="Want" value="0" />
</Feature>
<Feature name="MemoryClockTarget_PCI_VEN_1002&DEV_679A&SUBSYS_27601462&REV_00_4&BAB4994&0&0008A">
<Property name="Want_0" value="15000" />



Now look for this

Now the 30000
and 15000 part are your idle clock speeds, just raise them or make them match your cards default clock speeds,

Like so


<Property name="Want_0" value="80000" />
<Property name="Want_1" value="80000" />


now this didnt work for me as my above method did, but it may work for some,
remember though this means your card with be a little bit hotter ( didnt happen to me in testing though )


You can also raise the two voltages to stay the same.
But again the above RadeonPro methode worked for me.


Thought I would be a nice guy and update how I solved it for others having issues.



Peace, ZII

Youtube.com/videofletcher
m
0
l
!