My build won't power on..? URGENT

Ok I really didn't know where I should post this, but here I am. I'm literally sitting next to my build right now, having just got my graphics card in the mail today(the last component I needed). So here I am all excited for my build and my card finally arrived, but when i go to power on...nothing. My power supply doesn't make a noise, no fans turn on, nothing. I'm fairly sure everything is plugged in correctly because I had a friend who was not a beginner, as myself, help me. What do I do? I'm sitting here with about $1000 worth of scrap metal at the moment and i'd really like it to turn into a working machine, as opposed to a big ass paper weight. Thanks for any and all replies!
16 answers Last reply
More about build power urgent
  1. On the back of the power supply make sure its firmly plugged in and if you have a power switch make sure its on. Also if you have a small voltage selection switch make sure its set properly. 110 for usa.

    Can you list all the components of your build including make and model number.
  2. I believe it does have a voltage selection because it's the only switch i don't recognize, but it only has the numbers 230 and 116 on it. The rest of my hardware is as follows:

    GIGABYTE GV-R787OC-2GD Radeon HD 7870 GHz

    AMD FX-8320 Vishera 3.5GHz

    GIGABYTE GA-970A-UD3 AM3+

    RAIDMAX HYBRID 2 RX-730SS 730W ATX12V

    Western Digital WD VelociRaptor WD5000HHTZ 500GB 10000 RPM 64MB Cache SATA 6.0Gb/s 3.5" Internal Hard Drive

    G.SKILL Ripjaws Series 16GB (4 x 4GB)

    LITE-ON 24X DVD Writer 24X

    Rosewill BLACKHAWK Gaming ATX Mid Tower Computer Case, come with Five Fans, window side panel, top HDD dock
  3. Yea, I know I should have spent a bit more on the psu, but shouldn't it still work? I mean it's just about 750w
  4. Without checking, I don't think your system would max out 730W so I don't think this wattage target for your PSU is an issue. However, Raidmax is also unfamiliar to me so I can't confirm its quality - and as anyone from tom's will agree, a quality PSU is a must, thus ensuring target line/rail parameters are maintained at all times during all loads.

    However, do have a carefull look at the PSU to see if there is a manual switch (not common in a PSU). If there is make sure it's set to your country's voltage. It is odd that the PSU fan doesn't appear to spin when switched on - try disconnecting all power leads into the pc and switch on. Does the fan still fail to turn?

    Additionally, do recheck all PSU connections into the motherboars and all add-in connections. We have all missed things in the past (and still do) and commonly, it's the daftest - and last - thing we overlook.
  5. It could easily be the power supply being faulty out of box which sounds like your problem. I had a raid max in five other work computers i built 5 years back. Both of them fried with in a month and the others a year. One took the mobo out with it, raid max doesnt really make reliable power supply from my experience. They may have changed so i looked up reviews on newegg a lot of people have problem with the frying and taking other parts out. Or others not working out of the box which seems to be your problem. I looked your mobo up i tried looking for a mobo light that indicates its getting power but didn't see it. So i would say if you have a voltage tester you can use it to test your psu. I understand rmaing sucks when getting faulty parts which has happen several times to me. Luckily i have a micro center and tiger direct by me so i usually go there and get a replacement and just sell or return the broken one. hope you figure it out good luck.


    my build
    2600k at 4.6
    evga 580 gtx
    8 gb 2133 mhz cas 9
    asus extreme z
    creative titanium hd
    120 gb vertex 3 max iops raid
    All under liquid cooling swiftec and danger den
    coolmax 1300 watt psu holding strong for 5 years even though man others have failed for some
  6. I tried unplugging everything and still no luck. Except for I could hear the faintest noise coming from the psu, it was so quiet i'm not sure if it made it when everything was plugged in or not, but it's deff coming from the psu. And I tried to go with quality> for most of my components, but the psu does have a 4 star rating over almost 600 people so I can't believe that raidmax is thaaat bad...I just don't understand what's wrong, it's just frustrating me lol
  7. so then its possible you got the bad one which happens. My psu has a lot of bad ones that went out but mine has survived for 5 years now with its power almost maxed out. So its luck of the draw, but to know 100 percent use your friends or just get a volt tester which are 12 dollars.
  8. Alright, thanks for trying to help everyone! I plan on bringing it over to his house tomorrow and I guess I'll see how it goes from there.
  9. Also make sure you have the case front panel wiring connected to the motherbd correctly.
  10. I have, but i've run into a slight dilemma (kind of) i'm not fully sure if i should match the color of the cord to the socket, or what the mb has it labeled as...obviously I went along with the mb description, but at this point any little thing is sticking out in my mind as a possible error
  11. IT JUST POWERED ON FOR A SPLIT SECOND, I saw the fans and everything spin, and it started smoking!! I unplugged it right away, but wtff?!
  12. Bdayton94 said:
    IT JUST POWERED ON FOR A SPLIT SECOND, I saw the fans and everything spin, and it started smoking!! I unplugged it right away, but wtff?!


    What is it? If it is the power supply consider yourself lucky it didn't take anything else with it.

    A bad power supply can take out everthing that takes power. Then you would really have $1000 worth of scrap metal.
  13. you should go with corsair after you grab a new one. if there psu ever burn out and take parts out with it they will pay for them. My roommates corsair went and took out his mobo and cpu they sent him a check 1 weeks later.
  14. Well it turns out I had an extra cord plugged in somewhere? I really don't know, but good news is I'm up and running now, but having a hard time installing my os from USB. I selected USB-HDD in the bios but it's just stuck on the "loading operating system" screen. It's probly been on it for 25 or so minutes...anyways I feel this is a topic for a new thread and I'll be posting it in the mb section. Thanks so much everyone, hopefully this will be fully operational before I hit the sack!
  15. "I had an extra cord plugged in somewhere" .........."but good news is I'm up and running now"

    ---> consider yourself very lucky! I would highly recommend both yourself and your friend check out the rest of the wiring and all MB connections.
  16. I know this is a very late reply, but in case anyone wondered at all lol my computer is still running this strong and I consider it one of the most worth while purchases i've ever made, thanks!
Ask a new question

Read More

Graphics Cards Build Power Graphics Product