Sign in with
Sign up | Sign in
Your question
Closed

7950 not working after 13.1

Last response: in Graphics & Displays
Share
January 26, 2013 1:02:23 AM

Long story short, I was checking out the 13.1 driver and I decided to rollback because it was not stable. After trying the driver I tried to rollback to a previous version; got errors after installing/reinstalling. It was to no avail, so I proceeded to use the system restore and after the pc rebooted there was just black. I installed win 7, deleted my drives. When checking the device manager, the vga was not there. I tried installing the driver and it was yet another bsod. Anyone have any suggerstions?

i5 3570k 4.0 oc
7950 windforce GB 900 mhz clock
asrock oc formula
128 oc agility
wd vr 600gb
win 8 (currently 7)

More about : 7950 working

January 26, 2013 1:27:10 AM

It's usually a bad idea to rollback driver versions without doing a complete removal of the latest driver you used. Though I'm not sure why your GPU is not showing up in Device Manager.

Were you backing up from a system image?
Score
0
January 26, 2013 1:35:45 AM

Sorry for omitting some details, I did uninstall the previous driver. Yes it was an image. After it completed, the screen went black after the restart. I'm a bit frustrated atm, tomorrow I will check another gpu, if it isn't a MB prob, I guess I'll flash. Btw does anyone have a simple gpu flash guide?
Score
0
Related resources
January 26, 2013 1:36:17 AM

It weird because the fans are working fine and I have the dvi from the gpu hooked up to my monitor.
Score
0

Best solution

January 26, 2013 2:08:18 AM

Go to the BIOS/UEFI and select to reset defaults.

Also, while most of the time, selecting the Clean Install option when updating drivers and/or uninstalling from Add/remove programs work, some files get left behind when doing a rollback from the latest version of a driver.

A way to completely erase every trace of a driver is to boot into safe mode and run driver cleaning softwares such as Driver Sweeper.
Share
January 26, 2013 7:12:35 PM

Best answer selected by tentaclegrape.
Score
0
January 26, 2013 7:13:29 PM

Thanks Excella! Bios turned off the pci slot and after the reset it went back to enabled.
Score
0
!