Closed Solved

64 bit Win7, 6GB memory but only 4GB usable

Hi, I have Win7 64bit with 6GB memory. The Windows System control panel agrees with that showing 6GB ram and nothing about a limitation. But today I was opening a lot of files and the program wouldn't let me open more files after Windows memory use reached 4GB. Task Manager showed 4GB used out of 6GB. I tried opening another file with a different program and my screen flickered and the program shut itself off, so it looks like the problem is with Windows and not the other programs. How do I get Windows to use all available memory not just 4GB out of 6GB? Thanks.
13 answers Last reply Best Answer
More about win7 memory usable
  1. Check in your bios if you have an option called "Max Memory" Selected. If you have integrated graphics, you might have some of the memory allocated to graphics, which you should be able to determine in your bios as well.
  2. Your motherboard might be limited to 4 gigs as a max, i would check your motherboard specs and make sure it supports more than 4 gigs of ram first because otherwise windows will show 6 gigs of ram but it will say next to it 3.97 or 4.0 gb usable.
  3. kelthic: I have a separate graphics card with plenty of its own memory, not integrated graphics. Even with the separate graphics card is it possible that the graphics are reserving some of the main memory?

    Mightmaxio: as I said in my first post, Windows System control panel doesn't show a limitation like "4.0 gb usable".
  4. you will have to check in your bios to make sure that this isn't the case, especially if you have integrated graphics in addition to your discrete gpu. Also, can you list the model of motherboard you have? We'll want to look into the point brought up by mightymax as well.
  5. Its not an issue of recognizing the ram it would be a limitation of how ram gets computed by the bios such as my HP 775 mobo would let 8 gigs of ram show up but only have 3.96gb usable.
  6. Mark - you need to let us know your set-up .......i.e. your motherboard make+model + number, type and size of your memory modules. Without this we're kinda guessing :)
  7. Strangely I was able to get Windows to use 4.5GB of RAM using a different application, so something's very strange here if it wouldn't let me go past 4GB before.

    The motherboard is a GIGABYTE GA-X58A-UD3R. The manufacturer says that it supports up to 24GB memory.

    The RAM is GSKILL F3-12800CL7T-6GBPI, which is 3x2GB.

    Thanks for your help. Any other ideas about what could be causing Windows to have acted like it only had 4GB available ram?
  8. Is this a problem that has recently surfaced, or has your computer always been able to detect 6GB of RAM?
  9. Best answer
    I think i figured it out, your more than likely running a x86(32 bit) application on a x64 machine which would explain why that 32bit app only recognized 4 gigs of ram and not more. For an application to use more than 4 gigs of ram it will also have to be x64 bit.
  10. hanselb: this is the first time I've had any problems with memory on this computer, but I don't think that I've had so many files open at once before so this is why this problem just happend

    mightymaxio: that explanation makes a lot of sense. Thank you!!!! I will come back here if I have more issues with this but I bet that you're right.
  11. Best answer selected by Mark158.
  12. This topic has been closed by Nikorr
Ask a new question

Read More

Configuration Control Panel Memory Windows 7