Sign in with
Sign up | Sign in
Your question

XFX 5770 ATI Overheating or something else?

Last response: in Graphics & Displays
Share
January 26, 2013 1:27:24 PM

Okay,

So when playing games I got alot of black screens, someone said to put the Power plan to Performance, did this and seemed to fix.

But I notice when I play let's say battlefield 3 for 3-4 hours, I get a black screen with a loop of the last sound played. If I restart PC and play again it can go for another 3-4 hours or it will last for 10 seconds untill I get a blackscreen again.

Usually if it happens 2 times I leave the pc for some hours and come back then it works fine again.

My setup

e8400 P5e3 8 Gb ram 500 watt corsair hd 5770 radeon


I have stress tested my GPU and it does not get higher then 62 degrees, 30 idle 50 playing games.

CPU 40 idle, 55 game. Also stress tested, both did fine for 24 hours.

What could it be? Drivers up to date and evertyhing

More about : xfx 5770 ati overheating

January 27, 2013 8:12:41 PM

Go into the power profiles,
set standby, hibernate and sleep to OFF
leave the monitor standby ON, that's OK (maybe not, try OFF)
Set the Hard Drive standby to NEVER
Set system Performance to MAXIMUM, not "quiet mode."

Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
in the bios, see that the allocation for video, if available, is maxed.

Now open the hardware manager profiles...
click start
click computer
click system properties
click device manager
double click on mice and other pointing devices
right click on HID compliant mouse
left click on properties
click on the power management tab
UN-check the box that says: "allow the computer to turn off this device to save power." (there is now NO check mark in this box)
click OK

Now repeat this procedure for all mice, monitors, keyboards, and ALL USB ports on the device manager list.

You must open ALL the devices one at a time, as above, and turn off the power saver, for each device.
January 27, 2013 11:37:19 PM

Thanks for the reply, did all the changes didn't play a game yet but I stumble across a new freaking problem.

My videocard scored a 7,4 @ the windows index service, it said new hardware detected so I re-ran it, and now it scores a 6?!

I barely use this pc, I've only updated my videocard to the latest drivers and thats it.

Got an HD XFX 5770
January 28, 2013 12:11:46 AM

I stress tested my GPU only for 5 minutes with Furmark btw, not 24 hours.

Just did a 15min burn in test, card failed in the first minute @ 40 degrees, ( orange screen kinda same like when I game but then its black )

Restarted, did another test got 68 degrees for 15mins no problems
!