Sign in with
Sign up | Sign in
Your question

Could some one help with my issue

Last response: in Graphics & Displays
Share
January 26, 2013 9:06:53 PM

I was trying to play the Lord of the rings online game on my computer(that i now have working) But it ran like *** and was all jumpy and was really fustrating to play on

So i ran my computer through the Can you run it website seeing if some how my computer wasn't able to play the game.

This was the resultsCPU
Recommended: Pentium 4/Athlon XP or better
You Have: Intel(R) Core(TM) i3-3225 CPU @ 3.30GHz
Click here for the latest CPU drivers.

CPU Speed
Recommended: 2.8 GHz
You Have: 3.3 GHz

RAM
Recommended: 1 GB
You Have: 3.6 GB

OS
Recommended: Windows XP or Vista
You Have: Microsoft Windows Vista Home Premium Edition Service Pack 1 (build 6001), 32-bit
Click here for the latest Windows drivers.

Video Card
Recommended: 128 MB NVIDIA GeForce 6800 or ATI Radeon X850
You Have: ASUS HD7770 Series

Features: Recommended attributes of your Video Card
Required You Have
Video RAM 128 MB 2.5 GB
3D Yes Yes
Hardware T&L Yes Yes
Pixel Shader version 2.0 5.0
Vertex Shader version 2.0 5.0

DirectX version
Recommended: 9.0c
You Have: 10.0

Sound Card
Recommended: Yes
You Have: AMD High Definition Audio Device
Click here for the latest Sound Card drivers.

Free Disk Space
Recommended: 15 GB
You Have: 376.7 GB

It showed that my computer was way above the recommended stats on the game.

I'm running my computer through my 32 inch tv could that make the difference?
Also I tried to run Bulletstorm and that also ran like *** so it couldnt be due to server lag

More about : issue

a c 192 U Graphics card
January 26, 2013 9:17:02 PM

Check your temps. Did you load the latest drivers, or just let Windows find something? You can get the latest drivers from AMD's web site.
!