Sign in with
Sign up | Sign in
Your question

8600 GTS runs at PCIE link mode x2 instead of x16

Last response: in Graphics & Displays
Share
January 27, 2013 9:43:40 AM

So I've been looking around this forum for few days and still I can't solve this problem.

Everything started when I noticed a minor performance drop in some games. then I checked CPU-Z motherboard sector and noticed that my pcie card runs at x8 bus when max supported is x16.
So I tried random things like reseating card, changing bios settings with no luck.
Yesterday once I reseated the card and situation got even worse with no reason - link width x2! :( 
My mobo is pretty old, I've got it from a friend who didn't have any problems with this mobo (I think)
It's ASUS A8V E SE with AMD Athlon 64 X2 3800+ cpu.
My card is ASUS 8600 GTS 256 mb PCIE x16
aaaand I have 3 memory slots filled with 512 mb DDR 3200 ram cards
I dont use any pci or pcie x1 devices, only graphics card.
so Things I've done so far:

*Reseating the card >10 times
*Changing BIOS settings including pcie port freq, pci port freq, peg link mode, peg data scrambling, ram voltage, cpu voltage, etc...
*Cleaning my graphics card connector with alcohol
*Removing ram cards
*Clearing BIOS data

Please note that I have latest BIOS of my mobo. GPU-Z render test does not make any change tos my pcie bus. I'm 100% sure that it isnt OS/driver/software problem, because POST screen shows pcie 0: link width x2 or something like that.

So I don't know what should I do now. Pretty old graphics card runs even worse than in should and I dont have any alternative for now, I have to stick with this system.
a b U Graphics card
January 27, 2013 12:23:22 PM

You tried Nvidia Ntune, since the board and card is very old. It should work with it.
Allows to you change or up the FSB, CPU, and GPU.
The likely cause is the graphics card nothing else, you should try if you can another card, or borrow one off a friend to test it. It is likely down to the card it`s self.

http://www.nvidia.com/object/ntune_5.05.54.00.html
Related resources
a b U Graphics card
January 27, 2013 12:50:09 PM

Here is another tip for you since the board is old, Turn it all off at the wall.
get a cotton bud and clean the pins inside the Pci-e slot, all of the gold pins.
Use some alcohol on the bud, then leave it for ten or so minuets to evaporate.
It can be dirty pins of the slot it`s self. Btw here are the setting of the bios for x 16

Spread spectrum =Enable.
Pciex clock speed sync to cpu =Enable
Pcie clock should auto detect at 100 Mhz.

You should check that the cpu multiplier is set right also as the Pcie slot is working off the FSB of the Cpu. Oh and turn off cool and quiet off in the bios also it lowers the cpu core speed to cope with heat, and also the bandwidth of the Pcie slot and its frequency as it is tied to the Fsb speed of the cpu.
100Mhz down over to 66Mhz. Result drop in the link speed of the Pcie slot.


January 27, 2013 1:22:23 PM

Thanks. I tried to change bios settings how you said but that doesn't work. I think I will try to clean pcie port as you said.
a b U Graphics card
January 27, 2013 1:30:09 PM

+1 clean the port and the metalic tabs on the card and reseat.
a b U Graphics card
January 27, 2013 1:51:48 PM

A lot of motherboards or cards will throttle down when it's not being used. My 7750 says 16x but only at pci-e 1.1 . If I startup GPU-z, and next to the box, they have a ?, press that and start the render test, this forces the gpu into full speed mode and you should see it increase to it's full speed. Download gpuz and try that.
January 27, 2013 2:09:17 PM

getochkn, I already did that.
"GPU-Z render test does not make any change tos my pcie bus"
January 28, 2013 11:10:45 AM

Cleaned the port, still stuck at x2.. what the hell........:/
January 28, 2013 11:11:42 AM

I think I will ask a friend if he could give me his 9500 gt
January 28, 2013 5:52:52 PM

Ok so I installed friend's Sparkle 9500 GT and it is running at x16 link speed. So this is my video card problem eh..?
!