Sign in with
Sign up | Sign in
Your question

Getting "No Signal" Sapphire HD 7850 (Part II)

Last response: in Graphics & Displays
Share
January 31, 2013 12:28:06 AM

A few weeks ago I had a thread regarding my new Radeon HD 7850 card that would not work. I was pointed at the power supply as being the issue (too low power, and presumably got shorted out when I powered on) and purchased a 600W power supply to replace it.

Everything is plugged in and the computer turns on (I do not hear any POST beep as there doesn't seem to be any speaker connectors that I've found on the mobo), the fans spin, but nothing is going to the monitor and I'm still getting no signal at all. I tried swapping out the Radeon HD 7850 for my old GeForce 9500 GT (which worked before I bought and installed the upgrades) and still nothing. The motherboard has no onboard video that I can test and only one PCI-E slot.

Does this mean my motherboard somehow got fried now too and needs to be replaced?

Specs:

Motherboard: Gigabyte GA-MA770T-UD3P
CPU: AMD Phenom II X4 965 Black Edition
Video Card: Sapphire Radeon HD 7850
Power Supply: OCZ Mod X Stream-Pro 600W
Case: Generic black iBuyPower Mid-tower
February 21, 2013 7:26:20 PM

Have you found an answer? I have the exact same problem as you @_@
February 21, 2013 7:26:26 PM

double post @_@
Related resources
February 27, 2013 10:59:02 PM

Nope. I brought it to a local PC shop who told me my motherboard was fried (specifically he said he could not get it to POST, and thought it was the motherboard). I bought a new motherboard, and he still hasn't been able to get it to POST (that's with a new CPU, new video card, new power supply and now new motherboard), and now he thinks that my (brand new!) power supply is defective. At this point I'm ready to say screw it, try to get a refund on whatever I can, and get one custom built from a site like iBuyPower; I don't have the time to deal with minutiae in components.
February 27, 2013 11:06:51 PM

I actually found a way to get mine to work haha. I just flashed my bios and it started working @_@ Flashed it without the video card :]

Sorry about yours. Hope it all works out!
!