7970 VERY slow performance and fans not spinning

Hi there,
I have just upgraded from a XFX 7850 1gb to the VTX3D HD 7970 3GB X-Edition.

The first problem I have is the twin fans do not spin, only very briefly at power up and thats it!
And the second one is the drastically reduced FPS is games from the 7850.

I have installed the latest drivers etc. My system specs are below.

ASUS M97 PRO AM3+ MOTHERBOARD
AMD 8320 @ 4.0ghz
16GB DDR3 1600 RAM
1 TB SEAGATE HARD DRIVE
SAMSUNG 22X DVDR/RW
VTX3D HD 7970 3GB X-Edition
AMBIANCE 80+ 800w PSU

Thanks in advance
4 answers Last reply
More about 7970 slow performance fans spinning
  1. Did you put the power cords to the GPU in properly?
    If yes, then i'd suggest returning the card considering it's brand new and just get a new one.
  2. I suggest you first check all power connectors and if possible, try another powersupply. Or not, return it
  3. Use something like MSI's Afterburner and see what clocks are set. Also, does it ramp up to 3D clocks under load? It sounds to me like the card (or the drivers) think it's idle, and the fans are spinning down.
    Clear off any old (and the current) video drivers. Use something like CCleaner to be sure they're gone. Reboot, then install the latest drivers from AMD. Any change? If so, great; if not, RMA the card.
  4. Thanks for all the help guys.

    It's the card, I re-installed the drivers etc. tried a game (Borderlands 2) and it was the same with FPS issues, it eventually shut my PC down. The twin cooling fans were the fault. Returning it back to dabs.
Ask a new question

Read More

Graphics Cards Performance Graphics