Sign in with
Sign up | Sign in
Your question

Catalyst Control Centre won't launch (ATI 5870)

Last response: in Graphics & Displays
Share
January 31, 2013 7:57:24 PM

I've just updated to 13.1 however I can't launch the CCC.

This is what I've tried step by step;

- I uninstalled the AMD / ATI software and deleted any AMD or ATI directories that were still there.
- I removed the device drivers from Device Manager and also selected the option which deleted the files.
- I rebooted and ran the full 13.0 package and chose Express Install.
- CCC won't launch (I get the rotating circle before it just turns back to a cursor).

I don't have any special rights on my PC, ie. my account has full admin privs.
The CCC did work before I attempted to install the latest drivers!!
I need CCC to work so that I can 'overscan' the middle (HDMI) monitor because I have black borders around it.

Thanks in anticipation.

PC Spec;
ABIT IX48-GT3 Socket 775
Intel Core2Quad Q9400 (2.66Ghz)
8Gb Corsair TwinX DDR3 1333
ATI 5870 (3x monitors)
Win 7 64-bit
















Don't...

Bump posts


http://www.tomshardware.com/forum/283384-33-read-first
February 1, 2013 5:21:12 PM

Right - it's solution time!! I found the problem after spending hours on the damn thing.

It seems that it boils down to the ATI software not removing registry entries. So whether you install the new drivers or even *uninstall the current drivers/software* first it does not remove old registry entries.

I tried Driver Sweeper and this didn't touch the registry (of course) and I also tried Registry Mechanic and that didn't sort it either.

What I ended up doing is going through the registry manually, searching for "catalyst" and deleting everything I could bl00dy find that matched.
Then, I even deleted the video card under Device Manager which when the system rebooted just had a bog-standard VGA driver installed.

Running the 13.1 install suite again (then reboot) and the CCC now works.
However it's still just as buggy as ever and really has trouble getting the presets correct and seemingly my monitors have to be re-arranged manually every time.

I don't think I'll be buying ATI again, when it works it's great. However flaky software and the uninstallation / installation issues really take some hair-pulling to sort.
August 7, 2013 5:00:16 PM

Off topic: i got the catalyst "install package failure" message (new XP install). But i needed to install "Visual C++ 2005 Redistributable Package (x86)" for it to work. Perhaps do 2010 for good meaasure too...
!