Sign in with
Sign up | Sign in
Your question

Trouble Updating Drivers for Preinstalled Radeon HD 7350

Last response: in Graphics & Displays
Share
February 1, 2013 5:44:20 PM

Hello forum, I'm new here, and I have a little bit of a two-headed problem I'd like to share.

I recently bought an Acer Aspire M3450 desktop (64-bit Windows 7) which came with a Radeon HD 7350, and a whole bunch of preinstalled software, including Catalyst.

I quickly noticed that fullscreen flash video was stuttering on both the regular 19'' Dell flatscreen (DVI) and Sony Bravia 40" TV (HDMI, new current standard cable with ethernet) that I have hooked up, and after days of research and fine-tuning of settings in CCC, Windows, and several different browsers, I found no solution. Additionally, although fullscreen movies in VLC and WMP play smoothly at all sizes on the Dell screen, they will only play smoothly when windowed and shrunk to about 2/3 size when displayed on the TV; at fullscreen they stutter severely and eventually the picture stops altogether.

So I figured I should go ahead and update my drivers, since the versions listed in CCC were very outdated compared to the current version listed on AMD's website. However, upon downloading and installing the AMD graphics drivers for 64-bit Windows 7, I was left with no drivers whatsoever, and no CCC. Instead, I had the Vision Engine control center, with no graphics controls.

So did more research, and tried several different methods of completely cleaning out pre-existing ATI drivers before attempting to install new ones, and have done slight variations on this process several times, unsuccessfully (always after completely express uninstalling CCC from programs): deleting all ATI folders (including hidden) for all users as an Administrator, deleting the ATI folders from HKEY_LOCAL_MACHINE\SOFTWARE, and running Driver Sweeper in safe mode. Regardless of how thoroughly I cleaned, I had the same bad result when installing the new drivers.

I most recently tried, after that same cleaning process, letting the Catalyst Installer unpack, then cancelled out and changed the "WorkAroundInstall" value in InstallManager.cfg to "true" and it didn't make a difference when I resumed installation.

I also tried changing from "Auto" to "Onboard" display only in BIOS, screwing the little plastic cover off of the onboard VGA port and hooking an old monitor up to it, and going through the cleaning/installing process that way, but it still didn't help once I changed that BIOS setting back and went back into Windows using the PCIe card.

And of course, Acer has never released a graphics driver update for this model, I checked their site. I looked at some other models in the Aspire family, and couldn't find any graphics driver updates for them, either.

So, am I stuck with these old drivers forever? I've had to do about a dozen factory restores, and I'm close to giving up. If I can't resolve the driver installation issue, but I could still somehow fix the stuttering video, I guess I'd be happy. Anyone got an idea?

Thanks
February 4, 2013 12:50:11 AM

Factory resets and everything doesn't get rid of it? Wow that's tough.

I've never seen that before. By the way do you have a window's disk to clean install your system?
m
0
l
February 5, 2013 8:14:24 AM

I actually found some more recently dated drivers for the graphics card on Acer's website (turns out this card is very low-end and OEM-only, and that I buy things too quickly), and installed them, and the stuttering didn't improve at all.

I even took the Radeon 2400 XT from my old mighty little Optiplex GX620 and stuck it in the Acer; Windows automatically downloaded and installed drivers for it, and I tested out some video...still stuttering, and that NEVER happened when that card was in that ultra-loud little Optiplex. So I'm ruling out the graphics card, which means I've started this thread in the wrong section and with the wrong title, but oh well.

And unfortunately I don't have a Windows disc for a clean install. Wish I did.

This stuttering thing is really a head-scratcher. The 'Mystify' screensaver, which I've used the whole time I've owned this computer, even has a slight stutter now, which was never there before the last week or so. When I first got this machine 6 weeks ago, the very first thing I did was hook it up to my TV and start watching HD Youtube videos, ESPN3, Hulu etc. and it was all perfectly smooth. Screensavers would smoothly splash back and forth across both screens. But now literally everything has this fast stuttering problem.

I've also been having some bluescreen issues, particularly when launching programs. I used WinDbg to open the dump file after the most recent crash, and it said the crash was caused by ntkrnlmp.exe. Some quick googling told me that this was the most important file in Windows, and that errors traced back to it were usually RAM or driver related. Since the only other time I've experienced anything resembling this constant stuttering was on an old laptop which was desperately low on RAM, I thought that maybe, somehow, memory wasn't being used correctly when it came to video.

I ran memtest86+ and no errors were found, but there is something curious about this computer. I've always been told that sticks of RAM should be installed in PAIRS from the same package, but this machine came with 3 x 2GB sticks in 4 slots. CPU-Z said "Channels - Dual" in the Memory tab, which is a little confusing to me, and after removing the "third" stick and just going with two, CPU-Z now says "Channels - Single" which leaves me even more confused. And the stuttering, of course, didn't improve.

I'm really not sure what to make of any of this now, and unfortunately I bought this thing online (Newegg) and these problems started just after I'd passed the window for being able to RMA it.

I should also add that, as far as online video is concerned, I've used a few different free tools for bandwidth and network monitoring (I have a '30' mbps connection, always average 25-27 in reality), and there are no issues there whatsoever. And the stuttering issues happen with offline videos as well.
m
0
l
!