Sign in with
Sign up | Sign in
Your question

Poor performance with Nvidia GTX 670

Last response: in Graphics & Displays
Share
February 2, 2013 7:06:19 PM

Hello.
I recently got a new pc to help me with my gaming and youtube video recording.
Specs:

Intel® Core™ i7-3820 Quad Core 3.60 GHz 10MB Intel Smart Cache LGA2011

2TB SATA-III 6.0Gb/s 64M Cache 7200RPM Hard Drive

1TB SATA-III 6.0Gb/s 64M Cache 7200RPM Hard Drive

16GB (4x4GB) PC12800 DDR3/1600mhz Quad Channel Memory (Kingston HyperX Blu w/Heat Spreader)

MSI X79A-GD45(8D) Intel X79 Chipset, 3-Way SLI / Crossfire supported, 4 Channel DDR3 ATX Mainboard w/ 8 RAM slots,

THX TruStudio Pro 7.1 Audio, GbLAN, USB3.0, SATA-III RAID, 3 Gen3 PCIe X16, 2 PCIe x16 & 1 PCIe x1

950 Watts Power Supply

NVIDIA GeForce GTX 670 2GB 16X PCIe 3.0 Video Card

Hp w2007 1680 x 1050 monitor

-------

Now my issue comes from not games such as battle field 3 or far cry 3 but Minecraft running shaders.
I would like to get an higher FPS because I am planning to do some recordings for my channel.

While running minecraft with shaders I am getting around 20 fps, not recording, however compared to some videos of people on youtube with GTX 670's they are getting 100+ fps

e.g. http://www.youtube.com/watch?v=ydznTxhxC58

http://www.youtube.com/watch?v=Geog09_nAao

I was wondering if there is something wrong with the drivers I am using 310.90

Below are some GPU-Z Screen shots normal:
http://gyazo.com/fc55e681eb49396c9a87483be8a7365b

When running Minecraft:
http://gyazo.com/1cbe648457a1cd8837a78cf6b1540992

I would like to find out if something is holding my card back or the card is just not powerful enough???

In addition here are my CPU-Z screenshots to help get the issue resolved:

Normal: http://gyazo.com/547e03c11cd4b3d798985f16c6aed119

Minecraft: http://gyazo.com/e068592e81871ae2cd5e482a28d29b3f


Hope you can help me find out why I am getting such low fps or am i going to have to deal with it?
a c 200 U Graphics card
February 2, 2013 8:00:48 PM

make sure your mb bios is updated has the newest cpu and ram codes and bug fixes there a lot of patches for your mb.
try downloading june update for direct-x some of the older april updates from ms were missing files. check to see if there any minecraft patches your missing and see if there a setting to run in in dx9 or dx10 mode. some games got total rewrites foe newer dix10 and 11. some were just patched. for the gpu make sure it in the pci slot near the cpu. run gpu-z make sure the card and pci slot running at the max pci bus speed.
Anonymous
a c 117 U Graphics card
February 2, 2013 8:02:25 PM

don't know if this helps . . . 1:25 he starts discussing the clock speed . .
Related resources
February 3, 2013 12:03:35 PM

I am currently in the process of updating my BIOS and INTEL CHIPSET drivers.
Earlier I installed MSI afterburner and Heaven DX11 Benchmark.

Whilst the bench mark was running, (at 720p) everything on max i was getting around 50 fps and msi afterburner was telling me that I was using 100% gpu usage

I then proceeded to play minecraft the same resolution 720p with the shaders and i was getting 20fps and msi is telling me that 40% of my gpu is being used!

If there a way to force my GTX 670 to work harder on minecraft, as that seems to be the issue???

I will update with results after the Mother Board update!
Anonymous
a c 117 U Graphics card
February 3, 2013 12:14:36 PM

at the risk of putting it in possible not the best terms: it appears minecraft doesn't indicate to the gpu that it needs processing power.

whether this is from how the game is coded or the drivers not being properly optimized for the game, i can not tell you because i or people i know have not played it.


ill look around if you like and get back to you when you update. (i got a few errands to run and going to watch the superbowl later)
February 4, 2013 3:37:53 PM

I have added screenshots for the MSI Afterburner screenshots.

I believe that my graphics card is idling when playing java based games. Is there a way to stop this?
Anonymous
a c 117 U Graphics card
February 4, 2013 4:34:09 PM

try going to nVidia control panel and in manage 3D settings set the power management mode to maximum performance for minecraft.

if it doesn't detect the game, you ought to be able to add it.

February 4, 2013 6:41:58 PM

I have set the thing to maximum performance however there has been no change. I have not been able to find a way to add minecraft
Anonymous
a c 117 U Graphics card
February 4, 2013 6:54:01 PM

@ Program Settings click on ADD:


then brows to minecraft.exe so the driver will "see it" then adjust the power management.

btw, it you happened to change the "Global Settings" you may want to set it back to default
February 4, 2013 6:59:25 PM

That seems to have done it! MSI is showing that my card is working at 100% :) 
Anonymous
a c 117 U Graphics card
February 4, 2013 7:21:44 PM

nice job.
!