Sign in with
Sign up | Sign in
Your question

Lagging while playing fullscreen

Last response: in Graphics & Displays
Share
February 4, 2013 4:07:32 AM

this is really driving me crazy. I have been messing with every setting I can find and searching forums, but the only way I seem to be able to get smooth gameplay is by playing in a window. Even if the window is almost the same size as fullscreen, at the highest resolution, the window is smooth while the fullscreen is really choppy.

ok, here are my specs;

3820 oc'd to 4.625 with stepping enabled
x79 sabertooth mobo
240 g ssd
gigabite hd 7870 (I oc'd to 1200 with 1300 mem, seemed to make it worse... turned back to 1150 and 1250 mem)

dell 24" 1920 X 1200


changing to a lower resolution doesn't seem to help either...
should I throw money at the problem by getting another 7870 and crossfiring?
February 4, 2013 4:15:31 AM

danno84 said:
this is really driving me crazy. I have been messing with every setting I can find and searching forums, but the only way I seem to be able to get smooth gameplay is by playing in a window. Even if the window is almost the same size as fullscreen, at the highest resolution, the window is smooth while the fullscreen is really choppy.

ok, here are my specs;

3820 oc'd to 4.625 with stepping enabled
x79 sabertooth mobo
240 g ssd
gigabite hd 7870 (I oc'd to 1200 with 1300 mem, seemed to make it worse... turned back to 1150 and 1250 mem)

dell 24" 1920 X 1200


changing to a lower resolution doesn't seem to help either...
should I throw money at the problem by getting another 7870 and crossfiring?


Do you have your drivers all up to date ?
February 4, 2013 4:18:35 AM

Set back your gpu and ram speed to default then update to latest CCC and not beta version. It helps most of the time.

If that fails, u might have to RMA ur graphic card.
Related resources
February 4, 2013 6:17:24 AM

ugghh... reset gpu to defaults, uninstalled drivers, updated windows, reinstalled drivers, updated windows again. actually made the lagging better, but Ill still ask for an rma. thanks ttcboy
February 4, 2013 6:39:27 AM

danno84 said:
ugghh... reset gpu to defaults, uninstalled drivers, updated windows, reinstalled drivers, updated windows again. actually made the lagging better, but Ill still ask for an rma. thanks ttcboy


Glad to be of help. Seems like ur card have some defects and u made the right choice to RMA it.
!