Closed

My keys are turning into shortcut keys in the middle of a game

Hello,
I am having issues with my laptop. Sometimes when i type the letters turn into shortcut keys and when i am in the middle of an important school asignment I loose my work, because i can't do anything. I can use my mouse, but when i try to use my keyboard it is almost inoperable. I have even tried to use an external keyboard and the samething happens. I have used Rkill, malwarbytes, norton and ccleaner, but nomatter what i do it keeps happening. The only way i have been able to temperarily fix it is to restart the computer and the problem can come back in 30 minutes or it can come back in 10hours . it even happens when i play games.

This has been going on for about 6 months now.
And i am sick of it.
31 answers Last reply
More about keys turning shortcut keys middle game
  1. Try disabling Windows Sticky Keys:
    http://www.ofzenandcomputing.com/zanswers/2527/
  2. I turned off the sticky keys when i bought the computer, and when i followed the instructions on the website that you provided, It showed that the sticky keys were already shut off. but i put a checkmark in the box then hit apply then i unchecked the box then hit apply again. I will leave my computer on for 24hours and if the problem still exists i will put a reply
  3. What do you mean by shortcut keys. Does E open explorer R open Run and stuff like that?

    If it is, you may have a stuck start key(Alt and Ctrl also do things when pressed with other keys, this can be a defect or something wrong with the keyboard it self). I have seen it happen sometimes(even in software, but mostly with alt or control keys) but a quick hit to start then alt then control on both sides of the keyboard fix it.

    To rule out the keyboard on the laptop, you have to actually disable it when testing another keyboard since i can press start on my computer and R(Run) on my second keyboard(so 2 different keyboards in use) and it will still happen.

    You can connect the second keyboard and then disable the onboard on in the Device manager.

    When it happens, you should be able to at least save your files with the mouse to avoid loosing work.

    EDIT

    For games, if you use steam in game or xfire in game, make sure you are not pressing any keys when you activate them(just the keys you need, so Shift+Tab for steam and i think scroll+X for xfire.).

    I know if you are holding a key when you bring up those things, sometimes the game will keep that key down when you go back. This can make you just keep walking in a game when close steam/xfire in game.
  4. Ok, I will try that out. But usually what happens if say for instance i am in a word document or a video game and i hit a key, it either opens up a shortcut and backs me out of whatever i am doing or the keys that are not matched to a shortcut don't work. But i do think r opens the Run prompt. I have not tried the start alt and double shift on both sides.
  5. Well with any luck it will just be that. Replacing a laptop keyboard is not that hard.
  6. I don't have a solution, but just wanted to say that OP is not crazy. I've had a similar problem. Every few days, I wipe the grease off my laptop keyboard. Once when I did this, the combination of keys I pressed while wiping deleted some files. So now I lock the account before wiping. Any wayward keypresses get sent to the login screen instead.

    Most of the time this works. But about 1 in 10 times, I finish cleaning the keyboard, login again (using my fingerprint), and it's like the alt key is stuck down. e.g. I type f and the computer acts as if I pressed alt-f. I click with the mouse and it acts like I'm alt-clicking. Like OP, sticky keys is off. I've tried all sorts of things and I can't get it out of this mode, nor have I been able to figure out what key combination while wiping puts it into this mode.

    This is a software problem The alt key is not physically stuck because a reboot fixes it every time.
  7. TexasOne said:
    I turned off the sticky keys when i bought the computer, and when i followed the instructions on the website that you provided, It showed that the sticky keys were already shut off. but i put a checkmark in the box then hit apply then i unchecked the box then hit apply again. I will leave my computer on for 24hours and if the problem still exists i will put a reply


    Good choice! I have heard about doing that from others as well so that it re-writes to the settings file.
  8. I have this problem on windows 8 with a wireless keyboard while playing diablo 3.
    The only keys I am pressing(pretty rapidly at times) are 1,2,3,4,left click,right click.

    The only solution I have found is by turning on onscreen keyboard.
    I would like a permanent solution but for those who have this problem you can fix it temporarily very fast by settings
    control panel> ease of access> start onscreen keyboard.
    Atleast that's how I do it in windows 8.
  9. Nukemaster...

    Greetings and gracias for the tip here:

    nukemaster said:
    What do you mean by shortcut keys. Does E open explorer R open Run and stuff like that?

    If it is, you may have a stuck start key(Alt and Ctrl also do things when pressed with other keys, this can be a defect or something wrong with the keyboard it self). I have seen it happen sometimes(even in software, but mostly with alt or control keys) but a quick hit to start then alt then control on both sides of the keyboard fix it.


    I thought I was losing my mind and in for the battle of a lifetime all at once. Sorry for the reference, but my life flashed before my eyes when this started (like a nuke detonation if you will)...

    This one must be archived for future reference!
  10. try pushing ctrl a lot when your computer boots up
  11. Did anyone ever find the solution? I am going through the EXACT same thing right now and I just want it to stop. I usually just restart my comp, but it is really a hassel when it happens. I know there must be some shortcut that I have to undo, but idk how or what :(
  12. I haven't had a recurrence of the problem since I started wiping down my keys one row at a time (instead of everything at once - see my earlier post in this topic). However, from random reading it sounds like the problem is Windows is not getting a key-release event for whatever reason. Try pressing and releasing the stuck command key (ctrl, alt, shift, windows, menu) one at a time. For ctrl, shift, and alt, you have remember that the keyboard has two of those keys - one on the left and one on the right. Either one could be stuck so you have to hit and release both one at a time.
  13. I have been looking for a permanent fix for months, there just doesn't seem to be one.

    What I do when this happens:

    1. Open search with your mouse.
    2. Hold shift key, then type in "On screen" or "On screen keyboard", "On screen is enough most of the time to get "On Screen Keyboard" as an alternative.
    3. Open the On Screen keyboard. When the On Screen keyboard is up, the problem is gone, and won't come back (for me at least) until I shut it down.
  14. Hi! This seems to work for me

    Hit enter. Wait for narrator dialogue to open. Exit narrator. The issue is solved
    In narrator settings change start options for dialogue should this happen again.
    I don't know how or why this works...but it does
    Cheers! :)
  15. when this happens i press "windows key + v" then i return back to typing without restarting the pc
  16. TexasOne said:
    I turned off the sticky keys when i bought the computer, and when i followed the instructions on the website that you provided, It showed that the sticky keys were already shut off. but i put a checkmark in the box then hit apply then i unchecked the box then hit apply again. I will leave my computer on for 24hours and if the problem still exists i will put a reply


    Had the same issue just enabling and disabling sticky keys works.
    "ghost in the machine" :)
  17. Hi all,

    I was having this same issue. While it IS the fault of Sticky Keys (sort of), merely turning off Sticky Keys alone does not fix it - at least it didn't for me.

    The PERMANENT solution:

    Navigate to Control Panel > Ease of Access > Ease of Access Center > Set Up Sticky Keys

    In the second to last section, in "Options" you want to uncheck "Lock modifier keys when pressed twice in a row". This is the culprit. Honestly, it's pretty dumb that it's on by default.
  18. vicben said:
    when this happens i press "windows key + v" then i return back to typing without restarting the pc


    Thanks Vicben, Windows Key + v worked on my wife's laptop (it was driving her nuts!)
    Back in her good books (for a while!)
  19. Sarahsnafu said:
    Hi all,
    The PERMANENT solution:

    Navigate to Control Panel > Ease of Access > Ease of Access Center > Set Up Sticky Keys
    In the second to last section, in "Options" you want to uncheck "Lock modifier keys when pressed twice in a row". This is the culprit. Honestly, it's pretty dumb that it's on by default.


    Ding Ding Ding, we have a winner! Thank you so much!!
  20. the same happened with me but the Iock modifier thing didnt work and mine onIy activates when i hit the L key (so i have to use a capita I to improvise Iower case), when this happens i Iog back in and then when i start using keys, shortcuts start opening up. So to fix it i normaIIy just tap the pIus key on the right hand side of my keyboard tiII the magnifier opens up then i zoom out and continue working as normaI. I dont know how it fixes it, its just a method i worked out by accident and i have been using for months now. This is a reaIIy annoying probIem though because it is reaIIy hard to do schooI assignments without Iocking my computer a few hundred times by accident hahaha. Hope this heIped :)
  21. jtrac40 said:
    the same happened with me but the Iock modifier thing didnt work and mine onIy activates when i hit the L key (so i have to use a capita I to improvise Iower case), when this happens i Iog back in and then when i start using keys, shortcuts start opening up. So to fix it i normaIIy just tap the pIus key on the right hand side of my keyboard tiII the magnifier opens up then i zoom out and continue working as normaI. I dont know how it fixes it, its just a method i worked out by accident and i have been using for months now. This is a reaIIy annoying probIem though because it is reaIIy hard to do schooI assignments without Iocking my computer a few hundred times by accident hahaha. Hope this heIped :)


    My L key gets stuck, as does my Win key function, which has resulted in countless random lock screens. I feel your pain.
    Check this out, it worked for me. http://www.howtogeek.com/howto/windows-vista/disableenable-lock-workstation-functionality-windows-l/
    It will disable your lock screen shortcut (Win/L) and free up that L key. End the nightmare.
  22. Sarahsnafu said:
    Hi all,

    I was having this same issue. While it IS the fault of Sticky Keys (sort of), merely turning off Sticky Keys alone does not fix it - at least it didn't for me.

    The PERMANENT solution:

    Navigate to Control Panel > Ease of Access > Ease of Access Center > Set Up Sticky Keys

    In the second to last section, in "Options" you want to uncheck "Lock modifier keys when pressed twice in a row". This is the culprit. Honestly, it's pretty dumb that it's on by default.


    Works perfectly now. Thank you very much. You just saved all the old people in my office from having a frustration heart attack. Lol.
  23. This happens to me quite a bit... I think it is because I have the mouse on my laptop and a key gets pressed and maybe held down sometimes. I think it is the key between alt and ctrl on the right side of the space bar... it has a rectangle with three lines inside it - looks kind of like a page with writing on it.

    The solution that just worked is simply pressing the left alt key once - and bam... the weird keyboard shortcut only mode was turned off. I think sometimes different combinations of things worked in the past... like doing alt and that weird button, etc.
  24. when im in a game and it happens i hold (alt) and press (enter 5x). its use to turn on while fullscreening some games... hope this halped disable it anyways!
  25. crystaljenna said:
    This happens to me quite a bit... I think it is because I have the mouse on my laptop and a key gets pressed and maybe held down sometimes. I think it is the key between alt and ctrl on the right side of the space bar... it has a rectangle with three lines inside it - looks kind of like a page with writing on it.

    The solution that just worked is simply pressing the left alt key once - and bam... the weird keyboard shortcut only mode was turned off. I think sometimes different combinations of things worked in the past... like doing alt and that weird button, etc.


    it happen to me too and i find that yes the ALT+ Menu key fix it, question that is puzzling how do you get in that mode.
  26. What do you mean by shortcut keys. Does E open explorer R open Run and stuff like that?

    If it is, you may have a stuck start key(Alt and Ctrl also do things when pressed with other keys, this can be a defect or something wrong with the keyboard it self). I have seen it happen sometimes(even in software, but mostly with alt or control keys) but a quick hit to start then alt then control on both sides of the keyboard fix it.

    The above fixed my issue!! All my keys were.not working, only my shortcut keys. By pressing Alt and Control on left side and pressing AltGr on right side at the same time, fixed my issue. Thank you!!!!
  27. TexasOne said:
    Hello,
    I am having issues with my laptop. Sometimes when i type the letters turn into shortcut keys and when i am in the middle of an important school asignment I loose my work, because i can't do anything. I can use my mouse, but when i try to use my keyboard it is almost inoperable. I have even tried to use an external keyboard and the samething happens. I have used Rkill, malwarbytes, norton and ccleaner, but nomatter what i do it keeps happening. The only way i have been able to temperarily fix it is to restart the computer and the problem can come back in 30 minutes or it can come back in 10hours . it even happens when i play games.

    This has been going on for about 6 months now.
    And i am sick of it.


    Hi, not sure if this has been resolved, but it sounds like you accidentally pressed caps lock and the windows key simultaneously. It locks the keyboard into window's shortcuts. Just press them again to disable.

    Hope this helps!
  28. pinkdomino said:
    Hi! This seems to work for me

    Hit enter. Wait for narrator dialogue to open. Exit narrator. The issue is solved
    In narrator settings change start options for dialogue should this happen again.
    I don't know how or why this works...but it does
    Cheers! :)


    Ohh my gosh you have NO idea how much Im thanking you right now. Ive been working at this problem for 2 hours straight and I swear I was gonna smash my window or something. Made an account specifically to say thanks. Its crazy how the stupidest things can be solved by other stupid things :P
  29. vicben said:
    when this happens i press "windows key + v" then i return back to typing without restarting the pc


    I experienced this issue and nothing else worked : Shift x5 = disabled - no go | Open ease of access > Set up Sticky Keys > tick, apply, untick, apply - no go | Press and hold enter - no go | Smashing keyboard - satisfying but still no go...

    Windows + v = SUCCESS!

    Thanks @ vicben
  30. Try to press numlock you might have accidentally turned it on when you are playing . Plug in an extermal keyboard and press numlock then unplug it . After that you are done this works for me i hope it will work for you . Cheers✌
  31. necro thread
Ask a new question

Read More

Windows 7