Sign in with
Sign up | Sign in
Your question

Sapphire HD7770OC Ghz edition Blank Screen

Last response: in Graphics & Displays
Share
February 5, 2013 11:30:02 AM

Hi There guys,

I have a bit of weird one for you,

My system is running perfect except for one thing, and i have a feeling it is the GPU.

Everytime i watch movies on my PC, i rent a lot of movies, during the movie the screen goes blank, sound plays for a bit and then it stops alltogether. I never had this problem with my HD4870.

How do i explain to my suppliers what is happening, as they have run benchmarks on the card, and nothing happens. I play games at full res, no issues at all, but only on movies. What would be the best solution on regard to this, as i have also updated my display drivers. :pt1cable: 

Now i even have tried a clean install of the O/S and clean drivers install, same problem persists, put in my old HD4870 and no problems at all.

Thanks Guys in advance.
February 5, 2013 11:43:28 AM

could be your monitor maybe you have a setting that when a movie is playing the monitors dims down thats what mine does so mess with your monitor settings
m
0
l
February 5, 2013 12:04:52 PM

Hi Omaroma,

I have, the worst part is, like i said, i put in my old 4870 and have no issues.

Sometimes the screen takes nearly a whole movie, sometimes in 5 minutes, so i dont think it is the screen. Any other advise that i can maybe take a look into, is there something on the drivers side that i need to look into.
m
0
l
Related resources
!