Sign in with
Sign up | Sign in
Your question

7950 Black flickering - Can I get a refund?

Last response: in Graphics & Displays
Share
February 5, 2013 11:19:48 PM

First week seemed OK but now I am playing more games I notice the screen flickers black for 1 second every 30 seconds,

Now I'm on the 13.1 Drivers and flickering began to occur. Now 13.2 hasn't fix it.


I am really dissapointed that this company still fails to produce and fix bad drivers. I am never purchased ATI/AMD as people have warned about issues but the 7950 was TOO good to turn down.

Should I send the card back? or will these issues be fixed ASAP?

Thousands of us can't play LoL or SC2 or DayZ because of flickering and flashes. This is a £250 GPU and I did not expect these issues. I have even manually set the idle clocks to match the full clocks to no avail


I would like a response
February 7, 2013 1:09:19 AM

nvidia is not invincible either, my GTS 450 flickered like a *****.

Try 12.1 drivers.

and your refund... depends where you bought it really, but you wont get it from the manufacturer.
February 7, 2013 1:59:41 PM

ISSUE SOLVED WITH MULTIPLE FIXES



Ok Guys, Im going to be updating how I fixed the issue for those that read, My monitor is a 1080p 75hz monitor, even though I KNOW its 60hz The Catalyst ( CCC )
Program ( EIED ) Was telling me it was 75hz. So I manually set it to 60hz and everything appeared fine. However the flickers started,

I donwloaded software called Radeon Pro and created a new profile.

I click add new profile, when to the ATI folder and added it. Forced the settings I wanted like in CCC and disabled overdrive ( It still downclocks which is nice )
however this is just personal taste, what actually solved the issue was there was an option to manually force a refresh rate of 60Hz.

All I do now is run the profile just to make sure each time ( Im sure its auto anyway) and the flicker has stopped. The reason I believe the issue was happening was my FPS were going past 75, then down to 50 quickly in fast games like SC2 and LoL and the flicker happened. So the refresh rates were getting confused even though it said 60hz in CCC and I tried Vsync.

ALSO!

Coinciding with the fix I also set my games to borederless at the same time of doing the fix mentioned above so that may be the fix or the RadeonPro thing. Yet to test it fullscreen so try that.


Authough forcing 2d clocks didnt work for me, here is how to do it.
Open CCC, top left make a new profile, Close CCC.

Enable Hidden folders ( Search folder options )

The go to Your name on your PC -
APP Data
LOCAL
ATI
and go to your new Profile
EDIT IN NOTEPAD


and look for

<Property name="Want_0" value="30000" />
<Property name="Want_1" value="80000" />
</Feature>
<Feature name="PowerControl_PCI_VEN_1002&DEV_679A&SUBSYS_27601462&REV_00_4&BAB4994&0&0008A">
<Property name="Want" value="0" />
</Feature>
<Feature name="MemoryClockTarget_PCI_VEN_1002&DEV_679A&SUBSYS_27601462&REV_00_4&BAB4994&0&0008A">
<Property name="Want_0" value="15000" />



Now look for this

Now the 30000
and 15000 part are your idle clock speeds, just raise them or make them match your cards default clock speeds,

Like so


<Property name="Want_0" value="80000" />
<Property name="Want_1" value="80000" />


now this didnt work for me as my above method did, but it may work for some,
remember though this means your card with be a little bit hotter ( didnt happen to me in testing though )


You can also raise the two voltages to stay the same.
But again the above RadeonPro methode worked for me.


Thought I would be a nice guy and update how I solved it for others having issues.



Peace, ZII

Youtube.com/videofletcher
!