Sign in with
Sign up | Sign in
Your question

Port Forwarding on MN-500

Last response: in Networking
Share
April 12, 2004 11:39:53 PM

Archived from groups: microsoft.public.broadbandnet.hardware,microsoft.public.windowsxp.general,microsoft.public.windowsxp.help_and_support (More info?)

I am running Windows XP Pro, using cable connection.
I have purchased ServU FTP Server and have been working with it perfectly
untill I got MN-500 router. There are instructions on how to setup the port
forwarding but I'm unable to get my server running with MN-500.

Here are the help instructions from ServU:

*** START OF HELP FILE ***

Configure the router to forward ports 20 and 21 to the internal IP address
where Serv-U is listening. This allows the FTP traffic to be routed through
the router and into Serv-U. There should be options in the router to forward
these ports.

In Serv-U setup the IP for Passive mode to reflect the actual IP Address and
not the Internal IP address Serv-U sees:
a.. Select "Settings" under your domain.
b.. Select the "Advanced" tab.
c.. Enter the external IP address of your internet connection. If you are
using Serv-U with a dynamic IP address, leave this field blank.
d.. Set up the PASV port range option in Serv-U. Under "Local Server"
select "Settings" and then the "Advanced" tab. Here you will see the PASV
port range option.
When setting up the PASV port range, we recommend opening up ports 2000 -
2010. Then open up the same port range in your router and map them to the
Serv-U server.

You should now be able to connect from any FTP Client using PASV mode.

However, if you are still unable to connect disable the Block "FTP_bounce"
attacks and FXP. This option has been known to cause complications with some
connections.

*** END OF HELP FILE. ***

Here is the log file from ServU:

*** START OF LOG FILE ***

Mon 12Apr04 18:55:09 - Serv-U FTP Server v5.0 - (5.0.0.4) - Copyright (c)
1995-2004 Cat Soft, All Rights Reserved - by Rob Beckers
Mon 12Apr04 18:55:09 - Cat Soft is an affiliate of Rhino Software, Inc.
Mon 12Apr04 18:55:10 - Using WinSock 2.0 - max. 32767 sockets
Mon 12Apr04 18:55:11 - Loaded SSL/TLS libraries
Mon 12Apr04 18:55:11 - FTP Server listening on port number 43542, IP
127.0.0.1
Mon 12Apr04 18:55:12 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS: Port
number 21 already in use!
Mon 12Apr04 18:55:12 - Valid registration key found
Mon 12Apr04 18:55:52 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS: Port
number 21 already in use!
Mon 12Apr04 19:03:23 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS: Trying
to use non-existent IP address?
Mon 12Apr04 19:08:37 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS: Port
number 21 already in use!
Mon 12Apr04 19:21:44 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS: Port
number 21 already in use!

*** END OF LOG FILE ***

I am unable to connect by typing: ftp://MY.IP.ADD.RESS/
What am I doing wrong or what needs to be done?
Please help out. Thanks in advance.
Gino

More about : port forwarding 500

Anonymous
April 13, 2004 2:51:55 AM

Archived from groups: microsoft.public.broadbandnet.hardware,microsoft.public.windowsxp.general,microsoft.public.windowsxp.help_and_support (More info?)

Your port 21 is in use by something else.

Are you using IIS and did you enable its FTP component? If so, ServU won't
be able to bind to port 21.
Otherwise, you'll need to find what is using port 21

You can use netstat -ao to see what PID is binding itself to port 21.
After getting the PID number, you can use the tasklist command to match the
PID to the process that is holding it.

--
Jason Tsang - Microsoft MVP

Find out about the MS MVP Program -
http://mvp.support.microsoft.com/default.aspx

" - 781 -" <lets@have.org> wrote in message
news:o 3tcjCQIEHA.3840@TK2MSFTNGP11.phx.gbl...
> I am running Windows XP Pro, using cable connection.
> I have purchased ServU FTP Server and have been working with it perfectly
> untill I got MN-500 router. There are instructions on how to setup the
port
> forwarding but I'm unable to get my server running with MN-500.
>
> Here are the help instructions from ServU:
>
> *** START OF HELP FILE ***
>
> Configure the router to forward ports 20 and 21 to the internal IP address
> where Serv-U is listening. This allows the FTP traffic to be routed
through
> the router and into Serv-U. There should be options in the router to
forward
> these ports.
>
> In Serv-U setup the IP for Passive mode to reflect the actual IP Address
and
> not the Internal IP address Serv-U sees:
> a.. Select "Settings" under your domain.
> b.. Select the "Advanced" tab.
> c.. Enter the external IP address of your internet connection. If you
are
> using Serv-U with a dynamic IP address, leave this field blank.
> d.. Set up the PASV port range option in Serv-U. Under "Local Server"
> select "Settings" and then the "Advanced" tab. Here you will see the PASV
> port range option.
> When setting up the PASV port range, we recommend opening up ports 2000 -
> 2010. Then open up the same port range in your router and map them to the
> Serv-U server.
>
> You should now be able to connect from any FTP Client using PASV mode.
>
> However, if you are still unable to connect disable the Block "FTP_bounce"
> attacks and FXP. This option has been known to cause complications with
some
> connections.
>
> *** END OF HELP FILE. ***
>
> Here is the log file from ServU:
>
> *** START OF LOG FILE ***
>
> Mon 12Apr04 18:55:09 - Serv-U FTP Server v5.0 - (5.0.0.4) - Copyright (c)
> 1995-2004 Cat Soft, All Rights Reserved - by Rob Beckers
> Mon 12Apr04 18:55:09 - Cat Soft is an affiliate of Rhino Software, Inc.
> Mon 12Apr04 18:55:10 - Using WinSock 2.0 - max. 32767 sockets
> Mon 12Apr04 18:55:11 - Loaded SSL/TLS libraries
> Mon 12Apr04 18:55:11 - FTP Server listening on port number 43542, IP
> 127.0.0.1
> Mon 12Apr04 18:55:12 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS: Port
> number 21 already in use!
> Mon 12Apr04 18:55:12 - Valid registration key found
> Mon 12Apr04 18:55:52 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS: Port
> number 21 already in use!
> Mon 12Apr04 19:03:23 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS:
Trying
> to use non-existent IP address?
> Mon 12Apr04 19:08:37 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS: Port
> number 21 already in use!
> Mon 12Apr04 19:21:44 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS: Port
> number 21 already in use!
>
> *** END OF LOG FILE ***
>
> I am unable to connect by typing: ftp://MY.IP.ADD.RESS/
> What am I doing wrong or what needs to be done?
> Please help out. Thanks in advance.
> Gino
>
>
April 13, 2004 8:08:05 AM

Archived from groups: microsoft.public.broadbandnet.hardware,microsoft.public.windowsxp.general,microsoft.public.windowsxp.help_and_support (More info?)

Are you trying to connect to your FTP server from behind the router? If
you are you will need firmware version 1.09.* or higher to have the loop
back support enabled.

- 781 - wrote:

> I am running Windows XP Pro, using cable connection.
> I have purchased ServU FTP Server and have been working with it perfectly
> untill I got MN-500 router. There are instructions on how to setup the port
> forwarding but I'm unable to get my server running with MN-500.
>
> Here are the help instructions from ServU:
>
> *** START OF HELP FILE ***
>
> Configure the router to forward ports 20 and 21 to the internal IP address
> where Serv-U is listening. This allows the FTP traffic to be routed through
> the router and into Serv-U. There should be options in the router to forward
> these ports.
>
> In Serv-U setup the IP for Passive mode to reflect the actual IP Address and
> not the Internal IP address Serv-U sees:
> a.. Select "Settings" under your domain.
> b.. Select the "Advanced" tab.
> c.. Enter the external IP address of your internet connection. If you are
> using Serv-U with a dynamic IP address, leave this field blank.
> d.. Set up the PASV port range option in Serv-U. Under "Local Server"
> select "Settings" and then the "Advanced" tab. Here you will see the PASV
> port range option.
> When setting up the PASV port range, we recommend opening up ports 2000 -
> 2010. Then open up the same port range in your router and map them to the
> Serv-U server.
>
> You should now be able to connect from any FTP Client using PASV mode.
>
> However, if you are still unable to connect disable the Block "FTP_bounce"
> attacks and FXP. This option has been known to cause complications with some
> connections.
>
> *** END OF HELP FILE. ***
>
> Here is the log file from ServU:
>
> *** START OF LOG FILE ***
>
> Mon 12Apr04 18:55:09 - Serv-U FTP Server v5.0 - (5.0.0.4) - Copyright (c)
> 1995-2004 Cat Soft, All Rights Reserved - by Rob Beckers
> Mon 12Apr04 18:55:09 - Cat Soft is an affiliate of Rhino Software, Inc.
> Mon 12Apr04 18:55:10 - Using WinSock 2.0 - max. 32767 sockets
> Mon 12Apr04 18:55:11 - Loaded SSL/TLS libraries
> Mon 12Apr04 18:55:11 - FTP Server listening on port number 43542, IP
> 127.0.0.1
> Mon 12Apr04 18:55:12 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS: Port
> number 21 already in use!
> Mon 12Apr04 18:55:12 - Valid registration key found
> Mon 12Apr04 18:55:52 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS: Port
> number 21 already in use!
> Mon 12Apr04 19:03:23 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS: Trying
> to use non-existent IP address?
> Mon 12Apr04 19:08:37 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS: Port
> number 21 already in use!
> Mon 12Apr04 19:21:44 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS: Port
> number 21 already in use!
>
> *** END OF LOG FILE ***
>
> I am unable to connect by typing: ftp://MY.IP.ADD.RESS/
> What am I doing wrong or what needs to be done?
> Please help out. Thanks in advance.
> Gino
>
>
Related resources
Can't find your answer ? Ask !
April 15, 2004 2:58:12 AM

Archived from groups: microsoft.public.broadbandnet.hardware,microsoft.public.windowsxp.help_and_support (More info?)

Thank you all for replies.

One thing I don't understand is:
FTP Server listening on port number 43542, IP 127.0.0.1
Where does port 43542 come from within serv-u?
Is this the port to be changed? If so, I can't find where this number is
typed in Serv-U.
And it's not the same port number as I specify in FTP server port box.

Please respond.
Thanks
Gino


"joker" <no-spam@netzero.com> wrote in message
news:%23Yvb18TIEHA.4092@TK2MSFTNGP11.phx.gbl...
> Are you trying to connect to your FTP server from behind the router? If
> you are you will need firmware version 1.09.* or higher to have the loop
> back support enabled.
>
> - 781 - wrote:
>
> > I am running Windows XP Pro, using cable connection.
> > I have purchased ServU FTP Server and have been working with it
perfectly
> > untill I got MN-500 router. There are instructions on how to setup the
port
> > forwarding but I'm unable to get my server running with MN-500.
> >
> > Here are the help instructions from ServU:
> >
> > *** START OF HELP FILE ***
> >
> > Configure the router to forward ports 20 and 21 to the internal IP
address
> > where Serv-U is listening. This allows the FTP traffic to be routed
through
> > the router and into Serv-U. There should be options in the router to
forward
> > these ports.
> >
> > In Serv-U setup the IP for Passive mode to reflect the actual IP Address
and
> > not the Internal IP address Serv-U sees:
> > a.. Select "Settings" under your domain.
> > b.. Select the "Advanced" tab.
> > c.. Enter the external IP address of your internet connection. If you
are
> > using Serv-U with a dynamic IP address, leave this field blank.
> > d.. Set up the PASV port range option in Serv-U. Under "Local Server"
> > select "Settings" and then the "Advanced" tab. Here you will see the
PASV
> > port range option.
> > When setting up the PASV port range, we recommend opening up ports
2000 -
> > 2010. Then open up the same port range in your router and map them to
the
> > Serv-U server.
> >
> > You should now be able to connect from any FTP Client using PASV mode.
> >
> > However, if you are still unable to connect disable the Block
"FTP_bounce"
> > attacks and FXP. This option has been known to cause complications with
some
> > connections.
> >
> > *** END OF HELP FILE. ***
> >
> > Here is the log file from ServU:
> >
> > *** START OF LOG FILE ***
> >
> > Mon 12Apr04 18:55:09 - Serv-U FTP Server v5.0 - (5.0.0.4) - Copyright
(c)
> > 1995-2004 Cat Soft, All Rights Reserved - by Rob Beckers
> > Mon 12Apr04 18:55:09 - Cat Soft is an affiliate of Rhino Software, Inc.
> > Mon 12Apr04 18:55:10 - Using WinSock 2.0 - max. 32767 sockets
> > Mon 12Apr04 18:55:11 - Loaded SSL/TLS libraries
> > Mon 12Apr04 18:55:11 - FTP Server listening on port number 43542, IP
> > 127.0.0.1
> > Mon 12Apr04 18:55:12 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS:
Port
> > number 21 already in use!
> > Mon 12Apr04 18:55:12 - Valid registration key found
> > Mon 12Apr04 18:55:52 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS:
Port
> > number 21 already in use!
> > Mon 12Apr04 19:03:23 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS:
Trying
> > to use non-existent IP address?
> > Mon 12Apr04 19:08:37 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS:
Port
> > number 21 already in use!
> > Mon 12Apr04 19:21:44 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS:
Port
> > number 21 already in use!
> >
> > *** END OF LOG FILE ***
> >
> > I am unable to connect by typing: ftp://MY.IP.ADD.RESS/
> > What am I doing wrong or what needs to be done?
> > Please help out. Thanks in advance.
> > Gino
> >
> >
>
Anonymous
April 15, 2004 6:13:30 AM

Archived from groups: microsoft.public.broadbandnet.hardware,microsoft.public.windowsxp.help_and_support (More info?)

While this page is made for Linksys routers, the EXACT same principles apply
to other routers such as the MN500 (except for the fact that you do NOT have
to turn off DHCP.

http://linksysftp.org

Make sure nothing is using port 21 on the computer that you wish to use the
serv-u ftp server on.

--
Jason Tsang - Microsoft MVP

Find out about the MS MVP Program -
http://mvp.support.microsoft.com/default.aspx

" - 781 -" <lets@have.org> wrote in message
news:u3f4j6qIEHA.1048@TK2MSFTNGP12.phx.gbl...
> Thank you all for replies.
>
> One thing I don't understand is:
> FTP Server listening on port number 43542, IP 127.0.0.1
> Where does port 43542 come from within serv-u?
> Is this the port to be changed? If so, I can't find where this number is
> typed in Serv-U.
> And it's not the same port number as I specify in FTP server port box.
>
> Please respond.
> Thanks
> Gino
>
>
> "joker" <no-spam@netzero.com> wrote in message
> news:%23Yvb18TIEHA.4092@TK2MSFTNGP11.phx.gbl...
> > Are you trying to connect to your FTP server from behind the router? If
> > you are you will need firmware version 1.09.* or higher to have the loop
> > back support enabled.
> >
> > - 781 - wrote:
> >
> > > I am running Windows XP Pro, using cable connection.
> > > I have purchased ServU FTP Server and have been working with it
> perfectly
> > > untill I got MN-500 router. There are instructions on how to setup the
> port
> > > forwarding but I'm unable to get my server running with MN-500.
> > >
> > > Here are the help instructions from ServU:
> > >
> > > *** START OF HELP FILE ***
> > >
> > > Configure the router to forward ports 20 and 21 to the internal IP
> address
> > > where Serv-U is listening. This allows the FTP traffic to be routed
> through
> > > the router and into Serv-U. There should be options in the router to
> forward
> > > these ports.
> > >
> > > In Serv-U setup the IP for Passive mode to reflect the actual IP
Address
> and
> > > not the Internal IP address Serv-U sees:
> > > a.. Select "Settings" under your domain.
> > > b.. Select the "Advanced" tab.
> > > c.. Enter the external IP address of your internet connection. If
you
> are
> > > using Serv-U with a dynamic IP address, leave this field blank.
> > > d.. Set up the PASV port range option in Serv-U. Under "Local
Server"
> > > select "Settings" and then the "Advanced" tab. Here you will see the
> PASV
> > > port range option.
> > > When setting up the PASV port range, we recommend opening up ports
> 2000 -
> > > 2010. Then open up the same port range in your router and map them to
> the
> > > Serv-U server.
> > >
> > > You should now be able to connect from any FTP Client using PASV mode.
> > >
> > > However, if you are still unable to connect disable the Block
> "FTP_bounce"
> > > attacks and FXP. This option has been known to cause complications
with
> some
> > > connections.
> > >
> > > *** END OF HELP FILE. ***
> > >
> > > Here is the log file from ServU:
> > >
> > > *** START OF LOG FILE ***
> > >
> > > Mon 12Apr04 18:55:09 - Serv-U FTP Server v5.0 - (5.0.0.4) - Copyright
> (c)
> > > 1995-2004 Cat Soft, All Rights Reserved - by Rob Beckers
> > > Mon 12Apr04 18:55:09 - Cat Soft is an affiliate of Rhino Software,
Inc.
> > > Mon 12Apr04 18:55:10 - Using WinSock 2.0 - max. 32767 sockets
> > > Mon 12Apr04 18:55:11 - Loaded SSL/TLS libraries
> > > Mon 12Apr04 18:55:11 - FTP Server listening on port number 43542, IP
> > > 127.0.0.1
> > > Mon 12Apr04 18:55:12 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS:
> Port
> > > number 21 already in use!
> > > Mon 12Apr04 18:55:12 - Valid registration key found
> > > Mon 12Apr04 18:55:52 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS:
> Port
> > > number 21 already in use!
> > > Mon 12Apr04 19:03:23 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS:
> Trying
> > > to use non-existent IP address?
> > > Mon 12Apr04 19:08:37 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS:
> Port
> > > number 21 already in use!
> > > Mon 12Apr04 19:21:44 - SERVER IS NOT LISTENING ON IP MY.IP.ADD.RESS:
> Port
> > > number 21 already in use!
> > >
> > > *** END OF LOG FILE ***
> > >
> > > I am unable to connect by typing: ftp://MY.IP.ADD.RESS/
> > > What am I doing wrong or what needs to be done?
> > > Please help out. Thanks in advance.
> > > Gino
> > >
> > >
> >
>
>
!