On board graphics work, but video card doesn't?

The other day I finished my first computer and when I turned it on everything started fine, but there was no display on my monitor. After a while of fooling around with different things I realized that when the graphics card was receiving power things were showing up on the monitor. When I tried it again with the graphics card receiving power I got nothing. If anyone knows how to resolve this problem they'd be making a first time builder VERY happy.
1 answer Last reply
More about board graphics work video card doesn
  1. GameGuyG said:
    The other day I finished my first computer and when I turned it on everything started fine, but there was no display on my monitor. After a while of fooling around with different things I realized that when the graphics card was receiving power things were showing up on the monitor. When I tried it again with the graphics card receiving power I got nothing. If anyone knows how to resolve this problem they'd be making a first time builder VERY happy.


    Hi - a couple of things: OK - 4!

    1st) - did you make sure you connected the monitor cable
    to the graphics card output interface and not the mobo
    integrated gfx connector? Sometimes folks forget to switch.

    2) Not all mobo's automatically detect when a discrete gpu is
    attached. You prob need to go into BIOS (usually by hitting the del key during post),
    and "enable" the pci-e setting. You shouldn't need to, but you
    might want to disable integrated graphics if that option is available,
    it is prob preset to auto.

    3) Insure you download the drivers for your discrete graphics card
    from either AMD/NVidia website depending on which flavor you have.

    4) might also not be necessary (but I would do it) & run driver sweeper
    or a similar free program and delete the on board gfx drivers.
Ask a new question

Read More

Graphics Cards Graphics