Sign-in / Sign-up
Your question

Gateway & Router Subnet Issue/Port-Forwarding

Tags:
  • Routers
  • Gateway
  • IP
  • Networking
Last response: in Networking
March 13, 2012 7:43:28 PM

So here is the situation, and thus far looking through various threads I have not been able to find the answer.

I have a Motorola SURFboard SBG6580 gateway connected to a NETGEAR WNDR3700 router, off of which everything else is connected.

The gateway has the IP 192.168.0.1 and the router has the IP 192.168.1.1. The problem is that I'm hosting a Minecraft server and some other servers like TeamSpeak and while my roommates can connect using the local of my machine which I have set to a static IP of 192.168.150, no one can connect using the WAN IP. I have the ports properly forwarded on both the gateway and on the router, or I believe they are to be, but still no dice.

Typically I just DMZ my machine to eliminate any hassle, but the gateway will only let me DMZ hosts in the same subnet i.e., x.x0.x, but my machine is in the x.x.1.x subnet.

When i tried just changing the IP of the gateway to 192.168.1.1 and changing the IP of the router to 192.168.1.2 and setting the DHCP range of the router to x.x.x.3-149, it just changed the IP of the router to 10.0.0.1.

Any help on getting them into the same subnet or properly port-forwarding would be greatly appreciated.

Sorry if this double posted. My internet cut out when I hit submit.

More about : gateway router subnet issue port forwarding

March 13, 2012 8:31:46 PM

Have you turned off the DHCP on the Surfboard?
You should start by checking that.
Also If you have a firewall on the router you may want to disable it, if a firewall is running on the Gateway. At least until you get it all running as you want, you can turn it back on later.

The IP setup you mentioned is correct and should work, although it is odd that the IP on your router changed to 10.0.0.1.

Another setup you could try is to change the IPs on your router to 192.168.0.2, do the same for the DHCP pool (192.168.0.3-149) and that should also work.
Dont forget to check that they all have the same Subnet Mask.

Let us know how it goes..
m
0
l
March 16, 2012 9:16:18 PM

Just now getting around to fixing this since my roommate is at work. I disabled DHCP on the SURFboard as well as disabled NAPT to see if that would help, but with NAPT on or off, anytime I try to set the IP of the SURFboard to 192.168.1.1 I get the following message:

  1. IP Address range is Invalid
  2. Make sure the Primary Network and Guest Networks do not overlap IP pools:
  3. Primary Network - Gateway: 192.168.0.1, IP Pool: 192.168.1.2 - 192.168.1.254
  4. Guest Network 0 - Gateway: 192.168.1.1, IP Pool: 192.168.1.10 - 192.168.1.99
  5. Guest Network 1 - Gateway: 192.168.2.1, IP Pool: 192.168.2.10 - 192.168.2.99
  6. Guest Network 2 - Gateway: 192.168.3.1, IP Pool: 192.168.3.10 - 192.168.3.99
  7. Guest Network 3 - Gateway: 192.168.4.1, IP Pool: 192.168.4.10 - 192.168.4.99
  8. Guest Network 4 - Gateway: 192.168.5.1, IP Pool: 192.168.5.10 - 192.168.5.99
  9. Guest Network 5 - Gateway: 192.168.6.1, IP Pool: 192.168.6.10 - 192.168.6.99
  10. Guest Network 6 - Gateway: 192.168.7.1, IP Pool: 192.168.7.10 - 192.168.7.99


The WNDR3700 is currently set to an IP of 192.168.1.2 with a DHCP range of x.x.1.3-149 (I'm reserving 150-255 for specific devices).

I've also disabled any firewall settings I could find on the SURFboard. Searching Google has again yielded little helpful results.
m
0
l
Related resources
March 16, 2012 9:25:28 PM

I should point out that I cannot locate any options for a guest network despite the user manual I found online showing that there should be a very clear option. This Modem is provided to me from my ISP, Time Warner Cable.
m
0
l
March 18, 2012 10:41:18 AM

So if I understand correctly, your Modem is not the Surfboard or the WNDR3700?
If that's true and the message you get when trying to set the Surfboard IP is coming from the modem then that's a different story.
If you have no access to the modem supplied by your ISP you will have to disable DHPC on both WNDR3700 and Surfboard then assign IPs to both devices following the "Primary Network" setup of the modem.

Assign Surfboard:192.168.1.2 - 255.255.255.0 - GW:192.168.1.1 - DNS:192.168.1.1
Assign WNDR3700: 192.168.1.3 - 255.255.255.0 - GW:192.168.1.1 - DNS:192.168.1.1
Any other devices on your network will have to get new addresses 192.168.1.4...

There is a chance other connected devices connected to your network may have one of these addresses so you should probably disconnect other network cables when setting up Surfboard and WNDR. After you have configured these two devices and saved settings, reconnect the rest of the network and they will be assigned new addresses in this range.

m
0
l
March 19, 2012 5:25:04 PM

_envy said:

The gateway has the IP 192.168.0.1 and the router has the IP 192.168.1.1. The problem is that I'm hosting a Minecraft server and some other servers like TeamSpeak and while my roommates can connect using the local of my machine which I have set to a static IP of 192.168.150, no one can connect using the WAN IP. I have the ports properly forwarded on both the gateway and on the router, or I believe they are to be, but still no dice.


192.168.0.1 is not your WAN IP. You can find your WAN IP by going to

http://www.whatsmyip.org/

Be sure they are trying to connect to the correct address.
m
0
l
March 25, 2012 1:12:16 AM

The modem is the SURFboard. Sorry for any misunderstanding.

Just to clarify, my roommates can connect using the static local IP of 192.168.1.150, but no one can connect using the WAN IP which, as stated is not the same. I just don't want to post it here. :non: 

Anyway, still working on this issue. For the time being I've removed the router from the situation, but as one could imagine, I don't have the necessary time to just not have the internet working, so progress is slow and during off hours when the others are at work/sleeping.
m
0
l
March 26, 2012 7:39:20 AM

If the only way your room mates can connect to your WAN IP is when you are in the DMZ, the problem is comming from the Surfboard's firewall or security settings. Thats something you will have to look into yourself.
You would probably want to allow certain IPs through, but that would be difficult to setup since the WAN IP is not always the same, every time your router reconnects the WAN IP changes and so do the WAN IPs of your friends.
m
0
l
September 25, 2012 12:33:09 AM

I would be interested to know if you've reached a solution for this, as I'm having the same problem.

We have a minecraft server using craftbukkit set up on a desktop (Inspiron 530), with firewall allowing the port access, port forwarding on the router (NetGear WGR614v10), and a static IP for the Inspiron. Two other computers will connect to the server via the internal static IP, but Nothing will connect via the external IP. Using port checker tools like canyouseeme.org and yougetsignal.com shows that the port for the external IP is closed, and even that the internet port (80) is closed.

I was able to log onto the modem (Motorola Series M CPEi25725 provided by Clear) and change the firewall settings first to allow ping from the internet, then turning off the firewall altogether, and with both settings port 80 was still closed, let alone port 25565. I also set up port forwarding with the modem, the only way possible being to forward the port to the router's IP, in addition to forwarding the port with the router to the desktop's IP (so the modem forwards the port to the router and the router forwards the port to the Inspiron, or at least should). Still finding port 25565 to be closed, and unable to connect to the server using the external IP.

I have checked, double checked, and triple checked all my settings and am at a loss as to what to check or try next. In all my searching online, this thread is the only thread I could find describing the same problem, and everyone's solution is the same: check your firewall settings, check that the box hosting the server has a static ip, check that your ports are forwarded correctly. And as far as I can tell, all of these things are set as they should be.

I noted we both have/had a Motorola modem and a NetGear router... perhaps there's a communication/compatibility issue there?

Again, I'd appreciate any help you can give me if you have been able to figure this out, or get closer to an answer. Thanks.
m
0
l
January 31, 2013 5:39:52 PM

Shea_Dalziel said:
I would be interested to know if you've reached a solution for this, as I'm having the same problem.

We have a minecraft server using craftbukkit set up on a desktop (Inspiron 530), with firewall allowing the port access, port forwarding on the router (NetGear WGR614v10), and a static IP for the Inspiron. Two other computers will connect to the server via the internal static IP, but Nothing will connect via the external IP. Using port checker tools like canyouseeme.org and yougetsignal.com shows that the port for the external IP is closed, and even that the internet port (80) is closed.

I was able to log onto the modem (Motorola Series M CPEi25725 provided by Clear) and change the firewall settings first to allow ping from the internet, then turning off the firewall altogether, and with both settings port 80 was still closed, let alone port 25565. I also set up port forwarding with the modem, the only way possible being to forward the port to the router's IP, in addition to forwarding the port with the router to the desktop's IP (so the modem forwards the port to the router and the router forwards the port to the Inspiron, or at least should). Still finding port 25565 to be closed, and unable to connect to the server using the external IP.

I have checked, double checked, and triple checked all my settings and am at a loss as to what to check or try next. In all my searching online, this thread is the only thread I could find describing the same problem, and everyone's solution is the same: check your firewall settings, check that the box hosting the server has a static ip, check that your ports are forwarded correctly. And as far as I can tell, all of these things are set as they should be.

I noted we both have/had a Motorola modem and a NetGear router... perhaps there's a communication/compatibility issue there?

Again, I'd appreciate any help you can give me if you have been able to figure this out, or get closer to an answer. Thanks.

I don't know about your modem, but the SBG6580 has a setting to disable the gateway mode and essentially make it act like a regular cable modem. Click on the basic tab on the top of the screen, then find NAPT mode and disable it. Click on apply, let the modem reboot, reboot your router and you should be good to go.
m
0
l