Sign in with
Sign up | Sign in
Your question

Sapphire Radeon HD 7850 Not Displaying in Device Manager

Last response: in Graphics & Displays
Share
February 8, 2013 12:49:31 AM

I recently built my own computer and everything seems to be working except for the graphics card which is a Sapphire Radeon HD 7850 2GB. When I power up the computer both the fans on the card spin so I'm pretty sure it's powered. Whenever I try to plug my graphics card into my monitor (whether it be through HDMI or DVI) the monitor just says "No Signal" and goes into sleep mode.

I am able to use my computer because my Motherboard has integrated graphics. My motherboard is the Gigabyte GA-Z77x-UD3H model. I have tried going into the BIOS and setting the initial display first as both PCI and PEG but with not result. I have also tried disabling Internal Graphics but that just makes it so I get no signal from my integrated graphics and I have to reset the CMOS to get a display again.

When I get on my computer and go to Device Manager and I go under Display Adapter I only see Intel HD 4000, or something similar to that, and no Sapphire Card.

One more thing, I have tried Installing the drivers online and with the disk provided but that also did nothing, currently the drivers are uninstalled.

My PC Specs:
GPU: Sapphire Radeon HD 7850 2GB
CPU: Intel i5-3570k Ivy Bridge
MBA: Gigabyte GA-Z77X-UD3H
RAM: Corsair Vengeance 16GB (2 x 8GB)
PSU: OCZ ModXStream Pro 700W

Any help will be appreciate because I just want to get my rig up and running so I can play games! Thanks! :D 
February 8, 2013 12:57:34 AM

hmmm looks its like dead to me it should be plug & play no need to touch your bios settings have it replaced

or have a friend test it for you on his rig .
m
0
l
February 8, 2013 8:42:17 PM

Alright, that is what I was starting to suspect. Oh well, I'll just send it back to Newegg and I think I'm gonna buy a Gigabyte Geforce GTX 660 instead. I heard the Nvidia products work better with Intel processors anyway. Thanks! :sol: 
m
0
l
Related resources
!