Sign in with
Sign up | Sign in
Your question

Can't connect through switch

Tags:
  • Routers
  • Switch
  • Connection
  • Networking
Last response: in Networking
Share
March 14, 2012 9:26:35 AM

I've been hunting for a solution to my problem and haven't been able to find an answer. Maybe you guys can help. Here's my problem. I added a switch (TP-Link TL-SG1005D plugged into a D-Link DGL-4100 router)) so I could add a computer or two to my network. I have my Vonage modem plugged into the switch and it works fine, but when I try to plug a computer into it, nothing. I've been trying to use an XP machine that I rebuilt, and I keep getting the "limited or no connectivity" message. I've tried all the fixes I could find for that, and still no joy. I even plugged it right to the modem with no luck so I tried plugging my Windows 7 machine into the switch and it couldn't find the network either, but it works fine plugged into the router. When I go into the router, it has an IP address assigned to the switch, but the phone modem does not show up, where it did when plugged directly into the router. Is this normal?

Am I missing something simple here as far as the switch goes? The XP machine won't find the DHCP server and has the 169.254.XXX.XXX IP address with a MAC address of FF-FF-FF-FF-FF-FF. I've tried Microsoft's hotfix and releasing and renewing the IP...nothing. I know that's separate problem than the switch, but they're both driving me nuts trying to figure it out.

Sorry for the somewhat long post, but I'm trying to add all the details I can to try and resolve this. Thanks in advance!

More about : connect switch

March 14, 2012 2:15:50 PM

169.254.x.x. is an external ISP IP address that your computer is indicating, where in your desired setup it should show an internal network address.

You need to enable DHCP on your router. Attach the cable modem to the Vonage modem Internet port, then attach the Vonage Ethernet port to the router WAN port, attach the router to the switch LAN port to LAN port, plug your computer into another LAN port on the switch, set the computer to obtain an IP address from the router gateway automatically. Then the computer should have an internal network address like 192.168.x.x for example.

If you have DSL, follow the specific instruction on the second page of the link below to configure the Vonage unit before placing it into the described setup.

Here is a picture that should help guide you: http://www.vonage.com/support/files/pdf/VPORTAL_QuickSt...
m
0
l
March 14, 2012 3:27:31 PM

I'll give it a shot...thanks!
m
0
l
Related resources
March 21, 2012 7:08:20 AM

I fixed the switch issue, but that XP machine still won't network. The router sees it, but it won't connect, even when I manually enter the IP that the router assigned to it. The limited or no connectivity message goes away, but it still won't connect to the internet. When I set everything to automatically find IP, etc., I get the message. I can't figure it out.
m
0
l
March 21, 2012 8:45:40 AM

does the TP-Link TL-SG1005D have any dhcp options if they are turned on could course problems like you have
m
0
l
March 21, 2012 8:28:25 PM

ancientcityRT said:
I fixed the switch issue, but that XP machine still won't network. The router sees it, but it won't connect, even when I manually enter the IP that the router assigned to it. The limited or no connectivity message goes away, but it still won't connect to the internet. When I set everything to automatically find IP, etc., I get the message. I can't figure it out.

What do you get when you type ipconfig in the XP command prompt box?
m
0
l
March 28, 2012 7:04:15 AM

If it's on automatic, I still get the 169.254.xxx IP. If I enter it manually, I get what I entered.
m
0
l
March 29, 2012 12:18:17 AM

Sounds like the router DHCP service is not turned on, so it just acts as a switch rather than a router.
m
0
l
March 29, 2012 7:38:56 AM

It's on. I've tried DCHP release and renew...nothing.
m
0
l
March 29, 2012 9:18:38 PM

No, not release and renew -- is the DHCP service enabled on the router and what IP address range is it allowed to assign?
m
0
l
!