Sign in with
Sign up | Sign in
Your question

I want to remote desktop to 2 different computers that are on the same network b

Last response: in Networking
Share
March 14, 2012 1:21:03 PM

I am remotly wanting to connect to my laptop and my desktop. both of which are at home on the same network....router can I use remote desktop to connect to both? i have a NO-IP address so I connect to it and of course I have port 3389 forwarded to the internal static ip of my laptop but is there a way to also seperatly connect to the desktop?
a b D Laptop
March 14, 2012 1:32:22 PM

Yes, this can be done. you will need a static IP on your desktop. There is a registry entry that controls the port remote desktop listens on. Change the desktop to port 3390 or some other unused port number. Configure your router to port forward this port to the desktop: solved! ;) 

http://support.microsoft.com/kb/306759
m
1
l
a b D Laptop
March 14, 2012 1:33:02 PM

Almost forgot, you may need to reboot after the registry change.
m
0
l
Related resources
March 14, 2012 2:30:57 PM

I tried this and I cannot get it to work
I changed the port to 3390
forwarded incoming traffic on port 3390 to my static ip on desktop...192.168.1.5
on remote desktop i go to scottla.myftp.org:3389 and wont connect. I have a No-ip address that resolves to my isp supplied ip address so this shouls work and in fact does when I try to connect to the other computer but on that one I dont have to put a port number in....wondering if the conflict is there......
m
0
l
a b D Laptop
March 14, 2012 3:28:22 PM

If the computer you are trying to remote in from is on the same network, you will need to use the IP address, 192.168.1.5:3390. If you are trying to access it from off your network, than you would use your WAN IP address: port# (no space after colon - stupid smilies).

You do have an address that resolves to your ISP or you would have no internet connectivity. This is your WAN IP:

http://www.whatismyip.com/
m
0
l
March 14, 2012 3:50:56 PM

I am doing exactly that. I have a NO-IP name that resolves to my isp given ip address so I use that with :3390 and again it wont connect but it will if i use 3389 as the port in the registry and forward to this computer in the router......I can't understand why it wont work....
I know what my WAN IP is
thanks for assistance
m
0
l
March 14, 2012 4:04:07 PM

there has to be something else I am missing I have done all of the things mentioned here and to no avail....
m
0
l
March 14, 2012 4:32:36 PM

if i change the port in the registry and in the router i can get it to connect on port 3389 but no where else. I am thinking it has something to do with the port. I even changed machines and it will connect just not on another port #. Is there perhaps another parameter that is missing here??
m
0
l
a b D Laptop
March 14, 2012 4:34:48 PM

You did reboot the computer after editing the registry, right? Yes, it's that simple. I've done it on several computers and it works every time. If you used the "fixit" button on microsoft's site, I recommend you dig into the registry editor and confirm the change. I always do mine manually, not via the fixit button.
m
0
l
March 14, 2012 4:49:39 PM

I did reboot, I also made the change manually. I also went back after the reboot and checked the registry and it was in fact set to the changed port I set it to....??????? I am so lost for what the problem is here
m
0
l
a b D Laptop
March 14, 2012 4:56:00 PM

If you open a command prompt and type

netstat -a

followed by the ENTER key, do you see port 3390 as LISTENING? Also, did you verify that port 3390 was not in use prior to you making the registry entry? If not, it will cause problems.
m
0
l
March 14, 2012 5:06:45 PM

the port 3390 is listening..... I was not using that port for any other reason.
m
0
l
a b D Laptop
March 14, 2012 5:17:05 PM

That's odd. If you are certain that you edited the correct registry key and you are positive that you correctly port forwded in your router, then all should be working. The only other thing I can suggest is double check your firewall (assuming windows) and make sure port 3390 is allowed. Just selecting the remote desktop protocol in the windows firewall will not work since it assumes port 3389.

Other than that, I'm out of ideas.
m
0
l
March 14, 2012 5:21:40 PM

I changed the ports on the 2 machines I am tring to connect to and now I can connect to the other one and not the first one the 3390 port is listening and it will not connect.......
m
0
l
a b D Laptop
March 14, 2012 5:58:48 PM

Like I said, I'm out of ideas. you can always try a different port number. I use 4006, but as stated earlier, make sure that port isn't already in use on your computer.

Also, you didn't mention if you checked your firewall.
m
0
l
March 14, 2012 6:09:31 PM

One more question...for some reason it didnt post....How do I open a specific port in windows firewall. I googled it but it doesnt match what i see...I am running win 7 prof 32 bit os thanks
m
0
l
March 14, 2012 6:26:58 PM

HA HA!!!! I got it!! It was in fact the firewall!!! I figured it out and opened the port!!! Thank you for your help!
m
0
l
a b D Laptop
March 14, 2012 6:44:35 PM

Awesome!!! I knew something so simple shouldn't be that hard. I'm glad you got it working.
m
0
l
March 14, 2012 6:58:15 PM

Thanks!!
I felt the same way.
I am in school for all of this stuff and knew there had to be a way to make it work....
I'll never forget ho to do it now!!! :-)
m
0
l
October 7, 2013 2:06:41 AM

I've been using RHUB for its multi-tiered collaborative support. I also like RHUB b/c it allows more than one user to access the same computer remotely, so my wife and I can still use our desktop while on the road from different locations.
m
0
l
November 27, 2013 7:24:45 AM

Would you please tell me what you exactly did? How did you assign the port 3390 to the firewall? I have the same problem. Thanks.
m
0
l
November 27, 2013 8:31:47 AM

ha2013 said:
Would you please tell me what you exactly did? How did you assign the port 3390 to the firewall? I have the same problem. Thanks.


m
0
l
November 27, 2013 8:43:06 AM

You will need to go into the registry and change the port for remote desktop on the 2nd machine.(it will require a reboot afterwords), Google change remote desktop port ) and you will find it easy to do. Then you will also need to give each machine a static IP address. You will also have to set up port forwarding in your router for each machine matching the IP address with the port for remote desktop .Go into the firewall as well and open the port on each machine for remote desktop for that machine. You will also have to right click computer and go to properties and go into remote settings and enable remote desktop on each machine. Now you said you are using no-ip. Does this mean you are using No-ip for DNS? If so you have your own resolve instead of IP. so use whatever your (name resolved is? blahblah.myftp.org:3389) use your dns name with a colon and the port. this will direct it to no-ip which will resolve to your ip address and send it to your router which will forward to the appropriate machine by port # and you will be able to connect..make sure you have the name correct computername\loginname or you will get an error. Also you will be prompted with a problem with the certificate... (identity cannot verify)... click yes here and you should be able to connect
m
0
l
May 21, 2014 4:57:10 AM

After many hours of fighting with this, I have figured it out. I'm not an expert but what you need to remember is:
Everything assumes you are on port 3389. This includes the computer (can change it in the registry). Windows Firewall (remote desktop enabled is not enough, you have to create an inbound rule for the new port.)
If you are coming in from outside your network, your router assumes 3389. You have to steer it to the new port. In my router I had to create a service, add it to port forwarding and allow it through the router firewall.
I hope this helps someone. It would have helped me!
m
0
l
July 1, 2014 7:54:48 AM

Hawkeye22 said:
Almost forgot, you may need to reboot after the registry change.


Hawkeye, indeed you do! Just verified this after two days of trying to get remote desktop to non-standard ports working in my environment. Using a Netis WF2419, but it would not allow internal port re-use. On this router, external ports (3390, 3391, etc.) have to be routed to unique internal ports, and not just 3389. I modified the listening port in via regedit, but did not reboot. A reboot changed the port. Thanks!

m
0
l
less than a minute ago

Instead of all that registry jazz just have external ports forwarded to internal RDC ports on each machine you want to access remotely..way easier.

External IP:5900>192.168.0.2:3389
External IP:5901>192.168.0.3:3389
External IP:5902>192.168.0.4:3389

etc..
m
0
l
!