Sign in with
Sign up | Sign in
Your question

DVD in DMA mode

Last response: in Storage
Share
March 17, 2002 10:48:32 PM

I've tried just about every way to enable DMA on my Liteon DVD-ROM (in device manager, Ali's IDE driver and cache utility, and in bios) and I still see, on start-up, that it's in PIO mode. When I tried to use WinDVD for the first time it also said that my drive didn't have DMA enabled. I checked my drive info in Sandra and it says DMA is enabled. ?!?

Liteon LTD-163 (16X DVD-ROM)
Iwill XP333
Win98se

P.S. My DVD performance sucks now that I'm running on my XP333 W/ XP1600+. When I had the DVD-ROM on my old A7V W/ 800mHz Athlon my DVD performance was great. I have a feeling this is because I can't get the drive to run in DMA mode. Thanks for any help.

More about : dvd dma mode

March 22, 2002 12:04:23 AM

Oh, and re-installing the driver hasn't helped, nor has trying to use different DVD software.
March 24, 2002 3:59:02 AM

just a thought but make sure you have the VALID DMA settings enabled in your BIOS as well as any required motherboard IDE drivers.

and I definately agree that is what is affecting DVD performance.
Related resources
March 24, 2002 4:05:06 AM

sorry, kinda tired, I see you have tried IDE drivers and BIOS settings..........is the DVD the only device on whatever IDE channel it is hooked up to?
March 25, 2002 5:44:02 AM

There's a ZIP 100 as the slave on the same channel. I have the ZIP set to DMA mode also (I checked with Iomega and the ZIP should work fine in DMA).
March 25, 2002 6:22:34 AM

try it without the zip on the channel just to test.....it may be preventing the DVD from utilizing it's FULL DMA Speed.
Anonymous
a b G Storage
March 28, 2002 6:15:39 PM

Try this. I managed to reset my PIO mode to UDMA Mode 2:

1) Device Manager - Uninstall the relevant IDE channel
2) Reboot, configure everything in BIOS - enable Auto/UDMA
3) Device Manager - View Properties for the relevant IDE channel --> Use DMA when available
4) Reboot

Voila. Should work for anyone.

Then again, my setup has an extremely peculiar problem of suddenly going back to PIO mode when I'm using the Secondary IDE Primary channel ie installing some huge software using the DVDROM on my KT333 with 4 IDE devices connected. I suspect it's a VIA/WinXP driver issue though, cause this problem doesn't occur when I have a spare Secondary IDE Slave
March 30, 2002 9:46:27 AM

*trumpets*
REMOVE THE ZIP DRIVE!
*trumpets*


Anything i think of as 'Decent' is unlikely to ever become 'OEM'
March 31, 2002 2:36:28 AM

Doh! I was hoping that wasn't it. Oh well. Now if I only had one more IDE channel...
March 31, 2002 3:10:34 AM

my previous computer had a ZIP drive.

new one doesnt... any large scale file backups is done quite easity with my cd-rw and rewritable media.

dont miss the zip in the least

Anything i think of as 'Decent' is unlikely to ever become 'OEM'
March 31, 2002 5:20:38 PM

yeah, never enough IDE channels....now if you only had a CD-RW you could follow the advice above :) 

Besides buying a CD-RW, you could also get an ATA100 controller card although having a burner would let you get rid of the zip.

Also, I suppose you could only hook up the ZIP when you need it, my PC is always open so thats how I would do it if I had no spare cash.
!