Sign in with
Sign up | Sign in
Your question

Nvidia 660 Ti Freeze

Last response: in Graphics & Displays
Share
February 10, 2013 8:22:02 AM

Hello guys,
I wrote on this forum some times ago for the same problem. I thought it was the video card faulty but after a replacemente I got the same problem and now I am really lost and do not know what to do.
Let me explain better.

I have my new pc since one month

Intel i7 3770 3.4ghz
Asus P8Z77-V LE PLUS
2x8 gb ram Corsair 1866
Intel SSD 180gb
2x HD 1tb and 500gb western digital
Zalman cpu cooler CNPS 9900A Led
PSU Scythe "Chouriki 2 " 750w

and of course a MSI GeForce GTX 660 Ti Power Edition

The problem is that video card when is working makes a really strange noise (they are not the 2 fans, i tried to put them at 100% and their noise is completely different) and besides the noise the games freeze. Sometimes it goes back to windows other i ve to force a reboot.
The noise makes stronger when video card is working more. If i put all the details to low there is no noise and it seems no game freeze. I asked for RMA and a new video card arrived (different serial number so it is another one) but same problem.
I have an old ati sapphire hd 5770 vapor-x. If i put it, of course graphic is not the same ^_^ but at last no stuck no noise nothing.

The only thing that come in my mind is the PSU but actually Scythe should be a good brand and the spec of my psu are the same with other psu of the same level. The only difference, is that i got two +12v channels instead of one like other psu.

Here you can check my PSU: http://www.scythe-usa.com/product/power/007/spcr2_detai...

DO you think that if i change the psu i can resolve the issue?
I was wondering to buy a Thermaltake SMART M850W. IS that good enough?

Or you think that the problem can be something else?


Thank You
Best Regards :) 

More about : nvidia 660 freeze

a b U Graphics card
February 10, 2013 8:46:04 AM

If you want to buy a new psu then buy a good brand psu like corsair, antec, xfx. You can check your gpu to another system if the same problem exist.
February 10, 2013 8:52:22 AM

I used the gpu on my old pc waiting for all the other components to arrive.
the psu was the same and it did not gave any problem, no freeze at all.

Maybe now the new processor and because i have one HD more is stressing the psu and when video card has to work hard it gives some problem.


Now i do not have another system where to try the gpu.


So do you think i can be something else? I mean same configuration different video card my old ati no problem at all.
Related resources
a b U Graphics card
February 10, 2013 8:56:33 AM

660ti dont show any problem on your old pc with same psu? Then it maybe the mobo that is conflicting with your gpu somehow.
February 10, 2013 9:04:06 AM

Yes exactly, now i do not remember the model but it was asus.
The problem is that there is no real test to understand if there is a conflict between mobo and gpu i suppose.

I would like to fix the problem but i do not know from where it comes from. Sigh!
a b U Graphics card
February 10, 2013 9:07:55 AM

Thats confusing as 5770 is running fine. Did you install driver properly?
February 10, 2013 9:21:16 AM

Yes, i download latest driver from Nvidia web site for my operating system and then runned the .exe ^^ like usual
i ve also tried the nvidia with fresh windows, just after have formatted everything.
Moreover i ve 2 pci express slot on mobo, i tried both of them but with the same result.

Honestly i ve build so many pc and this is the first time i m having all this. Really annoying :) 


!