Crossfire is disabling itself?

Hello, I'm using catalyst control center 13.2 and whenever I chose to enable crossfire and hit apply it automatically switches back to disabled. This isn't a graphics bug because I can go into hardware information and the second card will be under disabled adapters. I'm using 2 HD Radeon 6970's and I'm on windows 8.
Can anyone help me with this?
4 answers Last reply
More about crossfire disabling itself
  1. Is this probem specific to CCC 13.2 ? What about CCC 13.1 ?

    As a side note, CCC 13.2 is beta software.

    Can you give some information about your computer, such as PSU, M/B, OS, etc. ?
  2. I installed the beta because catalyst 13.1 was giving me serious problems with crossfire enabled in game (constant screen flashing), which 13.2 fixed. I will note, however, that I had sent one card in for an RMA and had just installed it to the board after updating to CCC 13.1 a few days prior if that would make a difference.


    OS: Windows 8
    CPU: Intel Core i7-2600K Sandy Bridge 3.4GHz
    MB: ASRock P67 EXTREME6 (B3) LGA 1155 Intel P67 ATX Intel Motherboard
    PSU: Sentey Golden Steel Power GSP850-SM 850W ATX 12V v2.2 & EPS 12V v 2.91 SLI Ready CrossFire Ready 80 PLUS GOLD Certified
    RAM: 4x4GB 1600 MHz DDR3
  3. I just uninstalled CCC as well as all the components and drivers and reinstalled version 13.1. Same problem.
  4. Do you have UEFI motherboard ? Check if your Wndows 8 is installed on UEFI BIOS. If true, UEFI BIOS does not let you make changes in hardware settings. You have to disable UEFI security first and then make the changes. You must re-enable UEFI security later again. Please read your motherboard and/or computer documentation.
Ask a new question

Read More

Radeon Crossfire Catalyst Graphics