Integrated HD7660D GPU in A10 5800K not working properly

Hello,
I just put together my first computer build and I am running into a problem with the integrated graphics on my CPU(A10 5800K). I"m trying to play Planetside2 and I'm only getting 2-6fps on low settings, which is odd. I"ve checked Resolution>Advanced and the computer recognizes that the GPU is there and enabled...I just don't know what else to do, looked on bios and changed to onboard graphics, loaded game up and same thing happens. All hooked up throgh hdmi port. Any help is appreciated.

Build specs:
CPU: AMD A10 5800K w/HD7660D
MOBO: ASRock Fm2a85x Extreme6
RAM: Gskill Sniper 2x4gb 1600ghz
OS: Windows 7 Professional 64 bit
PSU: 530w Raidmax
16 answers Last reply
More about integrated hd7660d 5800k working properly
  1. Are you running the most current AMD driver or did you build your computer and power up?
  2. I am pretty sure I'm running on the most current catalyst driver 13.1
  3. I would just double check and maybe uninstall the driver and try again. 2-6 frames seems a bit crazy. I don't know if you are able to but you could possibly have physx enabled turn that off it you have it enabled.
  4. bigshootr8 said:
    I would just double check and maybe uninstall the driver and try again. 2-6 frames seems a bit crazy. I don't know if you are able to but you could possibly have physx enabled turn that off it you have it enabled.


    I am unistalling catalyst driver and will reinstall see if that helps
  5. @bigshootr8 Still getting low fps after reinstall. maybe i should unistall the driver of the gpu itself in screen resoulution>advanced settings>properties>driver? then reinstall that?
  6. Hmm I would uninstall the driver. And then use drive sweeper to clear out the registry inputs http://www.guru3d.com/content_page/guru3d_driver_sweeper.html and give that a go.
  7. what resolution ar eyou trying to game at?
  8. bigshootr8 said:
    Hmm I would uninstall the driver. And then use drive sweeper to clear out the registry inputs http://www.guru3d.com/content_page/guru3d_driver_sweeper.html and give that a go.


    alright I will give that a try in little bit thank you for the help so far.
  9. popatim said:
    what resolution ar eyou trying to game at?

    currently at 1280x720 on a vizio 32 inch hd tv, only thing i have close to a monitor at the moment.
  10. http://www.3dmark.com/3dm/204429? <just ran this test and it did pretty well until i got to the firestorm demo then it went to poop. Any idea what "graphics driver is not approved" means? I'm new to this stuff.

    all my drivers are up to date, I have no idea why planetside2 isn't running at around 30-40 fps like it should be.
  11. Well to be fair the firestorm benchmark is a dx11 benchmark and it is absolutely destroying cards at the moment.
  12. Can you check your gpu load to see if using GPU-z to see if it is at full load while playing. If it is maybe that is the max you can get, if not something else is wrong.
  13. Thanks a lot for everyone that had input.
  14. tonync_01 said:
    Can you check your gpu load to see if using GPU-z to see if it is at full load while playing. If it is maybe that is the max you can get, if not something else is wrong.


    thanks will try
  15. Jtrent95 said:
    thanks will try


    Jtrent95, any update on your situation? I am currently highly considering the AMD A10 5800K as a powerhouse for my new build. Want to know the result of your issue if you were able to fix it.
Ask a new question

Read More

Radeon Graphics