Sign in with
Sign up | Sign in
Your question

Installing Evga gtx 660 on windows-8 machine

Last response: in Graphics & Displays
Share
February 14, 2013 12:07:26 PM

I just recently purchased a new graphics card from evga and tried to install it in my new computer. The computer is an asus esseintio desktop with a amd a-8 5500 processor and onboard 7560d graphics. I installed the new card correctly and hooked the computer up to my monotior, i didnt get any display from either card.... (the evga or 7560d), so i called evga. The first tech guy told me it was a bad card, the second guy said it was Windows 8 secure boot, so i went through my bios with a asus tech guy and we could not figure out how to turn secure boot off... so i called evga again and the thrid guy i talked to told me to try the card on a diffrent computer to see if it works, and if it dose work he sent me a flash program via email to flash my card for windows-8 and said it should work. i have a ample power supply (roswell 450 watt).. Please help me.
February 14, 2013 1:19:31 PM

This new Eufi bios system is a pain, i know guys but theres got to be somebody out there who knows how to disable this crap.
July 22, 2013 10:26:14 AM

What are your machine specs? cmponents?
Related resources
October 12, 2013 9:39:31 PM

here is the fix: boot into your bios. go to security boot. disable that. followed by enable legacy boot. save and exit. shut down your pc. install your new card. plug everything back in. enjoy. - salpro
!