Sign in with
Sign up | Sign in
Your question

Ati HD5770 Sims 3 odd fps

Last response: in Graphics & Displays
Share
February 14, 2013 12:56:00 PM

So, my computer specs are: ATI Radeon HD5770, AMD Athlon 64 X2 Dual core, 4GB of DDR2 RAM, Windows 7 Ultimate. I think those should be enough to run The Sims 3 at least on medium settings without any lag. But it isn't like that in my situation. With the lowest settings Sims 3 fps drops to 30 and below while moving the camera in live play mode. That problem is only in the live play mode, but in the build & buy mode the game runs smooth. I do not understand what is wrong. Other games will run on ultra settings without any lag and fps drops, eg DiRT 2 I really need help. P.S I do not have any custom content. And confusing is the fact that with the highest settings game will run as good as with the lowest setting: fps drops to 30 and below in live play mode when moving camera. So changing setting to lowest does nothing.. Please help me.
a b U Graphics card
February 14, 2013 1:04:15 PM

It's the CPU. Even with an i5-3570K and GTX460 (highly OC'ed) I still drop to 30ish at certain times (average was 57fps though). However, when I was running a Core 2 Quad Q8300, it drops to 20fps and avg was around 40fps.

You clearly have a CPU bottleneck situation here.
February 14, 2013 1:06:11 PM

jimppi6 said:
So, my computer specs are: ATI Radeon HD5770, AMD Athlon 64 X2 Dual core, 4GB of DDR2 RAM, Windows 7 Ultimate. I think those should be enough to run The Sims 3 at least on medium settings without any lag. But it isn't like that in my situation. With the lowest settings Sims 3 fps drops to 30 and below while moving the camera in live play mode. That problem is only in the live play mode, but in the build & buy mode the game runs smooth. I do not understand what is wrong. Other games will run on ultra settings without any lag and fps drops, eg DiRT 2 I really need help. P.S I do not have any custom content. And confusing is the fact that with the highest settings game will run as good as with the lowest setting: fps drops to 30 and below in live play mode when moving camera. So changing setting to lowest does nothing.. Please help me.


Forgot to mention my cpu is Amd Athlon 64 x2 5200b 2,70Ghz
Related resources
February 14, 2013 1:13:12 PM

EzioAs said:
It's the CPU. Even with an i5-3570K and GTX460 (highly OC'ed) I still drop to 30ish at certain times (average was 57fps though). However, when I was running a Core 2 Quad Q8300, it drops to 20fps and avg was around 40fps.

You clearly have a CPU bottleneck situation here.


Sims 3 has 2,4Ghz CPU reqs and mine is a little better (2,7Ghz) so why does it still have low fps even with the lowest settings? :( 
February 14, 2013 1:13:14 PM

its your cpu
a b U Graphics card
February 14, 2013 1:23:04 PM

The "required" hardware just means it will run, not that it will run well.
February 26, 2013 12:32:44 PM

So I was thinking about upgrading my CPU to Phenom II X2 955 Black Edition if my old CPU is bottlenecking my system. Would that CPU perform better and how much better? And I have done some researching and it would work with my mobo.
a b U Graphics card
February 26, 2013 12:37:53 PM

It would definitely be better, but I don't know how much of an improvement you'd get because I haven't seen any sims3 benchmark.

Although to be honest, I really would recommend you get a quad core CPU at this point in time.
February 26, 2013 12:39:36 PM

Oops! I typed wrong. I meant this processor: AMD Phenom II X4 955 Black Edition 3,2Ghz. Sorry
a b U Graphics card
February 26, 2013 12:40:38 PM

Then it's fine I guess
February 26, 2013 12:41:06 PM

Great. And thank you EzioAs :) 
a b U Graphics card
February 26, 2013 12:42:29 PM

You're welcome ;) 
!