GPU Temp is not displayed anywhere

Hello guys and gals, I just finished building my first custom PC. Everything is running fine. Except that I'm worried that my GPU's temp is not being displayed in any programs I've tried GPU-Z HWmonitors etc (it just displays as 0 Celsius). My video card is: R7950 Twin Frozr 3GD5/OC Mobo: ASUS P8Z77-V LK OS: Windows 8 Pro x64

Haven't tried any stress load yet, played like 5 mins of assassins creed 3 and everything seems to run smooth. I'm worried that the fan control won't work correctly since the card isn't displaying temp. Any help is welcome
17 answers Last reply
More about temp displayed anywhere
  1. Make sure you have AMD's catalyst software and go to the vision control center. Under the graphics overdrive tab there should be a GPU temp and fan speed. You could also download speedfan to check the temp.
  2. Same as other programs shows 0 degrees Celsius
  3. Just tried Hwinfo and I think its working it says 31.0 C, going to see if it goes up or down.
  4. then use this to render the card so you will temp raise http://www.techpowerup.com/downloads/2198/TechPowerUp_GPU-Z_v0.6.7.html then press the ? mark on the bus interface to start the render
  5. The thing is that the fans on the card wont auto scale up when it needs too, I can only set it on manual. If I set the fans on auto it runs at 100% Don't know whats wrong
  6. where did you plug that gpu fan ?
  7. The card comes with an 8pin and a 6 pin they are both connected to the psu.
  8. for the card that ok but the fan on the card where it is plug to .
  9. The fans come preattached to the card, the only connectors it has is the power connectors. The fans do work fine I can scale them manually no problem. The real problem is that afterburner and amd catalyst are unable to read the GPU's temperature, meaning that the fan won't scale up or down when it should. I would have to do it manually, without knowing the real temp.
  10. in ccc under performance did you check the box to ajust manually the fan speed also check this in the afterburner,but there is some card that run at full speed on auto, ( the rev after the one i got was working at full speed )
  11. Yeah I been using it manually for now, but the thing is I'm afraid to play games since I cant tell the temp I dont know if I need to ramp up the fan :S I'm going to try removing the card and putting it on again .
  12. i use a desktop gadget that you could set a alarm on check this gpu monitor and it's free http://www.myfavoritegadgets.info/indexs.html#GPUMonitor
  13. I have the same with a new 7970. I tried various catalyst versions and even new windows install, no luck still 0 degrees and fans at 100% in auto mode. Gpu-z and afterburner also report gpu 0 celsius.
  14. then there is something with the gpu temp sensor lok it's time for rma .
  15. jgaf151, what was the outcome of this? I have two sapphire r9 280x's that do the same. they can't both be faulty, this is clearly software at fault.
  16. arkid77 said:
    jgaf151, what was the outcome of this? I have two sapphire r9 280x's that do the same. they can't both be faulty, this is clearly software at fault.


    I ended up exchanging it for a sapphire, because Newegg did not have a replacement available. The new one worked wonderfully, so in my case it was a malfunction on the card's sensor. my advice would be to exchange them if you can.
Ask a new question

Read More

Radeon GPUs Graphics