Sign in with
Sign up | Sign in
Your question

New ATI HD7870 freezes on boot

Last response: in Graphics & Displays
Share
February 15, 2013 7:16:47 PM

So I decided I needed a new graphics card since my old HD5850 just doesn't give me enough power for games. I decided to go with a gigabyte HD 7870 since it seemed like a good card. The problem is after swapping it out my computer freezes on boot. The first time I try booting it nothing happens the monitor and computer turn on but it just black screens and stays there. After powering it down and restarting it then it will display the first screen and freeze there (the screen that tells me what buttons to push to get bios or boot menu and such). At this screen it just freezes and I can't do anything, can't get into bios or boot menu. I sent it back for a replacement and the same thing happens with the new card so it has to be something else or very bad luck. If I put my old card in the computer starts fine.

windows 7-64bit OS
i7-860 cpu with a coolmaster evo cpu cooler
intel DP55wg motherboard
coolmax NW-650B powersupply
CORSAIR Vengeance 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory
Old graphics card is ATI HD 5850
New one that is not working gigabyte ATI HD 7870: -GV-R7870C-GD

My bios and drivers are up to date.
a c 259 U Graphics card
February 17, 2013 3:04:00 AM

Can you get into BIOS with the HD 7870?
m
0
l
February 17, 2013 3:40:24 AM

Nope I could not. the system locks up before i can do anything. Did all the driver removing stuff and I have all the power connecters hooked up. Still no go. I even reset my CMOS. I'm truly stumped. My roommate has a Sapphire HD 7870 card and I took it and put it in and my comp booted up with no problem. So for some reason the Gigabyte version of the card won't work on my comp and I have no clue why. I'm just giving up and sending it back. Going to try getting a Sapphire one since that seemed to work. Thanks for your help.
m
0
l
!