Sign in with
Sign up | Sign in
Your question
Closed

FIFA 13 Lagging/Stuttering

Last response: in Graphics & Displays
Share
February 17, 2013 6:09:51 AM

I just upgraded my computer's ram from 2gb to 6gb and also my OS to a 64 bit. Since then I am experiencing a lot of lagging and stuttering during game play. This was certainly not the case before the upgrade where I was able to get smooth game play with crysis 2, MW3, BF3, and also fifa 13. But since the upgrade the game play is absolutely terrible. Please guys help me its really annoying. I also unistalled and re-installed fifa 13, still no luck. Temperature of processor is around 50-60 degrees and the gpu's is about 40-50 degrees.

AMD Phenom X4 955 BE 3.2GHz
ASUS M4A88T-M LE
Sapphire ATI Radeon 6770 1GB GDDR5 (Catalyst 13.1)
6GB DDR3 (1x2GB + 1x4GB)
Windows 8 64 bit
February 17, 2013 6:46:26 AM

Since you mismatched the memory, they will run at lower speed (of the two) which can impact performance if it's too slow.
February 17, 2013 7:25:56 AM

EzioAs said:
Since you mismatched the memory, they will run at lower speed (of the two) which can impact performance if it's too slow.


Is there any way to resolve this issue, because I've seen many computers with mismatched memory and they are just as fine.
Related resources
February 17, 2013 7:37:22 AM

Either install the single 4GB DIMM or get a dual channel kit (ie. 2x4GB or 2x2GB 1600MHz).

Try the single 4GB first and see if that helps. Btw, what the memory specs (for both)?
February 17, 2013 8:16:13 AM

EzioAs said:
Either install the single 4GB DIMM or get a dual channel kit (ie. 2x4GB or 2x2GB 1600MHz).

Try the single 4GB first and see if that helps. Btw, what the memory specs (for both)?


Yup I'll try that in some time. Thanks bro. I'm kind of a newbie so I don't know how to find the memory specs for them. Is there any way to solve the issue without removing the ram and stuff?
February 17, 2013 8:22:16 AM

Look at the modules. They should have the specs there. Pulling out RAM is easy, just push the clips locking it and pull it out.
February 17, 2013 10:26:06 AM

EzioAs said:
Look at the modules. They should have the specs there. Pulling out RAM is easy, just push the clips locking it and pull it out.

Thanks man! I removed the 2GB ram and now i have just the one 4gb. The game is definitely playable but there is still some kind of disturbance. The framerate is pretty good just as before but there is still a bit of stuttering. Could you tell me the optimal settings for catalyst 13.1? Maybe that could be the problem cause I think I tweaked it a bit.
February 17, 2013 11:07:11 AM

Download CPU-Z and check DRAM Frequency under Memory. There's a chance you have a slow module that's bottlenecking the system.
February 17, 2013 11:56:14 AM

EzioAs said:
Download CPU-Z and check DRAM Frequency under Memory. There's a chance you have a slow module that's bottlenecking the system.

DRAM Frequency is around 666 MHz
February 17, 2013 12:06:10 PM

What AMD drivers were you using before? Try to uninstall the drivers and reinstall. I was maxing out FIFA13 on an old laptop with a C2D and 9800GS so your specs are strong enough. It's got to be a software issue.

Uninstall the display drivers through Control Panel, reboot, download CCleaner and clean out all the registry bugs, reboot, reinstall AMD drivers, reboot, and you should be good to go.
February 17, 2013 12:32:09 PM

Done all that. Currently running Catalyst 13.1. Previously I had 12.9, I reinstalled that but no difference. I'm back on 13.1. The game is distorted and stuttering. It seemed ok at first but after 30 to 45 mins (minutes in game) it starts to stutter.
February 17, 2013 12:32:15 PM

Done all that. Currently running Catalyst 13.1. Previously I had 12.9, I reinstalled that but no difference. I'm back on 13.1. The game is distorted and stuttering. It seemed ok at first but after 30 to 45 mins (minutes in game) it starts to stutter.
February 18, 2013 3:36:44 AM

stickg1 said:
What AMD drivers were you using before? Try to uninstall the drivers and reinstall. I was maxing out FIFA13 on an old laptop with a C2D and 9800GS so your specs are strong enough. It's got to be a software issue.

Uninstall the display drivers through Control Panel, reboot, download CCleaner and clean out all the registry bugs, reboot, reinstall AMD drivers, reboot, and you should be good to go.

Done all that. Currently running Catalyst 13.1. Previously I had 12.9, I reinstalled that but no difference. I'm back on 13.1. The game is distorted and stuttering. It seemed ok at first but after 30 to 45 mins (minutes in game) it starts to stutter.
February 18, 2013 3:54:45 AM

bakapen said:
Done all that. Currently running Catalyst 13.1. Previously I had 12.9, I reinstalled that but no difference. I'm back on 13.1. The game is distorted and stuttering. It seemed ok at first but after 30 to 45 mins (minutes in game) it starts to stutter.




I am having same issue....I had no problems running fifa 13 on my same pc and get 60 fps (windows 7 + ccc 12.8 or 12.10)
but then i installed windows 8 and ccc 13.1 and then reverted back to windows 7 + ccc 13.1 and i feel laggy after 2 minutes (20-30 minutes in game) but my fps are 60......i have also tried 12.10 but problem persists.... i dunno the reason

Plus I am playing offline and you???
February 18, 2013 6:41:59 AM

nathoka said:
I am having same issue....I had no problems running fifa 13 on my same pc and get 60 fps (windows 7 + ccc 12.8 or 12.10)
but then i installed windows 8 and ccc 13.1 and then reverted back to windows 7 + ccc 13.1 and i feel laggy after 2 minutes (20-30 minutes in game) but my fps are 60......i have also tried 12.10 but problem persists.... i dunno the reason

Plus I am playing offline and you???

I always play offline. It was really smooth just a couple of weeks ago but then I got a new 4GB ram, hence I did a clean install to Windows 8 64 bit and upgraded to catalyst 13.1 and since then, the game play is terrible. Btw, can you tell what are you're Game settings in fifa as well as your Catalyst 13.1 3d application settings?
February 18, 2013 6:58:53 AM

i am playing at 1600*900....with 4x in fifa config....disabled windows aero and vsync enabled gets me 60 fps....game starts fine but after 1-2 actual minutes(15-20 game minutes) game looks like lagging or slow motion although fps are 60.....i tried disabling vsync and gets me 180-220 fps but same problem....
February 18, 2013 7:44:58 AM

nathoka said:
i am playing at 1600*900....with 4x in fifa config....disabled windows aero and vsync enabled gets me 60 fps....game starts fine but after 1-2 actual minutes(15-20 game minutes) game looks like lagging or slow motion although fps are 60.....i tried disabling vsync and gets me 180-220 fps but same problem....

I'm guessing it could be a dust issue. I'll just clean up my computer and then see how it goes.
February 18, 2013 7:52:29 AM

no not a dust issue....because dust only rises temperature and mine and yours are absolutely fine....something other....because cod mw3 runs fine(or i am not feeling lag)
February 18, 2013 9:01:36 AM

nathoka said:
no not a dust issue....because dust only rises temperature and mine and yours are absolutely fine....something other....because cod mw3 runs fine(or i am not feeling lag)

yup, i was just playing black ops 2 and most wanted and they ran really well. i did not see any lag so far. must be some problem with fifa.
February 18, 2013 9:09:47 AM

i googled and came to know that ccc 13.1 has some microshuttering issue....some people suggested that downgrading ccc mostly leaves some traces of drivers...so they should be removed completely....we both had 13.1 and downgraded and both have same problems...so this issue must be with drivers.....

The only thing irritates me is that why microshuttering starts after 2-3 minutes of gameplay??????
February 18, 2013 9:39:10 AM

Coding of the game not agreeing with the drivers. You will need to go a full driver sweep. Then reinstall older drivers. I will try FIFA13 tonight after work to see if I have the issue as well.
February 18, 2013 10:07:17 AM

Try to patch Fifa to the latest version
February 18, 2013 11:06:52 AM

stickg1 said:
Coding of the game not agreeing with the drivers. You will need to go a full driver sweep. Then reinstall older drivers. I will try FIFA13 tonight after work to see if I have the issue as well.




if that is so then why game starts pretty well
February 18, 2013 1:07:50 PM

me and you both have tried going back to old(12.10 or 12.11)......so plz post here after you have clean installed



also upload your fraps file of fifa 13 and call of duty...
February 18, 2013 1:20:55 PM

nathoka said:
me and you both have tried going back to old(12.10 or 12.11)......so plz post here after you have clean installed

Will ccleaner do the job of removing all components of catalyst 13.1?.I'm currently downloading 12.11.

Best solution

February 18, 2013 1:32:29 PM
Share

I read on other forum

first unistall through control panel.....restart the PC, load on safe mode, use driver sweeper and clean the graphic driver (it support either ATI or Nvidia) and then load onto windows and install the new driver. this is the universal method !



and plz upload your fraps file for current laggy game...


and plus your game starts well??
February 18, 2013 3:48:55 PM

Plz post bakapen
February 19, 2013 2:04:45 AM

nathoka said:
Plz post bakapen

Sorry for the delay. I had internet problems. Ok, I unistalled 13.1 and everything related to ati or amd completely and installed 12.11. I'll post back soon after playing fifa.
February 19, 2013 2:41:59 AM

Ok guys, problem solved!! Just unistall all 13.1 drivers completely and remove every single component and restart your computer. Download catalyst 12.11 and play the game! As good as before! Catalyst default settings and fifa 13 settings are high, 2x, lock to 60fps, vsync enabled.
February 19, 2013 2:44:46 AM

Best answer selected by bakapen.
February 19, 2013 2:50:28 AM

bakapen said:
Ok guys, problem solved!! Just unistall all 13.1 drivers completely and remove every single component and restart your computer. Download catalyst 12.11 and play the game! As good as before! Catalyst default settings and fifa 13 settings are high, 2x, lock to 60fps, vsync enabled.




which method you used to unistall 13.1 completely...i am going to use the same...
February 19, 2013 3:01:58 AM

nathoka said:
which method you used to unistall 13.1 completely...i am going to use the same...

Run AMD Catalyst installed and choose uninstall. Then reboot when prompted.
Go to your c drive or wherever you installed the software and delete and ati or amd folder.
Go to device manager and under display adapters you should see a tab showing your graphic card. right click and choose uninstall.
Download this tool: treexy driver fusion: http://treexy.com/products/driver-fusion and remove your amd display adapter. (hit amd>analyse>delete)
Open ccleaner and fix your rgistry and run cleaner.
Restart computer.
Install 12.11 (i did it with .NET 4 support altough it shouldnt make a difference) http://www.anandtech.com/show/6497/amd-catalyst-1211-be...
and put catalyst settings to default and fifa setting are high, 2x, lock to 60fps, enbale vsync.
It sould work for you. Good luck.


March 24, 2013 8:53:40 PM

I'm getting stuttering/lag on FIFA 13 too. I recently upgraded to a 42-inch tv and it's very noticeable...thought it might be the tv, but I never noticed it on my 32-inch. I'm also running an ATI card (HD 7750)
!