Sign in with
Sign up | Sign in
Your question
Closed

How do I setup crossfire properly?

Last response: in Graphics & Displays
Share
February 17, 2013 9:21:20 PM

I have 2 msi radeon 7970 lightnings installed in my system (with the crossfire bridges and everything) and I would like to know how to get the latest drivers and set them up in a crossfire configuration.

feel free to ask me anything you need to answer the question.

thank you in advance :) 
February 17, 2013 9:25:03 PM

Forgot to mention there are multiple drivers on the amd websight not sure which one it would be if I just install it the same way I would any other driver :/ 
Score
0
Related resources
February 17, 2013 9:27:06 PM

this info is readily available by doing a google search or going to AMD's website support section, but here:
if you had a single card installed and you are adding a card you must uninstall old drivers and reboot first. you can then re-install the latest drivers and go into CCC and enable crossfire. you may need to reboot, but that's all there is to it really.
just make sure your motherboard has at least 2 x 8x pcie slots, crossfire works, but not well on a 16x/4x pcie setup. you will also want a high end i5/i7 cpu to feed them data.
Score
0
February 17, 2013 9:38:41 PM

this is my first build so there is no other existing graphics driver, i had gone and found the drivers for my model, but like i said there are multiple do i download all of them?
Score
0
February 17, 2013 9:48:39 PM

_computernewbie_ said:
this is my first build so there is no other existing graphics driver, i had gone and found the drivers for my model, but like i said there are multiple do i download all of them?

only download the latest catalyst control centre driver. Also download latest Crossfire Application Profiles, this will ensure the correct crossfire mode is used for a given application.
Score
0
February 17, 2013 10:02:13 PM

there is (catalyst software suit), (amd catalyst application profiles), and (latest BETA driver) so I download the beta driver, and the catalyst application profiles? did i get this right or is there something different? sorry i'm new at this and I don't want to mess up.
Score
0
February 17, 2013 10:07:05 PM

there is (catalyst software suit), (amd catalyst application profiles), and (latest BETA driver) so I download the beta driver, and the catalyst application profiles? did i get this right or is there something different? sorry i'm new at this and I don't want to mess up.
Score
0
February 17, 2013 11:35:41 PM

you can use the catalyst software suite, then update to the BETA driver if necessary. only use the beta driver if you have problems that it can fix. just start with the catalyst software suit and the application profiles. once installed you will have to enable crossfire in catalyst control centre.
Score
0
February 17, 2013 11:44:32 PM

ok i got the drivers, but now it gives me message that says:

"to run this application, you first must install one of the following versions of .NET Framework
v4.0
contact your application publisher for instructions about obtaining the appropriate versions of the .Net framework"


what do I do? how do I contact my "application publisher" ?

this is all vary confusing for me.
Score
0

Best solution

February 19, 2013 10:37:13 AM

Just let windows autoupdate do its thing.
Share
February 20, 2013 2:09:51 AM

Best answer selected by _computernewbie_.
Score
0
!