Sign in with
Sign up | Sign in
Your question
Closed

Router working wirelessly but not wired

Last response: in Networking
Share
March 25, 2012 8:44:43 AM

I have a Dlink dir-600 router I flashed it with dd-wrt it was was working good but I started experiencing some problems so I decided to flash it with the stock firmware and I did so later on after a week the Ethernet ports on the router stopped working I thought the router was bricked but I was able to connect wirelessly and could access the Internet and I was even able to change the settings of the router by going to 192.168.0.1 all was fine but all the ethernet ports stopped working so I thought it was the problem of the stock frimware and I again flashed it with dd-wrt but still all the Ethernet ports won't work I can only connect the computers wirelessly someone please help me out.
March 25, 2012 1:28:50 PM



Was the ethernet port on your PC working properly before or could it be your BIOS has an "either or" setting for WLAN and LAN? Have a look in BIOS in case it has and if so, alter it to Both. Also, while you're in there, check that the NIC is enabled in BIOS then if that doesn't work, check it in Device Manager to see if it has a driver issue.

Score
0
March 26, 2012 1:14:29 PM

NO it's not a problem of my computer it's working fine I am currently using another router and it works fine I tried plugging the Internet cable directy into my comp and it works so it's not a problem caused by my computer
Score
0
Related resources
March 26, 2012 1:40:17 PM

Can you try writing in complete sentences to make it easier to understand so more can help you?

Verify the IP address you are getting on your wireless is actually a 192.168.x.x number. If it isn't, then your ISP has locked the MAC address on your computer.

What IP address do you get when you plug into the ethernet port on your computer?
Score
0
March 27, 2012 5:27:05 PM

riser said:
Can you try writing in complete sentences to make it easier to understand so more can help you?

Verify the IP address you are getting on your wireless is actually a 192.168.x.x number. If it isn't, then your ISP has locked the MAC address on your computer.

What IP address do you get when you plug into the ethernet port on your computer?


Its not the internet connection,i cant even ping to the router from my computer which is connected to the Ethernet port on the router but if i try connecting to the router wirelessly then i am able to access the the router the Ethernet ports on the router doesn't seem to be working.
Score
0
March 29, 2012 2:04:51 PM

I'm guessing the firmware switches killed the ports, or the hardware for them just failed. Nothing you can do here unless there is a newer version of the firmware you can try.

Usually the wireless dies on routers, first time I've seen wireless work but the LAN ports die.
Score
0
March 30, 2012 4:13:42 PM

hang-the-9 said:
I'm guessing the firmware switches killed the ports, or the hardware for them just failed. Nothing you can do here unless there is a newer version of the firmware you can try.

Usually the wireless dies on routers, first time I've seen wireless work but the LAN ports die.

so there is no way i can fix it now do you want to me try out a stable build of dd-wrt frimware?how do i know if it is a hardware related problem or a software related one?
Score
0
March 30, 2012 4:16:21 PM

I'd try the original firmware. With this type of equipment, it's pretty hard to tell what is failing, especially with the hacking you did with the device.

Are you getting any lights on the router or network card with the ports?

The issue is that if re-loading the operating system on the router did not help anything, not much to be done unless you send it to the factory to have them test it.
Score
0
April 4, 2013 3:49:23 PM

clever_noob said:
I have a Dlink dir-600 router I flashed it with dd-wrt it was was working good but I started experiencing some problems so I decided to flash it with the stock firmware and I did so later on after a week the Ethernet ports on the router stopped working I thought the router was bricked but I was able to connect wirelessly and could access the Internet and I was even able to change the settings of the router by going to 192.168.0.1 all was fine but all the ethernet ports stopped working so I thought it was the problem of the stock frimware and I again flashed it with dd-wrt but still all the Ethernet ports won't work I can only connect the computers wirelessly someone please help me out.


clever_noob said:
NO it's not a problem of my computer it's working fine I am currently using another router and it works fine I tried plugging the Internet cable directy into my comp and it works so it's not a problem caused by my computer


Hi Clever,

Is your problem solved or not?
I have the same problem but with my trendnet TEW-634GRU router. It is working wireless but when I plug a wire in the lan port on it it even kills the wireless connection? Is there any fix to it or the router is broken?
Score
0
April 4, 2013 10:42:36 PM

If you're sure the port you're using is actually a LAN port and not an uplink port, the router must be broken. If the answers in this year-old thread can't help, please start a new one.
Score
0
!