Sign in with
Sign up | Sign in
Your question

[Graphics Card] GTX 660 ti AsRock Pro3 Gen3 Compatibility issue

Last response: in Graphics & Displays
Share
February 19, 2013 3:28:58 PM

Just got my new gtx 660ti ftw today and i have a compatibility issue with my asrock z68 pro3 gen3 Plug the card in, boot and nothing shows in the screen and it keeps in stand by. I already try updatin BIOS and nothing Can you help me?? THX! :(  :(  :( 
my specs:


AsRock Z68 Pro3 Gen3
Core i7 3770K 3.5 Ghz
Corsair Vengeance 16gb 20133 MHZ
Evga GTX 660 ti FTW edition
a b U Graphics card
February 19, 2013 4:00:37 PM

how did you update bios with nothing showing on the screen?
double check your connections..you have missed something
m
0
l
a b U Graphics card
February 19, 2013 4:01:56 PM

willox said:
Just got my new gtx 660ti ftw today and i have a compatibility issue with my asrock z68 pro3 gen3 Plug the card in, boot and nothing shows in the screen and it keeps in stand by. I already try updatin BIOS and nothing Can you help me?? THX! :(  :(  :( 
my specs:


AsRock Z68 Pro3 Gen3
Core i7 3770K 3.5 Ghz
Corsair Vengeance 16gb 20133 MHZ
Evga GTX 660 ti FTW edition



2 questions, what kind of PSU do you have (make, model, wattage) and do you have the power cables plugged into the video card itself?
m
0
l
Related resources
February 19, 2013 4:05:12 PM

i did it just before plug the new gtx. i have another gtx 550ti wich is works fine and i already check, everything seems ok
m
0
l
February 19, 2013 4:07:44 PM

bdiddytampa said:
2 questions, what kind of PSU do you have (make, model, wattage) and do you have the power cables plugged into the video card itself?

Corsair TX750M yes it have, 2 6pin pci conectors
m
0
l
February 19, 2013 4:07:57 PM

bdiddytampa said:
2 questions, what kind of PSU do you have (make, model, wattage) and do you have the power cables plugged into the video card itself?

Corsair TX750M yes it have, 2 6pin pci conectors
m
0
l
a b U Graphics card
February 19, 2013 4:12:59 PM

do you get the post screen when you boot?
m
0
l
February 19, 2013 4:17:07 PM

bdiddytampa said:
do you get the post screen when you boot?

Nah, nothing. Boot up but nothing shows in the screen. i try the card in a friends mobo (foxconn, amd phenom 6) and it woked fine
m
0
l
!