Sign in with
Sign up | Sign in
Your question

Crysis 2 FPS with GTX 570 SLI

Last response: in Graphics & Displays
Share
February 19, 2013 5:08:14 PM

I was wondering if this was normal at all, but it looks like that when I play Crysis 2 Maxed out with both DX11 and Hi-RES texture packs, the game keep skipping from 60 fps to precisely 40. Whitout a reason appearently, even when I stop and look in the same direction for a while.
Any ideas?

My rig components are:
Palit GTX 570x2 SLI
Intel i5-3570k 3.40 Ghz
Corsair Vengeance 6gb Ram
Windows 7 64bit

Thanks in advance

More about : crysis fps gtx 570 sli

February 19, 2013 5:32:58 PM

Is Vsync enabled? (60->40 FPS implies a 120Hz monitor with Vsync) High-res texture packs can eat up your VRAM pretty quickly and can significantly affect your FPS.
Related resources
February 19, 2013 5:48:53 PM

Ensure that:

a)v-sync is DISABLED in crysis settings
b)adaptive v-sync is enabled in Nvidia control panel for all applications.

See if that helps.
February 19, 2013 7:09:05 PM

Try turning your graphics down with Vsync on and see if it'll go to 120fps, because 40fps is impossible with 60Hz Vsync (double buffered).
!