HELP!!!!! HD 7870 Ghz Edition Might be Dead

Hey All,

I have been experiencing some issues with some of my games. I recently built my first PC and I have had some weird issues with it. The most concerning of those issues is that my computer does not seem to be handling certain games adequately. (I'll be posting tech specs at the bottom of this post.) To sum up my issues: Borderlands 1 crashes religiously after 45 min to an hour of game play, while Total War: Shogun 2 is completely unplayable. I cannot even go into settings to change features because when I go into the settings menu all the words are missing displaying only a few letters, the apply button and the gamma/brightness buttons. The cut-scenes in Shogun 2 also play awkwardly. They start normal, but as soon as the narrator begins talking the whole scene gets really laggy/choppy. My computer seems capable enough to handle the Star Wars: The Old Republic MMO without any issues as well as Far Cry 3 with High settings but no AA, AF or VSync. I don't know what the cause could be, I am thinking it is a bad GPU but I don't know how to confirm my suspicions any advice would be greatly appreciated.


My Specs:

MoBo: AsRock Z75 Pro 3
CPU: Core i3 3220
RAM: 8GB of DDR3 @ 1866
GPU: Radeon HD 7870 GHz Edition


Thanks In Advance for your Time

P.S. I have a 27" 1920*1200 resolution monitor connected through a DVI cable, plugged into the GPU.(Not sure if that matters)
3 answers Last reply
More about help 7870 edition dead
  1. First, use an i7 processor instead. A dual core processor does not have the capability to handle what you are trying to do. There is not enough processor space, and cache memory to get good graphics quality.
    You NEED at least a quad core processor, to get good gaming and graphics quality.
    Second, A big fat cooler on the CPU, you need lots of air and ventilation.
    Then, set a power profile:
    Windows contains a number of (very irritating) "Automatic Features" that are supposed to "Save Power"
    A. When these features are enabled, it causes a bunch of problems.
    B. Windows shuts down your system to sleep, hibernate, standby, etc..etc...
    C. After shutting down system to "save power" the system malfunctions when you try to wake it up again...and locks up, freezes, etc...
    It locks the mouse, it locks the keyboard, it shuts off the display, and locks out the hard drive, it shuts off USB devices, etc...etc...
    D. This will cause you to pull your hair out, and go to the funny farm...(those nice young men in their pretty white coats)
    E. Make it stop, please make it stop.
    F. Shut off all these (very irritating) "features" and USE your computer (for a change):

    Click Start, Click Control Panel, Click ( in power options) Choose a Power Plan
    Check the Box that says "high performance"
    Click "change plan settings"
    Turn off display: set to NEVER
    Put the computer to sleep: set to NEVER
    Click: Change advanced plan settings
    Select "high performance" from the drop down menu
    Scroll down the list: Click on the + signs to expand the choices for each item on the list.
    Require a password on wake up: set to NO
    Hard disk: turn off the hard disk: set to NEVER
    Wireless adapter settings:
    Sleep: set to NEVER
    Allow Hybrid sleep: set to NEVER
    Hibernate after: set to NEVER
    Allow wake timers: set to disable
    USB settings:
    USB selective suspend setting: set to NEVER
    Power Buttons and lid:
    Power button action: Setting: set to shut down
    Sleep Button Action: set to: do nothing
    PCI Express:
    Link State Power Management, Setting: OFF
    Processor Power Management:
    System Cooling Policy: setting: Active
    Display
    Turn off display after: setting: NEVER
    Multimedia Settings:
    When Sharing Media: Setting: Prevent idling to sleep
    When Playing Video: Setting: Optimize Video
    Click APPLY
    Click OK

    Go into the power profiles,
    set standby, hibernate and sleep to OFF
    leave the monitor standby ON, that's OK (maybe not, try OFF)
    Set the Hard Drive standby to NEVER
    Set system Performance to MAXIMUM, not "quiet mode."

    Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
    If there is a power saver or a "quiet mode" in the bios, shut it off...
    There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
    in the bios, see that the allocation for video, if available, is maxed.

    Now open the hardware manager profiles...
    click start
    click computer
    click system properties
    click device manager
    double click on mice and other pointing devices
    right click on HID compliant mouse
    left click on properties
    click on the power management tab
    UN-check the box that says: "allow the computer to turn off this device to save power." (there is now NO check mark in this box)
    click OK

    Now repeat this procedure for all mice, monitors, keyboards, and ALL USB ports on the device manager list.

    You must open ALL the devices one at a time, as above, and turn off the power saver, for each device.
  2. I have already set a power profile similar to the one you posted, I'll make changes where needed. I was not aware of the BIOS settings you mentioned so I'll definitely look into those. I am, however more concerned with the fact that my games are not working properly. If the processor is the issue then why can I run Far Cry 3 without a hiccup. While I do agree a better processor would help, I don't think it is the root cause of my issue.
  3. psu ????
Ask a new question

Read More

Radeon Graphics Product