Closed Solved

GTX 470 Drivers Fail

Hey community,
Well last night i tried updating to latest 314.07 Drivers and it failed, thought nothing of it turned off my pc went to bed, next morning i turn on and Computer wont pick up the GPU, but it still shows display but at low resolution.
Things iv tried:
Uninstall / Reinstall / restarting
Driver Sweeper on nvidia drivers, restarted in safemode ran sweep again,turned off kaspersky ,reinstalled same error.(also did this trying to install the drivers i had previously,but same error)
Reset mobo settings.

strange now that i run CPU-Z it reads my GPU.
Maybe putting it in a different pcie spot?
BTW, fans on it spin

Computer Specs
http://valid.canardpc.com/2700498
13 answers Last reply Best Answer
More about drivers fail
  1. You can give it a shot in a different pci-e slot however that is very odd that it would fail on you. Do you have anything running in the background that would think it was a hostile program?
  2. Not that i know of, heres a screen of my processes. I will try a different slot but untill then im taking and trying all recommendations, thank you all!


  3. Is it possibly a windows 8 issue that looks like a windows 8 task manager?
  4. bigshootr8 said:
    Is it possibly a windows 8 issue that looks like a windows 8 task manager?


    yeah its running windows 8, but thats the thing i had the previous drivers installed working perfectly, and new drivers fail to install and all the problems begun. Maybe its the new drivers messed up something with windows 8? If this were the case i would expect the same issue with tons of more people
  5. Also, is it possible my GPU is just dying? Im still using my computer with the 470 attatched and have video coming out from it, its just like it doesnt get picked up by anything on my computer.
  6. If not report the last file that loads at the bottom of the screen before it stops.


    Well i tried my other PCIE slot with no success, it hangs at the load spot for about 5 minutes then gives me an error

    http://i25.photobucket.com/albums/c79/blinkrawks/1-1_zps7105ac73.jpg
    http://i25.photobucket.com/albums/c79/blinkrawks/2-1_zpsd565a6b7.jpg
  7. Hmm, that is very odd well judging by your pictures you are looking to install a older driver. Have you installed the newest driver 314.07 - WHQL
    http://www.geforce.com/drivers/results/57096
  8. bigshootr8 said:
    Hmm, that is very odd well judging by your pictures you are looking to install a older driver. Have you installed the newest driver 314.07 - WHQL
    http://www.geforce.com/drivers/results/57096


    ive tried with several drivers, including the newest and last one known to work with my GPU
  9. not to kill your hope or anything but nvidia does kill videocards through driver updates. a lot of old 8800s got driver-murdered when the 200s came about, i remember a barrage of threads reporting broken cards after a driver update.

    let's just hope it's a windows 8 issue and you get a fix quite soon.
  10. wh3resmycar said:
    not to kill your hope or anything but nvidia does kill videocards through driver updates. a lot of old 8800s got driver-murdered when the 200s came about, i remember a barrage of threads reporting broken cards after a driver update.

    let's just hope it's a windows 8 issue and you get a fix quite soon.



    aww, wow thats terrible ..oh well..i guess it was time for an upgrade anyway
  11. I don't recall there being a on-pour of broken cards when the 200 series cards came out. I just think its a windows 8 thing perhaps there have been threads throughout the forums with people with issues with windows 8 drivers with there cards.
  12. Best answer
    I'm having the same issues with windows 8 and my 2x 470gtx cards.... I've swapped them out put one in at a time... still windows doesn't recognize them....

    The other day I found a post on Microsoft community.... to try to run the driver in compatibility mode.... which seemed to work for this person 460.... however I tried the same thing with now luck.... thoughts?

    http://answers.microsoft.com/en-us/windows/forum/windows_8-system/windows-8-video-hardware-error/a4c729ee-efd7-42a2-a088-97fccfc171e6

    Its a win8 issue I just grabbed a new mobo and these worked fine with win7 with no issues and they work fine in my older comp....
  13. Best answer selected by feebeeteemoff.
Ask a new question

Read More

Graphics Cards Drivers Graphics