Sign in with
Sign up | Sign in
Your question
Closed

GTX 470 Drivers Fail

Last response: in Graphics & Displays
Share
February 19, 2013 10:35:38 PM

Hey community,
Well last night i tried updating to latest 314.07 Drivers and it failed, thought nothing of it turned off my pc went to bed, next morning i turn on and Computer wont pick up the GPU, but it still shows display but at low resolution.
Things iv tried:
Uninstall / Reinstall / restarting
Driver Sweeper on nvidia drivers, restarted in safemode ran sweep again,turned off kaspersky ,reinstalled same error.(also did this trying to install the drivers i had previously,but same error)
Reset mobo settings.

strange now that i run CPU-Z it reads my GPU.
Maybe putting it in a different pcie spot?
BTW, fans on it spin

Computer Specs
http://valid.canardpc.com/2700498

More about : gtx 470 drivers fail

a c 133 U Graphics card
February 19, 2013 10:37:55 PM

You can give it a shot in a different pci-e slot however that is very odd that it would fail on you. Do you have anything running in the background that would think it was a hostile program?
Score
0
February 19, 2013 10:47:52 PM

Not that i know of, heres a screen of my processes. I will try a different slot but untill then im taking and trying all recommendations, thank you all!


Score
0
Related resources
a c 133 U Graphics card
February 19, 2013 11:42:45 PM

Is it possibly a windows 8 issue that looks like a windows 8 task manager?
Score
0
February 20, 2013 12:26:51 AM

bigshootr8 said:
Is it possibly a windows 8 issue that looks like a windows 8 task manager?


yeah its running windows 8, but thats the thing i had the previous drivers installed working perfectly, and new drivers fail to install and all the problems begun. Maybe its the new drivers messed up something with windows 8? If this were the case i would expect the same issue with tons of more people
Score
0
February 20, 2013 12:28:15 AM

Also, is it possible my GPU is just dying? Im still using my computer with the 470 attatched and have video coming out from it, its just like it doesnt get picked up by anything on my computer.
Score
0
February 20, 2013 9:34:25 AM

bigshootr8 said:
Hmm, that is very odd well judging by your pictures you are looking to install a older driver. Have you installed the newest driver 314.07 - WHQL
http://www.geforce.com/drivers/results/57096


ive tried with several drivers, including the newest and last one known to work with my GPU
Score
0
a b U Graphics card
February 20, 2013 2:18:09 PM

not to kill your hope or anything but nvidia does kill videocards through driver updates. a lot of old 8800s got driver-murdered when the 200s came about, i remember a barrage of threads reporting broken cards after a driver update.

let's just hope it's a windows 8 issue and you get a fix quite soon.
Score
0
February 20, 2013 6:21:29 PM

wh3resmycar said:
not to kill your hope or anything but nvidia does kill videocards through driver updates. a lot of old 8800s got driver-murdered when the 200s came about, i remember a barrage of threads reporting broken cards after a driver update.

let's just hope it's a windows 8 issue and you get a fix quite soon.




aww, wow thats terrible ..oh well..i guess it was time for an upgrade anyway
Score
0
a c 133 U Graphics card
February 20, 2013 6:49:48 PM

I don't recall there being a on-pour of broken cards when the 200 series cards came out. I just think its a windows 8 thing perhaps there have been threads throughout the forums with people with issues with windows 8 drivers with there cards.
Score
0

Best solution

March 1, 2013 3:40:48 PM

I'm having the same issues with windows 8 and my 2x 470gtx cards.... I've swapped them out put one in at a time... still windows doesn't recognize them....

The other day I found a post on Microsoft community.... to try to run the driver in compatibility mode.... which seemed to work for this person 460.... however I tried the same thing with now luck.... thoughts?

http://answers.microsoft.com/en-us/windows/forum/window...

Its a win8 issue I just grabbed a new mobo and these worked fine with win7 with no issues and they work fine in my older comp....

Share
March 8, 2013 1:05:57 AM

Best answer selected by feebeeteemoff.
Score
0
!