Sign in with
Sign up | Sign in
Your question

AMDCard installs as Standard VGA Adapter 64bit

Last response: in Graphics & Displays
Share
February 20, 2013 6:33:38 AM

AMD Driver failed to install, using VGA standard display driver.

I have tried to uninstall everything that has anything to do with AMD/ATI. I mean deleting folders, going in to "regedit", Ccleaner, control panel etc. (I have tried installing the latest AMD driver for 64-bit users.)

I have rebooted PC after every uninstall/install. But nothing seems to be helping.
When I'm visiting the "dxdiag"
under the tab "Display" it says that I have the Standard VGA Graphic Adapter.

I have also tried downloading Windows Updates but nothing seems to work.

I'm using Windows 7 (64 bit) as OS.
AMD Radeon 5770 HD Series
February 20, 2013 7:06:56 AM

It didn't help, it still says VGA standard graphic driver. :-/
Related resources
February 20, 2013 7:28:22 AM

You have to manually update the drivers, using Device Manager => Update drivers.

When you tried to install the drivers, the drivers file is expanded to C:\AMD\Support\...., C: being your system drive.

When you use Device Manager to update drivers, please choose "Let me choose the drivers" option and show the path to the drivers file, usually C:\AMD\Support\....\Packages\Drivers\Display\. Please check include subfolders option, too.
February 20, 2013 7:38:26 AM

suat said:
You have to manually update the drivers, using Device Manager => Update drivers.

When you tried to install the drivers, the drivers file is expanded to C:\AMD\Support\...., C: being your system drive.

When you use Device Manager to update drivers, please choose "Let me choose the drivers" option and show the path to the drivers file, usually C:\AMD\Support\....\Packages\Drivers\Display\. Please check include subfolders option, too.


Thank you kind sir, this helped! :)  I'm eternaly grateful really.
!