Eye stressing Shuttering while gaming [EXTREME IRRITATION]

HI GUYS, am facing an extremely irritating problem while playing few games like FARCRY3, RAGE etc. I get 40+fps on ultra setting which is good, but it is still stressing my eyes very badly. Every time with every movement of the player in the game the surrounding and the enviorment gets kinda blur and kinda flickers and i just cant focus on any thing ,dunno how to really put it in words but in short it is very irritating despite having 30-40+fps.

But with games like COD:black opps 1&2 hitman absolution etc i face no such problem even if it happens it happens at very minimum level and which is barley noticeble and work fine.

First i thought there was some thing wrong with my eyes or my glasses lol even got them checked sounds crazy i know hahahah......., but still no success:( .I tried few 3rd party software lile Dxtory and Readon Pro to cap the fps at 30, 35, 40 but still it is not helping me. Even changed the mouse dpi (mental satisfaction) Even tested games from low to high setting still no success. Updated the graphics driver still :( . Now am running out of ideas of possible solutions to this problem please help mw out.

What am i suppose to do

Should i update the mobo bios or graphic card vbios or is there any hardware problem in my pc?

System Rig:
AMD FX8120
Ati radeon hd 6870
4gbx2 corsair vengeance
500gbx2 HDD
Asus M5a97 EVO (Current bios 0902)

Really need ya help guys.
5 answers Last reply Best Answer
More about stressing shuttering gaming extreme irritation
  1. Best answer
    There are a few things, but I would just get rid of the Asus motherboard entirely.
    Run through the checklist, and set a new power profile:
    Windows contains a number of (very irritating) "Automatic Features" that are supposed to "Save Power"
    A. When these features are enabled, it causes a bunch of problems.
    B. Windows shuts down your system to sleep, hibernate, standby, etc..etc...
    C. After shutting down system to "save power" the system malfunctions when you try to wake it up again...and locks up, freezes, etc...
    It locks the mouse, it locks the keyboard, it shuts off the display, and locks out the hard drive, it shuts off USB devices, etc...etc...
    D. This will cause you to pull your hair out, and go to the funny farm...(those nice young men in their pretty white coats)
    E. Make it stop, please make it stop.
    F. Shut off all these (very irritating) "features" and USE your computer (for a change):

    Click Start, Click Control Panel, Click ( in power options) Choose a Power Plan
    Check the Box that says "high performance"
    Click "change plan settings"
    Turn off display: set to NEVER
    Put the computer to sleep: set to NEVER
    Click: Change advanced plan settings
    Select "high performance" from the drop down menu
    Scroll down the list: Click on the + signs to expand the choices for each item on the list.
    Require a password on wake up: set to NO
    Hard disk: turn off the hard disk: set to NEVER
    Wireless adapter settings:
    Sleep: set to NEVER
    Allow Hybrid sleep: set to NEVER
    Hibernate after: set to NEVER
    Allow wake timers: set to disable
    USB settings:
    USB selective suspend setting: set to NEVER
    Power Buttons and lid:
    Power button action: Setting: set to shut down
    Sleep Button Action: set to: do nothing
    PCI Express:
    Link State Power Management, Setting: OFF
    Processor Power Management:
    System Cooling Policy: setting: Active
    Turn off display after: setting: NEVER
    Multimedia Settings:
    When Sharing Media: Setting: Prevent idling to sleep
    When Playing Video: Setting: Optimize Video
    Click APPLY
    Click OK

    Go into the power profiles,
    set standby, hibernate and sleep to OFF
    leave the monitor standby ON, that's OK (maybe not, try OFF)
    Set the Hard Drive standby to NEVER
    Set system Performance to MAXIMUM, not "quiet mode."

    Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
    If there is a power saver or a "quiet mode" in the bios, shut it off...
    There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
    in the bios, see that the allocation for video, if available, is maxed.

    Now open the hardware manager profiles...
    click start
    click computer
    click system properties
    click device manager
    double click on mice and other pointing devices
    right click on HID compliant mouse
    left click on properties
    click on the power management tab
    UN-check the box that says: "allow the computer to turn off this device to save power." (there is now NO check mark in this box)
    click OK

    Now repeat this procedure for all mice, monitors, keyboards, and ALL USB ports on the device manager list.

    You must open ALL the devices one at a time, as above, and turn off the power saver, for each device.
  2. ok, not sure about all that. ^

    Is there a setting for motion blur in those 2 games? I know Crysis 2 had it and it was insufferable. If so, stop that.
  3. I am sure about that.
    EVO motherboard causes major headaches.
    "EVO" design was supposed to "save power." But what happens is that it starves the CPU and other components for energy, rendering them 1/2 useable.
    I had one, and had nothing but problems, till I changed to another motherboard.
    Now I am using Gigabyte. No more problems, 100% usable, everyday without fail.
  4. Changing windows power plan did not help me much in a noticeable way. Tonight i will change the bios setting as you said and am feeling good bout it hope it works. But never thought asus m5a97 evo could be a troublemaker despite positive reviews.

    Tnx for giving buch of ideas :)
  5. Best answer selected by i-blaze.
Ask a new question

Read More

Radeon Graphics